Help - Search - Members - Calendar
Full Version: zradio - works, but
OESF Forums > General Forums > General Support and Discussion > Software
Anonymous
I installed zradio on my 5600. I really enjoy listening to these shoutcast stations anywhere in the house. Indeed, it was one of the reasons I bought the Zaurus in the first place.

Anyway, the test version worked with some problems, so I paid 10 bucks at Handango for the official version. Seems to be the very same software, with the same problems. And email to "support" goes unanswered.

The main problem is in adding new stations. It doesn't work, and I have to edit the XML configuration file everytime I want to change the stations.

Also, weirdly, the volume and station sliders show the digit "6" every time the digit "5" is supposed to show.

I suspect these are 5600 problems, and that it works on the 5500.

Anyone using this (otherwise very good) program?
RichS
I have zradio installed on my 5600 on an sd card. I had no problem adding stations. They add to the end of the list (on the slider/tuner). The only problem I did have with it was using the "S" button. It's an "M" on my Z. Click on the "M", then click on the memory-preset and it saves the current station into the preset.
It 'works' for me, but on my dial-up line it's a bit difficult to stream anything...
I have the standard Sharp roms, ver 1.32 on mine...
Anonymous
This is weird, becaue I have the same setup (5600, 1.32 ROM, SD card).

What is the version of your ipk file?

Thanks!
RichS
I have zradio_1.2b_arm.ipk, probably from killefiz.de. I don't remember any problems with it at all. Mostly because of all the problems I had trying to get tkcradio to work...
sstepak
I'm looking for a steaming media player on my sl-5500 (v3 rom) without going open zaurus just yet. Is zradio limited to a handful of stations? Can I pick up stations that don't have zradio links?
RichS
I don't know what the limit is, or if there is one? There are 10 or so preset button, then a slider that works someehting like a radio dial. Well back in the old days when radios had dials... Mine has 50 or so now I think. Stations are added from a seperate window. You must know the 'station' IP address and port number. And the station MUST be Shoutcast! It doesn't work with any other format. From what I've seen, this is the greatest drawback as there doesn't seem to be many Shoutcast broadcasts...
hughesr
zRadio is a bit cumbersome in general, and I was enjoying the same problems you were. A great deal of the stations do not reply back to the Zaurus when you click play. If you do find one that works on your PC click add first, delete the default port 8000, and enter in the correct url & port. Click "play" Then go back to the menu and you should see it in your list. If you do, click "close" that will save it. I have never gotten a reply back from the zRadio tech support to date, and I paid the $10 as well.
Anonymous
In general, I found that whenever a station does not respond to zradio, it doesn't respond in the PC as well. So it's not zradio's fault. At times, the shoutcast file has multiple IP entries, and one works while the other doesn't, so copy over to the zaurus the one that works.

But I am still perplexed that after re-installing multiple times, I still have the two problems that I mentioned in the first message of this thread (repeated below). Any ideas would be appreciated.

===
zradio version 1.2b, ROM is 1.32, and the installation is to SD.

The main problem is in adding new stations. It doesn't work, and I have to edit the XML configuration file everytime I want to change the stations.

Also, weirdly, the volume and station sliders show the digit "6" every time the digit "5" is supposed to show.

===
RichS
Well "Guest", since it seems to work for the rest of us and not you, I'll offer a note.

First, yes the volume does read 6 when it should read 5. A nasty bug that should never have gotten through on a $10 program...

As for adding new stations, this is the procedure that works for me.

Hold the stylus on the screen until the "Radio play list" shows. Slide the stylus onto that to see the playlist. In the top section, just under "Radio addres", enter the new stations IP address and port such as: 208.16.194.24:8000
Do NOT enter "http://" before the IP address, and NO spaces either.
Then hit the 'add' button.

From what I can see, zradio has to be able to actually connect to the station or it will not add it to the list. You will not see the IP address added to the list. It gets the name of the station, enters that into the list and re-sorts the list. If you see the name listed and click on the "+", it will expand showing the IP and port. But this will NOT work unless zradion can talk to the station when you hit the add button.

You may already know all this, but that's the procedure and it works for me, so there's nothing else I can add to it. We both have the same Z, same ROM and installed on SD card. If the above doesn't work for you, then maybe there's something wrong with permissions?
Anonymous
Last night I reformatted the internal flash and reinstalled everything (not that much work, only 1-2 hours). A couple of bugs (including zradio not adding stations) have disappeared. I certainly spent a lot more than this on these bugs :-(

I suspect it was indeed a matter of permissions, but everything looked OK.

Many thanks for your comments!
arnoldmm
I paid for zradio and tried to install it on my SL-5500 with Open Zaurus 3.3.5.
It doesn't install and Package Manager complains:

Package zradio has no Architecture defined

Has anyone installed this with Open Zaurus? I convinced my girlf friend to buy an SL-5600 smile.gif and I installed it there with no problems on the default Sharp ROM.

BTW I think it's incredibly bad form for this guy to charge for software he no longer supports. If he no longer wants to support it after a couple of years, which I can understand, he should pass it on (or sell it) to someone else or give it away free.

I am going to let Handago know that he no longer supports the software.
RichS
Sorry I can't help with the OpenZaurus problem.

But thanks for letting us know about the support problem. Since I couldn't get tkcRadio demo installed & working, I was going to pay the price for zradio. But if it's a dead issue, I'll skip it and try to get some response out of tck...

As I said, I know nothing of OZ, but did you give the command line ipkg install a try? I had to use that for quite a few packages with the Sharp rom 1.32...
RadioRental
as an aside for PC users looking for shoutcast stations. I use winamp 2.91 (downloadable off various sites other than winamp who would prefer you to use later bloated versions). It catches about 500 stations, right click on the winamp skin to get the station details. I use the demo zRadio and just edit the xml file myself.
I'm sure there are other ways of finding out station IPs but winamp 2.91 is a nice to have.

Also, another aside but related. I save streams using a PC app called streambox vcr (again, search the web for this one cos Realmedia got the software banned!) then I copy the .mp3 streams to my Z and play radio on the the go. As far as I'm aware this is legal and 100% free mp3 downloads.

having fun
RadioRental
Streambox: http://www.dawnload.net/audio_software/aud...reambox_vcr.cfm
I guess its illegal if your a US user (o;
Winamp 2.91 (I checked this download myself and its 100% ok) http://fantom-xp.h10.ru/winamp_2.html
arnoldmm
Thaks for the links, I'll check them out. I wrote an application for myself on Windows that plays shoutcast streams and can also save them as MP3 files, started with WIN32 API and then used Borland C++ Builder. I used a library called FMOD and also LameEnc for encoding, I would like to port it to Zaurus, FMOD works on Linux but not Zaurus. I don't use a lot of the FMOD functions so that should not be a problem. I don't have any idea how difficult it would be as I have not yet installed a Zaurus development environment or tried to do anything with it.
xamindar
I'd just like to share my little input on zradio. I have had two problems with it and after fixing those, the program seems to work quite well.

1. I had the problem of it not saving the stations I have added to the play list. Like it was mentioned above, just fix the permissions on the xml file so that zradio has permission to write to it.

2. After many frustrating attempts at adding the japan-a-radio stream to the list and having it fail to load the list the next time I ran zradio (the playlist would be blank), I finally figured out that certain characters can not be read by zradio.

For example, the japan-a-radio stream had the '&' in the station name and once I removed that from the xml playlist file (just replaced it with 'and') zradio would load up just fine with all the stations I had added.
Strange little bug huh.

i hope this helps someone.
aig
arnoldmm,

I installed zradio 1.2b on my SL-5000D today under OZ 3.3.6pre-1. It is perfectly capable of functioning and does quite well under OZ. To get around the Architecture issue, just uncompress the ipk file and extract the data.tar.gz file. I did this using WinRAR and copied it over to my z to the root directory.

Then at the console type:
tar xzvf data.tar.gz

and it will put everything where it needs to go.
Restart OPIE.

Grab the oz-compat libs and install them from:
http://www.mithis.com/zaurus/ipkgs/

Then select zradio to use the compat libs.

This worked for me, if you have any questions, feel free.

~AIG
braindrop
I never knew about this, I think I'll try it out. Right now I listen to the stream off theclassicalstation.org and I'm sharing that in case anybody else is a classical fan. I use their vog stream with xmms on OZ. I help support them because when I pointed out to them that there was no mention of linux on their stream page they actually added instructions for it! Not that the instructions were needed for most linux users but I was impressed and so now I help support them because they have no funding outside of listeners.
Anyway, there's good classical and I will see if zradio works on my setup here.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.