Help - Search - Members - Calendar
Full Version: brick my SL5600
OESF Portables Forum > General Forums > General Discussion
ced
This morning, I've done a hard reset on my SL5600 and the green mail light is flashing constantly. If I plug the power then the orange led is flashing as well...

I don't know what happen... :-( what should I do?
Ive done a search on the forum and I can't find anything about it.
ced
I've done a D+M + reset and I've got a service menu. I've never used it so what should I do now?
ced
When I've tried to do a "CF update" (I've stored the default 1.32 sharp rom files) then I get:

CODE
CF Update



  ---- Found orders -----

Error!!!



I've done a "NAND Flash Back Up" and that succeeded. But when I've tried to do a restore then it can't find the SYST5600.DBK on my CF card.

I've tried 2 differents CF card and same issue.


So how can I un-brick my Z? :-(
aplanas
I think that you must get an old NAND backup, and do a restore from this backup. The problem is How put a DBK file in your CF whitout the Zaurus. May be a CF writer?
oreo
Remove CF and SD cards. Remove the battery. Connect to AC adapter power supply without the battery. Do a hard reset. Replace battery. Do a soft reset. Insert CF card. See if now you can read from the CF card.
ced
aplanas -> I've got a CF writer... where can I get NAND backup for the SL-5600?

oreo -> I've tryied your procedure, nothing... (how do you do a soft reset due to the Z is bricked?)
tumnus
I think oreo was referring to the reset button below the battery inside the battery compartment.

I presume you have tried the Format option from the Maintenance menu?

Does a NAND restore also overwrite the hidden Flash ROM partition that contains the bootloader and flash software?

It might be a CF slot hardware problem. Have you got a SD card you could try all of this with? At least that would confirm whether or not it is a CF slot problem.
ced
tummus -> I can't access the "maintenance menu", I can only access the "service menu".

so if oreo was talking about the reset button next to the battery as a "soft reset". how do you do a hard reset?

I've got an SD card but I haven't got enough space on it and it's an ext2 type. and I haven't a SD writer...

I can do a NAND backup so to write to my CF card it's ok. so do you think the read mechanism is broken?
ced
I've done a NAND backup from a collegue. but my Z doesn't find the backup file during the NAND restore.

Did I f***up my Z? :-(
ced
I've copied the backup file to my SD card using my collegue Z. I get the same thing...

CODE
NAND Restore from SD



file SYST5600.DBK

not exist file


is it matter my SD card is an ext2 type?
ced
I've found a "diag menu" with D+P. it's similar from the "service menu" but with a lot more options.

I've tried the NAND restore (page 4) and I get the same thing (can't find the file)

There is a "NAND User Data Erase", should I try that? ;-)

and there is a "NAND Flash Erase"...


I've tried the "Compact Flash" test (page 2) and it give me lot of "NG:" lines. is it valid?

The "CF CARD Write" test (page 3) gives me -> "no free sector(-1)"
The "CF CARD Read" test (page 3) gives me -> "Sector not found!"
tumnus
QUOTE
so if oreo was talking about the reset button next to the battery as a "soft reset". how do you do a hard reset?

I guess the definition of soft on hard reset is a bit confusing on the 5600. I would say a hard reset is the 'Format' option on the Maintenance menu after leaving the battery cover switch in the 'Replace Battery' position for at least 10 seconds as that in theory restores your Z to the factory state since the 5600 keeps /home even after a a flash as you know.

So it doesn't do a thing when you try the usual OK+On for the Maintenance menu? I'm guessing in all this, you've had the battery cover switch in the 'Replace Battery' position for more than 10 seconds at a time.

I don't know if the 5600 needs FAT16 or not like the 5500. All my cards are FAT16 anyway.
ced
!!!!!!!!!!!!!!!!! ehehehe !!!!!!!!!!!!!

I've re-formated my SD card to vfat and copy the backup file to it.

The backup option stores the file in lowercase!!! and expect to read it in uppercase!!!

cool I'm back! :-) :-)


I've no idea why this happen in the first place...
aplanas
Ohhh... great!

It's extrange. I can't restore my NAND backup from my CF. The message is the same "file not found". I put the name in uppercase and in lowercase and I get the same result
aplanas
.... don't touch the NAND write test ..... .... .... ohhhhhh sad.gif

Now I need restore THIS backup!!!
kurochka
I decided to share my 5600 NAND backup file with the community. It is 250 CPU, basic the Kompany ROM with no additional software. The size of the file is 67Mb. I have just made it and have not tried restoring from it. I could not upload it to the Download section here (maybe there is size limitation). Please post here if you have web space on http or ftp server to post this file. I do not want to disclose my email to everybody in the world.
suchs
ced: I am in a similar situation. I am soon to do a nand backup up using the 5600 pxa250 posted ... did you need to save it to lowercase? can i leave it in uppercase on my cf card? SYST5600.DBK

btw any howtos on this? heh. :wink:
suchs
QUOTE
I can't restore my NAND backup from my CF. The message is the same "file not found". I put the name in uppercase and in lowercase and I get the same result


yup. me too. I have this same problem.

I was able to get back going, however by including the mversion.bin file on the cf card along with updater.sh, initrd.bin, and zImage.bin and doing a regular maintenance menu cf update.

so at-least I've been unbricked for the moment. biggrin.gif
szym
Can you send me nand file for Z 5600
I have little problem to turn on zaurus
And what does NG mean ?

I can publish it for other people on our www.webd.pl servers

Thanks for fast replying
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.