Help - Search - Members - Calendar
Full Version: Can't Get Package Installation To Work Properly...
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Personal Java/Jeode/J2ME Personal Profile
daldred
I'm using a SL5500 with Sharp 3.10 ROM, and developing a Java app which I hope to release generally when it's ready. It's a Sudoku helper (it doesn't solve them, just lets you do them on screen): it's called Zudoku.

I have a very preliminary version working, and I've been trying to package and install it. The file Zudoku.class will run happily from my development directory, so if I do:

cd /home/zaurus/Programming/Java
evm Zudoku

things happen as they should.

I've built an ipkg following the instructions on the Java FAQ on the ZUG pages. The run_Zudoku file at this stage reads:

cd /home/QtPalmtop/java/
evm -XappName=run_Zudoku Zudoku

...and the Zudoku.class file is in /home/QtPalmtop/java. Everything seems to be in the right places, but when I tap the icon, the program doesn't run.

If I use the console, navigate to /home/QtPalmtop/bin, and do ./run_Zudoku, I get an error message:

Exception in thread "main", java.lang.NoClassDefFoundError: Sudoku at Zudoku.main (bytecode 0)

However, exactly the same class file, run from my development directory, runs without any problems. If I change the run_Zudoku file so that it cd's to /home/zaurus/Programming/Java instead of the QtPalmtop directory, it runs the program, provides the icon on the taskbar - no problems!

What am I missing? huh.gif
Omicron
QUOTE(daldred @ Aug 24 2005, 12:31 PM)
If I use the console, navigate to /home/QtPalmtop/bin, and do ./run_Zudoku, I get an error message:

  Exception in thread "main", java.lang.NoClassDefFoundError: Sudoku at Zudoku.main (bytecode 0)


What am I missing?    huh.gif
*


Sounds like it is looking for Zudoku class in paackge Sudoku (or directory).

Try using various Sudoku.Zudoku type combinations.

Also, you probably need to user the -classpath option to specify the class path of .



Hope this helps.
daldred
QUOTE(Omicron @ Aug 24 2005, 07:57 PM)
Sounds like it is looking for Zudoku class in paackge Sudoku (or directory).


Aaargh. Department of the bleeding obvious strikes again. I'd not transferred all the class files over....

Thanks....
insomniux
QUOTE(daldred @ Aug 24 2005, 09:31 PM)
QUOTE(Omicron @ Aug 24 2005, 07:57 PM)

Sounds like it is looking for Zudoku class in paackge Sudoku (or directory).


Aaargh. Department of the bleeding obvious strikes again. I'd not transferred all the class files over....

Thanks....
*



Interesting I've been looking for a sudoku package for my sl6000 but havent found any working If you interested in testers, I will be happy to volunteer!
daldred
QUOTE(insomniux @ Sep 23 2005, 08:10 PM)
QUOTE(daldred @ Aug 24 2005, 09:31 PM)
QUOTE(Omicron @ Aug 24 2005, 07:57 PM)

Sounds like it is looking for Zudoku class in paackge Sudoku (or directory).


Aaargh. Department of the bleeding obvious strikes again. I'd not transferred all the class files over....

Thanks....
*



Interesting I've been looking for a sudoku package for my sl6000 but havent found any working If you interested in testers, I will be happy to volunteer!
*



If you'd like to mail me on david at familyaldred dot org dot uk I'll send you a trial version! I'm reasonably happy with the way it works, but there are bits which don't seem quite right in interface terms, and I'd love someone else to have a look.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.