Help - Search - Members - Calendar
Full Version: Update Libc?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
takuan
I was wondering if anyone knew how i could update libc6 as it is now 2.2.5... i need an updated version for some programs i would like to install. 2.3+
thnx
Chero
you could try glibc_2.3.2_armv5tel.ipk over here.

Not sure if everything works, "libpthread" is not complete, but not every program needs it.
WARNING : i don't think uninstall is possible !!!! Backup first !!!

Chero
takuan
QUOTE(Chero @ Aug 28 2005, 10:02 PM)
you could try glibc_2.3.2_armv5tel.ipk over here.

Not sure if everything works, "libpthread" is not complete, but not every program needs it.
WARNING : i don't think uninstall is possible !!!! Backup first !!!

Chero
*


yea... i guess i should have backed up..=P
well, at least we now know that it doesn't work for the 6000L. I've just thought to check the other posts about libc and it seems that updating to 2.3.x breaks alot of other apps since pdaxrom was compiled with the old libc.. that'd be nice if the next ver. was updated with the new version <wink wink> =]
lardman
QUOTE
I've just thought to check the other posts about libc and it seems that updating to 2.3.x breaks alot of other apps since pdaxrom was compiled with the old libc.


I don't think it's because it's incompatible, but rather that as everything is linked to libc, moving/replacing it using any commands (like mv, cp) which are linked to it can be problematic.


Si
Chero
QUOTE(lardman @ Aug 29 2005, 01:49 PM)
QUOTE
I've just thought to check the other posts about libc and it seems that updating to 2.3.x breaks alot of other apps since pdaxrom was compiled with the old libc.


I don't think it's because it's incompatible, but rather that as everything is linked to libc, moving/replacing it using any commands (like mv, cp) which are linked to it can be problematic.


Si
*



Right,
I've been running on of the (g)libc6-ipkgs and everything worked just fine.
The only problem was "libpthread" what caused a problem in OpenOffice. All the other apps I've tried were just fine (I tried firefox, Kopi, kapi, abiword and settings-apps right after installing). I've only been running it for a few days cause i've been trying to create a version with a full libpthread (without succes so far)
More on this is in the openoffice thread.

Chero
omro
QUOTE(Chero @ Aug 29 2005, 06:55 AM)
The only problem was "libpthread"


Does anyone know why compiling the the glibc 2.3.x builds for pdaXrom seem to have trouble with libpthread?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.