Help - Search - Members - Calendar
Full Version: C3100 Xmms Playback
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
xfaethorx
Hi,

I installed XMMS on my Zaurus SL-C3100 yesterday, I tried to play an MP3 through it but unfortunately it played about 1 second if that and then the audio cut out and you couldn't hear anything but the odd click. To me it sounds like its trying to play the file but isn't making it.

My questions are

1. can the Zaurus handle XMMS?
2. If so does anyone have it running?
3. If you do what version are you using and where did you get it from/
4. did you have to change anything for it to work?

I'm trying to get as much stuff as I can into X/QT if I can't do it then its not a problem I'd just like to have XMMS working smile.gif.
DoTheDog
xfaethorx,
I gave xmms a try on PocketWorkstation and ran into the same problems you are having. I was trying to stream it over wireless. I'm not sure if the problem is too much CPU required or not enough buffering going on. I am currently just using the MusicPlayer that comes with the Z. I set the buffering to 5MB and it works great over wireless. So in answer to your questions:
1. Mine can't
2. Got it running but not using it
3. Just used apt-get install xmms in PocketWorkstation
4. Tried to up the buffer time in oss settings but didn't seem to help.
xfaethorx
QUOTE(DoTheDog @ Aug 31 2005, 02:05 PM)
xfaethorx,
I gave xmms a try on PocketWorkstation and ran into the same problems you are having. I was trying to stream it over wireless. I'm not sure if the problem is too much CPU required or not enough buffering going on. I am currently just using the MusicPlayer that comes with the Z. I set the buffering to 5MB and it works great over wireless. So in answer to your questions:
1. Mine can't
2. Got it running but not using it
3. Just used apt-get install xmms in PocketWorkstation
4. Tried to up the buffer time in oss settings but didn't seem to help.
*



yep looks like exactly the same problem smile.gif. Ah well that can go into the "F**ked if i can be bothered" section and I'll just the MusicPlayer instead. I would have prefered to have an X based Mp3 player for when I'm in X but no bother as long as I can hear tuneage its not all bad biggrin.gif.
DoTheDog
I was wondering if you installed alsa if it would be better. When I run it from a terminal I get errors saying it can't find libasound.so.2, libmikmod.so.2, libGL.so.1. Not sure about the other two but I believe libasound is from alsa no? The OSS module doesn't have good buffering capabilities, it will only let me buffer 10 secs...
xfaethorx
I think its the supporting .so libs. Either the output library or the mp3 decoder theres alterantives but i've not managed to get them to work so as of now I've given up for the moment.

libmad MIGHT be the solution but i've had no luck getting xmms to work with it properly.
Sna
you have to find the mad plugin for xmms for mp3 reading
i had the same problem using pdaxrom at beginning
xfaethorx
i found the mad plug in but it didn't install to the directory properly.
I'll try again and let peps know.
xfaethorx
right i've got it working!

heres the versions of things you need to get it to work (or at lesat this is what I've used to get mp3s to successfully play via xmms.

xmms_1.2.10_armv5tel.ipk
xmms-mad_0.5.6-1_arm.ipk
libid3tag_0.15.1b_armv5tel.ipk
libmad_0.14-2b-1_arm.ipk

theses are the files I used, you might have to copy libxmmsmad.so from /home/QtPalmtop/lib/xmms/Input to /home/root/lib/xmms/Input but once you've done that it'll work!

I've successfully played a bunch of MP3s through it biggrin.gif.
DoTheDog
Great hint. I also got xmms running in PocketWorkstation by just doing:
apt-get install xmms-mad

Installed and now works well.
bam
anyway to tar up the ipk's and upload here, I found them but my installer is giving me lip, somehting bout invalid charachter found in file
Cresho
i can create ipk files to make it run.

anybody should email me the files and i will create a single ipk?

intrested?

i want to know how suspend works? does it suspend right or anything?

I hope you guys are talking about the default sharp rom.
bam
yes default sharp rom, works perfectly without moveing any lib's anywhere, just standard install, as for suspend, hmmm dunno, will play around with it. When are we gonna have a pdaxrom for the 3100, wish I had a spare 3100 to give to the guys to make the rom, actually I am willing to make a monthly donation of 25(usd) for say the next 2 years if they come out with it soon, hint hint smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.