Help - Search - Members - Calendar
Full Version: Mediaplayer And Streams
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
axonal
I've been able to connect to an MP3 stream using mediaplayer2 for about 30 seconds, until it stops itself. The button literally changes from play to pause and stops the stream from playing. It seems to work, and play, but it stops for some reason that I don't understand. Anyone have a clue what to do regarding this? I've tried using XMMS, but it doesn't play at all.
lardman
Does it say anything enlightening when you start it from the command line?

Si
niv
But I just posted it a couple of days before?
y not post in the thread I made?
as for command line: all looks cool
it loads with no errors, and runs.
I hear clicks at the earphone.
seems OSS is used.

What info should I post to help solve it? should I: $mplayer stream >file
and send the file?

I have a 5500 running Hentges 3.5.3 opie of a SD.

Thanks.
PS. pls kill the post I opened
lardman
QUOTE
But I just posted it a couple of days before?
y not post in the thread I made?


Me? Didn't see it, I've other things to do as well as answering questions on this forum I'm afraid wink.gif

QUOTE
What info should I post to help solve it?


What's the exact command line? what are you playing - mp3, mpeg, avi, etc.?

I think oss should work, but iirc there might have been an update to something (libqte perhaps) to make the sound work correctly - try a search (also look in the mailing lists) or ask on IRC - I don't use Opie, I use GPE.

You could also try using -ao sdl (which works better for me than oss anyway).

If you want more info from mplayer then remove -quiet or -really-quiet and you could even add on -v (all the way up to adding -v -v -v which might be a bit too much info).


Si
niv
QUOTE(lardman @ Sep 2 2005, 01:42 PM)
QUOTE
But I just posted it a couple of days before?
y not post in the thread I made?


Me? Didn't see it, I've other things to do as well as answering questions on this forum I'm afraid wink.gif

I was refering to axonal

I will post more info on this issue soon.
Niv
niv
what I have:
CODE
# mplayer http://radio.aguda.bgu.ac.il:8001/stream.mp3
MPlayer 1.0pre7-3.4.4 (C) 2000-2005 MPlayer Team
CPU: ARM

Playing http://radio.aguda.bgu.ac.il:8001/stream.mp3.
Resolving radio.aguda.bgu.ac.il for AF_INET6...
Couldn't resolve name for AF_INET6: radio.aguda.bgu.ac.il
Resolving radio.aguda.bgu.ac.il for AF_INET...
Connecting to server radio.aguda.bgu.ac.il[132.72.186.158]:8001 ...
Cache size set to 320 KBytes
Connected to server: radio.aguda.bgu.ac.il
Cache fill: 12.50% (40960 bytes)    Audio file detected.
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
AF_pre: 44100Hz/2ch/s16le
AO: [oss] 44100Hz 2ch s16le (2 bps)
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
Video: no video
Starting playback...
A:   0.0 (00.0) ??,?% 29%
A:   0.1 (00.0) ??,?% 31%
A:   0.2 (00.1) ??,?% 31%
A:   0.3 (00.3) 161.9% 30%
A:   0.6 (00.5) 160.4% 32%
A:   0.7 (00.6) 162.1% 33%
A:   0.9 (00.8) 161.1% 33%
A:   1.1 (01.0) 160.9% 32%
A:   1.3 (01.2) 163.9% 33%
A:   1.4 (01.4) 163.6% 35%
A:   1.6 (01.6) 163.3% 36%
A:   1.8 (01.8) 178.6% 38%
A:   2.0 (01.9) 178.8% 38%
A:   2.2 (02.1) 177.5% 40%
A:   2.3 (02.3) 178.5% 41%


I get a clicking noise.
Tried the -ao sdl - yeild the same resualt.

-v :
CODE
MPlayer 1.0pre7-3.4.4 (C) 2000-2005 MPlayer Team
CPU: ARM

CommandLine: '-v' 'http://radio.aguda.bgu.ac.il:8001/stream.mp3'
get_path('font/font.desc') -> '/home/root/.mplayer/font/font.desc'
font: can't open file: /home/root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using Unoptimized OnScreenDisplay
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/home/root/.mplayer/input.conf'
Can't open input config file /home/root/.mplayer/input.conf: No such file or dir
ectory
Can't open input config file /usr/etc/mplayer/input.conf: No such file or direct
ory
Falling back on default (hardcoded) input config
get_path('stream.mp3.conf') -> '/home/root/.mplayer/stream.mp3.conf'
Playing http://radio.aguda.bgu.ac.il:8001/stream.mp3.
Filename for url is now http://radio.aguda.bgu.ac.il:8001/stream.mp3
Filename for url is now http://radio.aguda.bgu.ac.il:8001/stream.mp3
Resolving radio.aguda.bgu.ac.il for AF_INET6...
Couldn't resolve name for AF_INET6: radio.aguda.bgu.ac.il
Resolving radio.aguda.bgu.ac.il for AF_INET...
Connecting to server radio.aguda.bgu.ac.il[132.72.186.158]:8001 ...
--- HTTP DEBUG HEADER --- START ---
protocol:           [HTTP/1.0]
http minor version: [0]
uri:                [(null)]
method:             [(null)]
status code:        [200]
reason phrase:      [OK]
body size:          [0]
Fields:
0 - Content-Type: audio/mpeg
1 - icy-br:128
2 - icy-description:Radio Ben Gurion
3 - icy-genre:Collage
4 - icy-name:Tunes from the Negev
5 - icy-private:0
6 - icy-pub:1
7 - icy-url:http://www.bgu4u.co.il
8 - Server: Icecast 2.2.0
--- HTTP DEBUG HEADER --- END ---
Content-Type: [audio/mpeg]
Cache size set to 320 KBytes
Connected to server: radio.aguda.bgu.ac.il
CACHE_PRE_INIT: 0 [0] 0  pre:65536  eof:0
Cache fill:  0.00% (0 bytes)    ==> Found audio stream: 0
demux_audio: seeking from 0x68C to start pos 0x0
demux_audio: audio data 0x0 - 0x0
Audio file detected.
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using generic C decore!
MP3lib: init layer2&3 finished, tables done
MPEG 1.0, Layer III, 44100 Hz 128 kbit Stereo, BPF: 418
Channels: 2, copyright: No, original: No, CRC: No, emphasis: 0
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
AF_pre: 44100Hz/2ch/s16le
ao2: 44100 Hz  2 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags:   8/8  (8192 bytes/frag)  free:  65536
AO: [oss] 44100Hz 2ch s16le (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
A:   0.0 (00.0) ??,?% 25%
A:   0.0 (00.0) ??,?% 25%
A:   0.1 (00.1) ??,?% 25%
A:   0.2 (00.2) 159.8% 26%
A:   0.4 (00.4) 163.2% 26%
A:   0.6 (00.6) 162.7% 28%
A:   0.8 (00.7) 162.3% 27%
A:   1.0 (00.9) 162.4% 28%
A:   1.2 (01.1) 162.4% 28%
A:   1.3 (01.3) 162.0% 29%
A:   1.5 (01.5) 162.2% 31%
niv
yet OGG sounds fine:
CODE
MPlayer 1.0pre7-3.4.4 (C) 2000-2005 MPlayer Team
CPU: ARM

CommandLine: '-v' 'http://radio.aguda.bgu.ac.il:8001/stream.ogg'
get_path('font/font.desc') -> '/home/root/.mplayer/font/font.desc'
font: can't open file: /home/root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using Unoptimized OnScreenDisplay
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/home/root/.mplayer/input.conf'
Can't open input config file /home/root/.mplayer/input.conf: No such file or dir
ectory
Can't open input config file /usr/etc/mplayer/input.conf: No such file or direct
ory
Falling back on default (hardcoded) input config
get_path('stream.ogg.conf') -> '/home/root/.mplayer/stream.ogg.conf'
Playing http://radio.aguda.bgu.ac.il:8001/stream.ogg.
Filename for url is now http://radio.aguda.bgu.ac.il:8001/stream.ogg
Filename for url is now http://radio.aguda.bgu.ac.il:8001/stream.ogg
Resolving radio.aguda.bgu.ac.il for AF_INET6...
Couldn't resolve name for AF_INET6: radio.aguda.bgu.ac.il
Resolving radio.aguda.bgu.ac.il for AF_INET...
Connecting to server radio.aguda.bgu.ac.il[132.72.186.158]:8001 ...
--- HTTP DEBUG HEADER --- START ---
protocol:           [HTTP/1.0]
http minor version: [0]
uri:                [(null)]
method:             [(null)]
status code:        [200]
reason phrase:      [OK]
body size:          [0]
Fields:
0 - Content-Type: application/ogg
1 - icy-br:Quality 0
2 - icy-description:Radio Ben Gurion
3 - icy-genre:Rock
4 - icy-name:Tunes from the Negev
5 - icy-private:0
6 - icy-pub:1
7 - icy-url:http://www.bgu4u.co.il
8 - Server: Icecast 2.2.0
--- HTTP DEBUG HEADER --- END ---
Content-Type: [application/ogg]
Cache size set to 320 KBytes
Connected to server: radio.aguda.bgu.ac.il
CACHE_PRE_INIT: 0 [0] 0  pre:65536  eof:0
Cache fill: 17.50% (57344 bytes)    Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename http://radio.aguda.bgu.ac.il:8001/stream.ogg
ext: .ogg
Trying demuxer 18 based on filename extension
==> Found audio stream: 0
[Ogg] stream 0: audio (Vorbis), -aid 0
Ogg demuxer : found 1 audio stream, 0 video stream and 0 text stream
Ogg file format detected.
==========================================================================
Opening audio decoder: [libvorbis] Ogg/Vorbis audio decoder
dec_audio: Allocating 4096 + 65536 = 69632 bytes for output buffer.
Name: ???? ????
OggVorbisComment: ENCODEDBY=THE UNDER-TAKER
OggVorbisComment: Title=???? ????
OggVorbisComment: tracknumber=9
OggVorbisComment: date=2003
OggVorbisComment: Genre=Rock
OggVorbisComment: Album=15 ???·?? ?? ??? ???????·?
OggVorbisComment: BAND=??? ???????·?
OggVorbisComment: Artist=??? ???????·?
OggVorbisComment: SONGLEN=225000
OggVorbisComment: ENCODEDBY=oddcastv3
OggVorbis: Bitstream is 2 channels, 44100Hz, 64000bit/s VBR
OggVorbis: Encoded by: AO; aoTuV b3 [20041120] (based on Xiph.Org's libVorbis)
OggVorbis: Init OK!
AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8000->176400)
Selected audio codec: [vorbis] afm:libvorbis (OggVorbis Audio Decoder)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
AF_pre: 44100Hz/2ch/s16le
ao2: 44100 Hz  2 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags:   8/8  (8192 bytes/frag)  free:  65536
AO: [oss] 44100Hz 2ch s16le (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
Ogg : bad packet in stream 0
A:   0.4 (00.3) 10.1% 31%
A:   0.1 (00.0) ??,?% 31%
A:  47.3 (47.3)  0.2% 31%
A:  47.4 (47.3)  0.2% 35%
A:  47.4 (47.4)  0.2% 35%
lardman
It's trying to use mp3lib, you need to force it to use libmad - either by putting 'ac mad' in the conf file (which lives in ~/.mplayer/), or by specifying this on the command line,


Si
niv
thanks Si, works fone now.

I think that Hentges should include this fix:
CODE
$echo ac=mad >>  ~/.mplayer/config
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.