Help - Search - Members - Calendar
Full Version: Bluetooth Startup Question
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
HeavyWeaponDude
Hello everybody!

I recently got a Billionton bluetooth card for my Collie.
Reading the different topics in the forum I've managed to make it work correctly, with the classical set of instructions:

setserial /dev/ttyS3 baud_base 921600
modprobe hci_uart
hciattach /dev/ttyS3 billionton
hciconfig hci0 up

But strangely enough if I try to start this same interface using:

/etc/init.d/bluetooth/start

I get this message:

Starting Bluetooth subsystem: hcid sdpd Can't open HIDP control socket: No such file or
directory
hidd rfcomm.

I'm puzzled... Anything should I edit to make it run? Would be more pratical to use just one command instead of four smile.gif
Thanks!
lardman
You could always look inside the /etc/rc.d/bluetooth script and see how it differs from your sequence of four commands.

Si
HeavyWeaponDude
Well, I had already checked that file and it differs heavily form the simple sequence of commands.

First I looked for the other files /etc/init.d/bluetooth refers to: /etc/bluetooth/rfcomm.conf and /etc/bluetooth/hcid.conf.
Everythinhg looks fine in them. I've also compared what's inside with the same files on my Fedora laptop.

The script itself (/etc/init.d/bluetooth) it's mostly different from the /etc/rc.d/init.d/bluetooth on my laptop, but that should be just distro related, if I got it right.

Since the error message is hidd related I've tried to type at the console:
#hidd
and i get the same error message. This doesn't happen if i try other commands included in /etc/init.d/bluetooth. I wonder what can be the problem.
Probably, I'm just missing something really stupid, like some parameter to type in a config file...

Thanks for the hint
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.