Help - Search - Members - Calendar
Full Version: Trouble With Belkin Keyboard And 3.5.3
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
phisch
I'm using OZ 3.5.3 as included with the Poodle Hentges ROM.

Bought a new Belkin keyboard (F8U1500) to use with my poodle. Went through the contorted installation of irk-belkin with -force-depends to bypass the (unneeded?) lirc dependency. My Z can receive IR messages from my phone with no problem with the irda applet on. When I look through my digital camera at the keyboard irda port I see lights as I push the keys.

The "Belkin" input option comes up in the menu, and I have the irda applet off (it is gray). I see no keypresses in any app that I've tried. The "On" radio button is checked when I select the Belkin input method. My IRK settings are:
Keyboard: Belkin
Zaurus Model: SL5600/SLC7XX
Startup: IRK On

Network Settings show an "irda0" connection. Should I have an irda1?

> ps -A | grep ira
1180 root 480 S irattach /dev/ttyS

Any ideas? Do I need lirc? (Can't find a poodle version on the feed, but I did see Collie versions) I'm willing to try anything from the command line.

Thanks in advance.
-Phil
phisch
QUOTE(phisch @ Sep 2 2005, 03:51 PM)
I'm using OZ 3.5.3 as included with the Poodle Hentges ROM.

Bought a new Belkin keyboard (F8U1500) to use with my poodle.  Went through the contorted installation of irk-belkin with -force-depends to bypass the (unneeded?) lirc dependency.  My Z can receive IR messages from my phone with no problem with the irda applet on.  When I look through my digital camera at the keyboard irda port I see lights as I push the keys.
*


Okay, let me re-phrase the question.
Has anyone gotten ANY ir keyboard to work with OZ 3.5.3 on a poodle? If so, what irk did you use, what keyboard do you have, and what contortions did you go through to make it work?
Thanks in advance!
-Phil
Hrw
could you try to rmmod all irda modules and then try irk? maybe irda0 block irda port...
phisch
QUOTE(Hrw @ Sep 8 2005, 08:31 AM)
could you try to rmmod all irda modules and then try irk? maybe irda0 block irda port...
*


I don't think I have any irda modules loaded.
> lsmod
sharp_mmcsd_m
pxa_bi
net_fd
usbdcore

I tried killing irattach, and restarting it. No effect either way. What devices need to be present for this to work? Just ircomm0?
Oh, I'm using Hentges ROM if that matters.
I noticed I don't have a kernel-module-irda installed. I assume it's compiled into the kernel?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.