Help - Search - Members - Calendar
Full Version: Usb-net Not Working In Collie -r21 Kernel
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
STrRedWolf
I have a 5500SL (collie) that was a bitch to upgrade (Opie kept wanting to update -- I deleted enough space to make it go through). One flash later, everything seems normal... until I try to transfer files over USB.

Nope, no go. Tried the old "Remove every module related to it" trick, and had to reboot my zaurus because it stuck on the Return key.

Out on a whim, I pulled up the terminal and typed in "dmesg":
CODE
usbdm: usbd_monitor 0.3 035 2002-06-12 20:00
monitor_request_irq: 23 44
monitor_request_irq: failed: -16
usbdm: request irq failed.


unload and reload usbdmonitor, and the IRQ is gotten... but now my touchscreen doesn't work, and USBnet still doesn't work. dry.gif

A reboot doesn't help with the USB issue. At least I can get wifi out to update things if need be...
lardman
QUOTE
Opie kept wanting to update -- I deleted enough space to make it go through


You should comment out all of the feeds except the upgrades/collie one so that only the kernel modules are upgraded.

QUOTE
until I try to transfer files over USB.


Try running 'usbnet start' - the usbnet script should be somewhere under /etc iirc.


Si
STrRedWolf
QUOTE(lardman @ Sep 6 2005, 01:35 AM)
You should comment out all of the feeds except the upgrades/collie one so that only the kernel modules are upgraded.

Try running 'usbnet start' - the usbnet script should be somewhere under /etc iirc.


Si
*


Nothing. I'll try one last try. At least I have a connect plus comming in...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.