Help - Search - Members - Calendar
Full Version: Trouble Turning Sl 5600 Back On
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
arthur_kalm
Hi everyone,

I reciently got a Sharp Zaurus SL 5600 and installed OZ with Opie on it. My biggest complaints about Opie are as follows:

1. When I turn the Z off (holding down the cancel button), I can't turn it back on for a few minutes. Furthermore, once it turns on, it turns off instantly and I have to press the on button again. What can I do to fix this?

2. The alarm sound is very quite. Can I change it for another alarm sound?

The first problem is the biggest one and causes me the most pain. The second one is a minor inconvience.

Thank you for any help.
caconym
Read up on on the r21 kernel patch. It's already in the Hentges ROM and directions for upgrading from the original OZ 3.5.3 ROM are on the main site:
http://openzaurus.org/wordpress/2005/07/27...rnel-on-collie/
This patch gets rid of the on/off button issue. This is a well known/discussed bug.
arthur_kalm
QUOTE(caconym @ Sep 8 2005, 04:22 PM)
Read up on on the r21 kernel patch. It's already in the Hentges ROM and directions for upgrading from the original OZ 3.5.3 ROM are on the main site:
http://openzaurus.org/wordpress/2005/07/27...rnel-on-collie/
This patch gets rid of the on/off button issue. This is a well known/discussed bug.
*


Thank you for the link. But is there an easier How To? I am a newbie on Zaurus.

Do I have to get USB networking working before I can get the kernel patch? Is there a way to just download the files off the net onto my computer and install them? How do I flash _just_ the kernel?

Thanks.
lardman
The above link is for a different machine; that said, some of the kernel code is shared between the machines, hence the same sort of problems.

This: http://www.oesf.org/forums/index.php?showtopic=14836

is the link you want for the 5600 (poodle).

Flashing instructions are here: http://openzaurus.org/wordpress/installation/sl-5600/

You should replace the zImage with the one from the link above (follow the instructions in that link though) and assuming you are running 3.5.3 already, you can do without the initrd.bin (which contains the root filesystem). Make sure you do have the updater.sh though otherwise the flash won't happen,


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.