Help - Search - Members - Calendar
Full Version: 3100 Beta Testers Needed!
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Pages: 1, 2
Laze
Hey anyone willing to try the latest pdaXrom for 3100 series - if so please post and i will PM you. You can also write to me at laze ]at[ pdaxrom.org with your details and IM info - so we can talk with you when installing it for the first time.
bam
will have to make a full abckup, way cool smile.gif busy now time for work, bbl, btw will pm ya when b-up complete smile.gif
sashz
There test rom for SL-C1000/C3100

http://212.10.30.205/rc10/sashz/test/kathrin-rc11-akita.zip
http://212.10.30.205/rc10/sashz/test/kathr...kita.zip.md5sum

please test.

Regarding repartion tool.
Please notice before using them you need to the fix the booloard, because the original Sharp bootloader can't handle more 64 MB.

WARNING: Bootloader fix and repartion is only tested on the C1000 series - C3100 users must have full ROM backup (NAND backup) in order to restore if theres any problems flashing.
martinbogo
Will test tonight. What do you mean, -change- the bootloader? That's going to be a biiiiit tricky here, as the only bootloader I'm aware of is the one built into the SL-C3100.

Got one handy, along with instructions on the install?

-Martin
sashz
QUOTE(martinbogo @ Sep 9 2005, 10:18 PM)
Will test tonight.  What do you mean, -change- the bootloader?    That's going to be a biiiiit tricky here, as the only bootloader I'm aware of is the one built into the SL-C3100.

Got one handy, along with instructions on the install?

-Martin
*


we fixed builtin bootloader for remove 64MB root partition limit problem smile.gif in original bootloader impossibe create root partition large than 64MB. With fixed bootloader possible use root partition up to 121MB (with 121 MB root partition second partition (user partition) will hide).

Look NAND Flash utils in installer.
martinbogo
Ahhhh... I found it. Spacibe Tovarish!

I will report in the morning how the install went. I am doing a NAND flash backup first.

-Martin
Shaka
I'm willing to help test for you, I've sent you an email with my details.

- Renzo Koornhof
Laze
Everybody just download all post your questions and findings here :-)
sashz
if you want install with default partitions, you not need to use flash utils.
Shaka
Well, I would like some instructions as to how to actually install the RC11.

However, at the moment I am only able to boot the Z into single user mode. I wiped the drive during a partial install of OpenBSD, and then I panicked when it wouldn't load properly, so I re-flashed the NAND with the one from the Tri Soft website, which means I lost the boot loader that OpenBSD was using. Will I be able to test this without actually being in the original Qtopia first? Or can the installation be done in either single user mode, or is there a NAND image available? I suppose a further question would be, does pdaXrom rely on being able to access the hard drive as it came from the factory such as the Sharp rom does?
badog
i will test it tonight
jiangtao9999
Not support Chinese ....
AbiWord & dillo Can't Display Chinese ...

Not Support locale ...
unsure.gif

Partition tool is goog ~~
My root is 100M .
smile.gif

C1000 + SD 1G

---------------------
update:

support codepage 936 !!!
biggrin.gif
Civil
Hm... I'm think it was bad idea for me to use bootloader fix... Installation program said that all done, press OK to reboot. After OK it shut Z down. And PowerLED turned off... No reaction on keyboard etc. (on hard reset too).
Now it's lays on the desk without battery (I hope It'll help, at least I hope I could get to Service Menu and use NAND Restore)

P.S. Battary was Fullcharged.
P.S.S. I have C3100.
badog
CF/SD become U-disk is supported
WIFI BT is supported and good!
USB -NET is supported
CP936 is supported
OSS Mixer is work

but overclock is not supported!!!!

now testing gunermic read xls.
Laze
ATTENTION!!!!

PLEASE DONT USE THE BOOTLOADER FOR C3100 - IT SEEMS TO BUGGY AND YOU MIGHT HAVE TO USE NAND BACKUP!


We need copy of bootloader. They can extract it with next steps:
1. Download this file http://pocketworkstation.org/files/recover...ract-updater.sh
rename it to updater.sh and put on CF card.
2. Run flash updating from CF card.
3. That will not update flash, but load system ROM to CF card.
4. Please send us the mainte.bin on laze ]at[ pdaxrom.org
badog
after install glibc-2.3.2+glibc-i18n
RC11 may be localed to all zone by "export LANG=XX"
martinbogo
QUOTE(Laze @ Sep 10 2005, 07:35 AM)
ATTENTION!!!!

PLEASE DONT USE THE BOOTLOADER FOR C3100 - IT SEEMS TO BUGGY AND YOU MIGHT HAVE TO USE NAND BACKUP!


*


... and this is why I waited till morning. Laze, the extracted bootloader is waiting in your inbox.

-Martin
wmadan
QUOTE(jiangtao9999 @ Sep 10 2005, 02:39 AM)
My root is 100M .
smile.gif


After I install RC11 on my C1000, fix the bootloader and set root at 121, I have 76MB free on root. How did you get 100MB free?

Bill
wmadan
USB mouse doesn't work out of the box, you must change serverargs in startx as before. When using the mouse, the screen orientation switches to portrait as before as well.

I found a bug in the package manager when using the USB mouse. When I launch the package manager, the mouse freezes.

Bill
Civil
Sorry for stupid (and almost offtopic) question:
And is there some recomendations for people whom used bootloaderfix and after that Z doesn't even load Service Menu?
sashz
QUOTE(Civil @ Sep 10 2005, 09:26 AM)
Sorry for stupid (and almost offtopic) question:
And is there some recomendations for people whom used bootloaderfix and after that Z doesn't even load Service Menu?
*


sorry for our problem with bootloader sad.gif

Please look this

http://www.trisoft.de/en_c3100howto.htm

section In case a backup won't work (and only then !)
SYSTC310.zip NAND-Backup from 08/17/2005
sashz
QUOTE(badog @ Sep 10 2005, 07:25 AM)
after install glibc-2.3.2+glibc-i18n
RC11 may be localed to all zone by "export LANG=XX"
*


please write more about what files need for pdaXrom localization. i want setup en_EN.UTF-8 as default locale in next version for solve internationalization input/output problem smile.gif
Civil
I've got backup (my own)... but I can't get Service Menu (only black screen) and powerled is off even with AC adapter...
Sna
Nice, I've installed this rom without repartitionning too much
the only thing i see is the microdrive "problem"
it's the third partition to mount to access files on the internal drive by default, not the first smile.gif
but in /etc/fstab i see no traces of an /dev/hdc1 as mounted by default
how is it mounted at startup? and at resume smile.gif

second thing
i've no access to the fn key
edit : the fn key is mapped as the alt button

third thing
when unmount a cf card in the unmount applet the microdrive is unmounted also

EDIT : the CPU applet is always at 100% (not true, i've found a process that take 100% CPU)

there are my first tests on my C3100
jiangtao9999
QUOTE(wmadan @ Sep 10 2005, 11:39 PM)
QUOTE(jiangtao9999 @ Sep 10 2005, 02:39 AM)
My root is 100M .
smile.gif


After I install RC11 on my C1000, fix the bootloader and set root at 121, I have 76MB free on root. How did you get 100MB free?

Bill
*


blink.gif
My root size is 100M :used 45.2M ,free 54.8M ......
& /home 21M :used 3.8M ,free 17.2M

It is not free 100M in root ....
wink.gif
badog
QUOTE(sashz @ Sep 10 2005, 06:41 PM)
QUOTE(badog @ Sep 10 2005, 07:25 AM)
after install glibc-2.3.2+glibc-i18n
RC11 may be localed to all zone by "export LANG=XX"
*


please write more about what files need for pdaXrom localization. i want setup en_EN.UTF-8 as default locale in next version for solve internationalization input/output problem smile.gif
*



glibc2.3.2:http://zaurus.earpassion.net/untested/glibc_2.3.2_armv5tel.ipk
glibc2.3.2-i18n:http://zaurus.earpassion.net/glibc-i18n-2.3.2-noarch-1.tgz
jiangtao9999
QUOTE(sashz @ Sep 11 2005, 02:41 AM)
QUOTE(badog @ Sep 10 2005, 07:25 AM)
after install glibc-2.3.2+glibc-i18n
RC11 may be localed to all zone by "export LANG=XX"
*


please write more about what files need for pdaXrom localization. i want setup en_EN.UTF-8 as default locale in next version for solve internationalization input/output problem smile.gif
*


Need i18n support ( locale : zh_CN.GB18030 & zh_CN.BIG5 )
& Chinese Blod & italic display ( It's seem to some patch )
& Input Method ( SCIM : http://www.scim-im.org/ )
& Chinese Font
& more .......
tongue.gif
Borealid
Although it's already been mentioned, the Fn key is mapped to Alt. As far as I can tell, there's no way to press the Fn key, so I can't type an =, |, etc.
Sna
second test smile.gif
auto-rotation doesn't seems to work
some tweaks for the power
auto supend cannot be avoided with the screen blanker applet
same thing for screensaver smile.gif
Borealid
FYI: auto-rotation doesn't work, but clicking rotate does function.

The keymap in the system console is correct, it's just X that's wrong.

There's a bug in ipkg that makes it get stuck trying to download "__.ipk". Why haven't you updated to a more recent ipkg version?
sashz
QUOTE(Sna @ Sep 11 2005, 09:01 AM)
second test smile.gif
auto-rotation doesn't seems to work
some tweaks for the power
auto supend cannot be avoided with the screen blanker applet
same thing for screensaver smile.gif
*


after flashing user flash was formatted?
Sna
i think yes
i had 64mb free in my user space after install with a partitionning 64/64

the install was good (except the fix bootloader part of course smile.gif)
sashz
QUOTE(Sna @ Sep 11 2005, 10:45 PM)
i think yes
i had 64mb free in my user space after install with a partitionning 64/64

the install was good (except the fix bootloader part of course smile.gif)
*


please make copy of system rom to us:

1. Download this file http://pocketworkstation.org/files/recover...ract-updater.sh
2. rename it to updater.sh and put on clean CF card.
3. Run flash updating from CF card.
4. That will not update flash, but download system ROM to CF card.
5. Please send all files from CF on sash ]at[ pdaxrom.org
Sna
Ok, no problem, i'll mail you that tonight when i can play again with the Z smile.gif
sashz
QUOTE(Sna @ Sep 11 2005, 11:38 PM)
Ok, no problem, i'll mail you that tonight when i can play again with the Z smile.gif
*


thank you!:)
Borealid
To fix the X keymap for SL-C3100, all that needs to be done is adding "|SL-C3100" to the "if model==SL-C3000" in the .xmodmap file, making the SL-C3100 use the SL-C3000 keymap. That works nicely.

How can I make xstroke start up at the same time as my X session? I tried putting it after matchbox-panel in .xinitrc (removing the & at the end of matchbox-panel), but it doesn't work. I also tried putting it in mbdock.session -- the mb-applets don't load.
badog
after test:
gnumeric has a problem still. Numbers of Ms-Excel-format-file can't be opened rightly.
overclock is not supplied
sashz
for restore C3100 which was killed with corrupted bootloader:

http://212.10.30.205/rc10/sashz/test/recover-3100.tar.bz2

unpack and copy 2 files updater.pro and mainte.bin to FAT16 CF or SD card.

insert card to zaurus

turn off power , remove battery.

Press and hold C and D keys and insert battery.

Led will on for some time and than off.

Remove and insert battery again, and run zaurus with ON key smile.gif
albertr
Sash,

Thank you for working out repartitioning on C1K!
-albertr
jam13
Just upgraded my C1000 from 10.4 to 11

Install went OK, and everything boots fine, but I can't get my WiFi (Zonet ZCF1100) card working. It seems that the hermes/orinoco kernel module is now missing. Is this in a separate package now, or is it just missing?

Also although I can get my Bluetooth card working, when I try to eject it using the card control applet, the Zaurus locks up and needs a hard reset. This also occurs with a "cardctl eject".

Incidently, I have never been able to get the PPP GUI to do bluetooth browsing (it seems to time out too early), so I always have to set the config files up manually. Is it just me or does this happen to others too?

Jamie
jam13
QUOTE(jam13 @ Sep 12 2005, 06:24 PM)
Install went OK, and everything boots fine, but I can't get my WiFi (Zonet ZCF1100) card working. It seems that the hermes/orinoco kernel module is now missing. Is this in a separate package now, or is it just missing?
*

Oops - my bad.

I remember now that the driver modules were missing before too - it seems to work by some other magic smile.gif

Problem was a type in my SSID sad.gif sorry!

Nice to see the USB net drivers working smoothly by the way.

Jamie
Civil
sashz
Thanks ) Now it's back to life.

Now about bugs:
1) No AutoHDD Mound (mounts /dev/hda1, and not /dev/hda2 and hda3).
2) After Inserting any CF Card - it umounts internal hdd.
Borealid
For me, the hard drive is not unmounted with any CF card. This release does mount /dev/hda1 on /mnt/ide, but not /dev/hda3 on /mnt/hdd3, as I told it to in /etc/fstab. In addition, it says "eject failed" for every eject - but successfully ejects anyway, AFAIK.

I can't type a period in the console.

Why do you guys not include GNU screen? It would make this so much more functional... It compiles just fine... By the way, your GNU make package is broken. I had to roll my own.
Sna
with the trick of Borealid
in the .xinitrc, add |SL-C3100 just after 3000 in the if
all keys are normal smile.gif

and the Auto-rotation is working now smile.gif
bam
so if i used the partition tools and expanded to 121Mb rom(it wouldnt turn on after that) i can use the two files in the recover 3100*.tar file and itll get me back my flash menu screen right? If not then what do I need? Any ideas would be helpful(better than sending it back)
sashz
QUOTE(bam @ Sep 12 2005, 10:56 PM)
so if i used the partition tools and expanded to 121Mb rom(it wouldnt turn on after that) i can use the two files in the recover 3100*.tar file and itll get me back my flash menu screen right? If not then what do I need? Any ideas would be helpful(better than sending it back)
*


please wait new rom , there will correct bootloader for C3100.
benplaut
okeedokee... i've got a usbd0 on the Z, and a usb0 on the Ubuntu in ifconfig -a.

What do i do now? i want internet via USB, of course... tongue.gif
bam
well restoring flash now, to original rom, via maintenance menu. Hopefully I can get this working,soon
ccooke
What are the latest test images?

I tried with the ones posted up here earlier, but it seemed that matchbox-desktop segfaulted all the time, so the furthest I could get into X was a panel and a clock. Still the barded background.
Borealid
To get the internet working, run these commands.

On the Zaurus:
ifconfig usbd0 10.10.10.2
route add default gw 10.10.10.1
echo nameserver 192.168.1.1 > /etc/resolv.conf

On the PC [as root]:
echo 1 > /proc/sys/net/ipv4/ip_forward
ifconfig usb0 10.10.10.1
iptables --flush
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD --in-interface usb0 -j ACCEPT

This assumes that your PC is connected to the world via eth0, and your nameserver is at 192.168.1.1. This will let the Zaurus access your PC as 10.10.10.1, and the PC get to the Zaurus as 10.10.10.2. Go ahead and play around if this doesn't work. Note that you have to redo the PC-side ifconfig line each time you detach/reattach the Zaurus, or you can have Hotplug do it for you.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.