Help - Search - Members - Calendar
Full Version: V1.3.1 Jvm (blackdown)
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Personal Java/Jeode/J2ME Personal Profile
Greetings all,

I have successfully installed and used (well, up to a point) Blackdown-1.3.1-RC1, native threads, nojit.

When I try running a Java application that uses AWT however I get:

Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/mnt.rom/cf/j2re1
.3.1/lib/armv4l/ /lib/ version `GLIBC_2.3' not found (requir
ed by /usr/mnt.rom/cf/j2re1.3.1/lib/armv5tel/
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at Method)
at sun.awt.NativeLibLoader.loadLibraries(
at sun.awt.DebugHelper.<clinit>(
at java.awt.Component.<clinit>(

I have tried loading libc 2.3 from the familiar distribution and put in LD_LIBRARY_PATH but this hoses everything (even ls, sh) ;-)

Has anyone gotten this to work or, in the alternative, does anyone know of another version 1.3+ JRE that is completely functional on this platform?

Many Thanks!
What's with all the cross posting?
QUOTE(BarryW @ Sep 9 2005, 11:37 AM)
What's with all the cross posting?

yeah, it's starting to get bothersome smile.gif
I was unsure as to where it would be most appropriate to post my question and some folks focus solely on certain topics.

But I will assume that you dont know the answer to my question. dry.gif

Many Thanks.

QUOTE(BarryW @ Sep 9 2005, 04:37 PM)
What's with all the cross posting?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.