Help - Search - Members - Calendar
Full Version: OZ 3.2 upgrade OPIE to 1.0.3
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
merciless
I have installed OZ 3.2 on the 5500 and I want to upgrade OPIE to 1.0.3. I have the OPIE packages save in the SD card. After setting up SD card as the feed location, I quit OPIE, and did ipkg update and ipkg upgrade. For the first package, I get "invalid magic" error. I tried the same thing using the CF card, no problems there. What is the deal with using the SD card? :roll:

Also, I always have to do perform ipkg upgrade at least twice (I have tried several times). "ipkg upgrade" always seem to freeze the first time. I would have to do a hard reset to continue. And even then, I have to upgrade some packages manually. Am I doing something wrong? :?:
lardman
Invlaid magic indicates that the file is corrupt.

I also had to perform ipkg update a couple of times to get it to complete, I've no idea why.

To tell the truth I'd upgrade to 3.3.6pre1 (or just to 3.3.5 if you only want opie 1.x - 3.3.6pre1 is the way of the future, but needs the compat libs to run old opie/sharp apps).


Si
VeeDubb
I'd DEFFINATELY agree. Upgrading opie is compliicated and hard to do right. I STRONGLY suggest you just install a newer version of OZ. 3.3.5 is great. And 3.3.6 is great to, just don't try to install the compat libs on a vfat partition.
merciless
Thanks for the feedback. I will try 3.3.X eventually since I am in the process of selecting which ROM to use.

As a final attempt, I decided to let the upgrade run for as long as possible. It finally did complete, after over an hour. The only package I had to upgrade by hand afterwards was opie-pics.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.