Help - Search - Members - Calendar
Full Version: Wcf12 - Connected, But Not....
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
ThreeDot
Stock Zaurus SL-5500 (latest Sharp ROM)
Linksys WCF12
Native Drivers
Wireless IP: 192.168.1.108
USB IP: 192.168.129.201
Gateway (for WiFi) set to ip of router (1.1)



Ok, here it is in a nutshell:

I plug in the card (comes up as eth0), connect to my wireless network (to all indications successfully), I can ping localhost, I can ping the ip (192.168.1.108) but I can't ping anything else on the network, not even the gateway...



Ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0C:41:15:BC:24
inet addr:192.168.1.108 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:94 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:2016 (1.9 Kb)
Interrupt:35


netstat -rn:

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.129.0 0.0.0.0 255.255.255.0 U 40 0 0 usbd0
192.168.1.0 0.0.0.0 255.255.255.0 U 40 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 40 0 0 eth0

HELP!
russilwvong
QUOTE(ThreeDot @ Sep 13 2005, 04:46 AM)
I plug in the card (comes up as eth0), connect to my wireless network (to all indications successfully), I can ping localhost, I can ping the ip (192.168.1.108) but I can't ping anything else on the network, not even the gateway...

What do "iwconfig eth0" and "lsmod" say? I just went through the process of getting a different Wifi CF card running:
http://www.oesf.org/forums/index.php?showtopic=14812
ThreeDot
QUOTE(russilwvong @ Sep 16 2005, 04:29 PM)
What do "iwconfig eth0" and "lsmod" say? I just went through the process of getting a different Wifi CF card running:
http://www.oesf.org/forums/index.php?showtopic=14812
*



iwconfig eth0:

eth0 no wireless extensions.

---I assume this is a problem, but what do I do about it? This is driving me nuts...

lsmod:

Module Size Used by
sa1100_bi 23088 0 (unused)
net_fd 16688 1
usbdcore 22592 0 [sa1100_bi net_fd]
usbdmonitor 5488 0
prism2_cs 54576 1
p80211 9952 1 [prism2_cs]
sharp_mmcsd_m 27408 1
devinfo 2912 0 (unused)
lardman
prism2_cs?

Uses hostap here. Is this a funny feature of the Sharp 'ROM's?


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.