Help - Search - Members - Calendar
Full Version: Smbmounter 0.1-2 Not Working
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
DoTheDog
Hi all, I am having trouble with smbmounter. I like the idea of being able to smbmount without having to type a really long string in qconsole. The problem I am having is that I can define the server name (netbios name AND tried IP address as well) share name, username and password. Basically when I hit the mount button, nothing happens.

I can smbmount command line.

When I try to run smbmounter in qconsole, as user zaurus:

#sudo smbmounter
SlSharedManager: can't get proc entry
Display size = 480x640

I also got an error:
could not open translation file /home/QtPalmtop//i18n/ja/libsl.qmid

I just put a link in that directory like so:
ln -s /home/QtPalmtop.rom/i18n/ja/libsl.qmid /home/QtPalmtop//i18n/ja/libsl.qmid

now I don't get that particular error anymore.

Does anyone know what the "can't get proc entry" error means and is this the reason smbmounter won't work? If so anyone know how to fix it?
DoTheDog
Ok figured out the "can't get proc entry" problem. I had debian running and it had mounted /proc. A reboot cleared it. But smbmounter still doesn't work. No errors now though. Hmmm....
icruise
I was never able to get that to work, and I submitted a very similar question a couple of months ago, but never got any advice that helped. So I'm not sure what to tell you, sorry.
DoTheDog
icruise,
Thanks for the response. Still can't get it to work. I can't seem to get the automount scripts seen here and meanie's site either? I wonder if it is a c3100 issue?
Meanie
I have updated the SMB mounting section http://www.users.on.net/~hluc/myZaurus/cus...html#filesystem
which should clear up how to get it working. I tested this on my C3100 as well to make sure all the instructions are the same. If things fail the first time, make sure you delete any leftover entries in /hdd3/Documents/NetworkFolders, before you try again, otherwise it gets confused.
DoTheDog
Meanie, Thanks for the update.

I got it working! kinda... Not sure what did it. I added the record in the hosts file,uninstalled and reinstalled the smbmounter ipk, also made sure that it runs with root privileges and rm -rf all the directories in /hdd3/Documents/NetworkFolders/ (that is pretty key, it won't work at all if the directory is there). I found that you MUST hit the unmount button even if it doesn't work to clear the created directory.

It still doesn't work if I launch it from the Q application menu. It does work if in terminal, running as zaurus user I type: sudo smbmounter.

Any ideas?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.