Help - Search - Members - Calendar
Full Version: Lost My Fstab
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
bolbit
Hi every one

I have my fabulous C1000 since 4 days now :-) ! It is with the sharp rom in english.

Today i received my 1G SD Card (PQI) from newegg, but when i put it in the Z, nothing happen :-((.

i decide to reboot -> yes, the SD card is here !! so, I created a 720 MB partition, as described here, everything was good.

Then, i remove the sd card, and plug it back ... nothing happen one more time ...

dmesg said (a long list of ):

pxa_sd_wait_id_response: responce time out (cmd=01 MMC_STAT=0x2142)

by searching in this forum, i have found this thread : http://www.oesf.org/forums/index.php?showtopic=9366

seems same that my pb, but the card is brand new...

and this from google (this is why i have lost my fstab)
http://64.233.187.104/search?q=cache:N7Bw3...nt+zaurus&hl=fr
why not, let's try this, so i tried to remove the mtab and type 'ln -s /proc/mounts /etc/mtab' and obviouly, mister murphy was around and i have typed 'rm /etc/fstab' instead of 'rm /etc/mtab'...(i was playing with fstab just before to try to find something)

So, my first question : help, is there someone that can send me the regular fstab from a C1000 ???

2nd question : I have rebooted the Zaurus, and now i can see the SD icon, and can access to the SD Card (i can only write as root, not as zaurus, but it is another issues, no?). if i unplug the card and put it back : same messages (no icon, no access to the card).

The SD card seems to be recognized only at boot ? is it a bad SD card or the problem came from an other part ?? did i need to change the SD card ? thanks

PS : After reboot without fstab, everything seems to work...

update : I have the sd card plugged in since yesterday. no pb. Even after a suspend and resume. I didn't try to remove it yet. i have done a backup, seems fine. ???
bolbit
No one have a fstab for C1000 ?
Absolute Nirvana
QUOTE(bolbit @ Sep 29 2005, 06:33 PM)
No one have a fstab for C1000 ?
*


Finally got around to making a copy for you. I had to tar it because it wouldn't let me upload it as it was. Hope this helps. I have the same problem with my SD (actually MMC) card. I have to mount it manually for it to show.
bolbit
Thank you very much !!.
For me, when the sd didn't automount, i can't even mount it manualy.
there is this 'time out' error message (dmesg) ?
Absolute Nirvana
What command are you using to mount the sd card?

After becoming root,
CODE
mount /dev/mmcda /mnt/card
always worked for me.
jpmatrix
Bolbit,
I've a 256 SD card from Truewin the Z could never recognize from its internal sd card reader... i had the same lot of messages like you : pxa_sd_wait....
i could never mount the card although i had no problem with my PC or with another friend's pocketPC PDA... i believe the Z just doens't like that card smile.gif
but i find an issue : plug an usb sd card reader to the Z and mount the truewin sd card in it and... it works!
so apparently it's really a matter of the Z internal sd reader...
Cresho
stick with lexar, pny
bolbit
Ok, it seems this PQY is not perfect.

I have kept the sd card inside the Z for 2 days and all was good.

Then i decide to make final test with it (before send it back to neweggs), i have formated the sd card with a FAT16 FS, and try different ways to plug it.. the result is now the Z automounts the SD card if i stay 1 to 2 s pushing the sd card at the maximun and then release it. So it should be a connector pb... I hope i will not damage the internal Z sd card reader doing that ..

I'm am now try to make kino2 running... (mplayer works, but if i try to install kino2-bvdd, it says that it need mplayer -w100 ???)..

I have still lot of time to spend on this toy :-) !!!! i love it!

PS Absolute : it was the command that i used.
bolbit
Well, after having installed applications and creates a file swap, the Zaurus became very slow... removing the SD card solved this slowness.
Therefore, return of the Card at neweggs and I will try to find another mark. The reference of this SD Card is: PQI 1GB SD CRD 45 Ae20-1030-0101
to be thus avoided.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.