Help - Search - Members - Calendar
Full Version: Rc11 Gcc [solved, Pls Don't Read]
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Fatty
Hi all.

I'm using RC11 with XFCE4 + GCC/header from the RC11 feed.

When I compile really simple/single file program (like the hello world stuff) with 'gcc -o test test.c', the program can be compiled to executable but nothing happen when run. Any suggestion?

[Solved] sorry for such stupid question. Tried all possible solution but missed out the most obvious one... no path pointed to my /home and it requires ./test to run tongue.gif
pgas
ehe, not so stupid ;-)

I think it happens to a lot of people (I've done exactly the same) because:

* the current dir is not in the path (while it is the case under DOS/Windows)

but more vicious is the fact that

* 'test' is a valid command that does not output anything.

and thus you end up running 50 times /usr/bin /test instead of your program, trying to change the output doing all sort of things without even getting an error...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.