Help - Search - Members - Calendar
Full Version: Can't Get Mplayer/kino2 Working With C3100
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
Merardon
I'm using the stock Sharp ROM on my Zaurus C3100 (want to keep Japanese support), and I've done everything I can think of to get it working. I installed Tetsu's special kernel, Tetsu's kernel module package, bvdd_0.4.0-1_arm.ipk, mplayer-bvdd-iwmmxt_1.1.5-1_arm.ipk, kino2_0.4.3b_arm.ipk, and mplayer didn't work. Crashes with:

QUOTE
FATAL: Cannot initialize video driver.

FATAL: Could not initialize video filters (-vf) or video output (-vo).


I then installed libmad_0.15.0b-zports-0_arm.ipk and libSDL_1.2.6-zports-5_arm.ipk, and still no luck. Can anyone let me know if I'm missing any libraries? Wipe it clean and start from scratch? (Not a problem if I have to do that, just got it two days ago)

This is the second time I've attempted to get it working. The other time I followed the instructions here, substituting newer versions where applicable, along with Tetsu's kernel, and that worked out with the same error message. (I wiped the Z after that though and started from scratch for the second attempt)
lardman
What do you pass to mplayer after the -vf and -vo switches?

Or what's in the conf file in ~/.mplayer/

Or does kino2 itself specify the switches to pass?

In any case you can increase mplayer's verbosity by passing the -v switch.


Si
Merardon
Here's the entirety of the mplayer output.

QUOTE
bash-2.05$ mplayer -vm -fs -v "Final Fantasy VII - Advent Children.avi"
MPlayer 1.0pre7-3.4.2 © 2000-2005 MPlayer Team
for Zaurus 1.1.5 © 2004-2005 AGAWA Koji (atty)
CPU: ARM
CPUflags: iWMMXt

85 audio & 196 video codecs
CommandLine: '-vm' '-fs' '-v' 'Final Fantasy VII - Advent Children.avi'
get_path('font/font.desc') -> '/home/zaurus/.mplayer/font/font.desc'
font: can't open file: /home/zaurus/.mplayer/font/font.desc
Font /opt/QtPalmtop/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Unoptimized OnScreenDisplay
Failed to open /dev/rtc: Device or resource busy (it should be readable by the user.)
Using nanosleep() timing
get_path('input.conf') -> '/home/zaurus/.mplayer/input.conf'
Can't open input config file /home/zaurus/.mplayer/input.conf: No such file or directory
Parsing input config file /opt/QtPalmtop/etc/mplayer/input.conf
Input config file /opt/QtPalmtop/etc/mplayer/input.conf parsed: 59 binds
get_path('Final Fantasy VII - Advent Children.avi.conf') -> '/home/zaurus/.mplayer/Final Fantasy VII - Advent Children.avi.conf'
Playing Final Fantasy VII - Advent Children.avi.
[file] File size is 936610710 bytes
STREAM: [file] Final Fantasy VII - Advent Children.avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
AVI file format detected.
list_end=0x2286
======= AVI Header =======
us/frame: 41708  (fps=23.976)
max bytes/sec: 0
padding: 0
MainAVIHeader.dwFlags: (272) HAS_INDEX IS_INTERLEAVED
frames  total: 145321  initial: 0
streams: 2
Suggested BufferSize: 0
Size:  320 x 240
==========================
list_end=0x10F4
==> Found video stream: 0
====== STREAM Header =====
Type: vids  FCC: divx (78766964)
Flags: 0
Priority: 0  Language: 0
InitialFrames: 0
Rate: 2997/125 = 23.976
Start: 0  Len: 145321
Suggested BufferSize: 63418
Quality 10000
Sample size: 0
==========================
found 'bih', 40 bytes of 40
======= VIDEO Format ======
  biSize 40
  biWidth 320
  biHeight 240
  biPlanes 1
  biBitCount 24
  biCompression 808802372='DX50'
  biSizeImage 460800
===========================
Regenerating keyframe table for MPEG4 video
list_end=0x217A
==> Found audio stream: 1
====== STREAM Header =====
Type: auds  FCC:  (0)
Flags: 0
Priority: 0  Language: 0
InitialFrames: 1
Rate: 56000/1 = 56000.000
Start: 0  Len: 339417344
Suggested BufferSize: 28000
Quality -1
Sample size: 1
==========================
found 'wf', 18 bytes of 18
======= WAVE Format =======
Format Tag: 8192 (0x2000)
Channels: 6
Samplerate: 48000
avg byte/sec: 56000
Block align: 1
bits/sample: 0
cbSize: 0
===========================
list_end=0x2286
AVI: dmlh found (size=248) (total_frames=145321)
list_end=0x378C96EE
Found movie at 0x280C - 0x378C96EE
Reading INDEX block, 290630 chunks for 145321 frames (fpos=0x378c96f6)
list_end=0x37D38B96
hdr=Software  size=44
Software  : VirtualDubMod 1.5.10.1 (build 2366/release)
AVI index offset: 0x2808 (movi=0x280C idx0=0x4 idx1=0x6D6C)
Auto-selected AVI audio ID = 1
Auto-selected AVI video ID = 0
AVI: Searching for audio stream (id:1)
AVI video size=590114373 (145321) audio size=339417344 (339417344)
VIDEO:  [DX50]  320x240  24bpp  23.976 fps  778.9 kbps (95.1 kbyte/s)
[V] filefmt:3  fourcc:0x30355844  size:320x240  fps:23.98  ftime:=0.0417
Clip info:
Software: VirtualDubMod 1.5.10.1 (build 2366/release)
get_path('sub/') -> '/home/zaurus/.mplayer/sub/'
get_path('default.sub') -> '/home/zaurus/.mplayer/default.sub'
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
No accelerated IMDCT transform found
AC3: 5.1 (3f+2r+lfe)  48000 Hz  448.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0xA
No accelerated resampler found
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
using /dev/fb0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
AF_pre: 48000Hz/2ch/s16le
ao2: 48000 Hz  2 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 48000 Hz samplerate (requested: 48000)
audio_setup: frags:  8/8  (8192 bytes/frag)  free:  65536
AO: [oss] 48000Hz 2ch s16le (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...
a52: error at resampling
[ffmpeg] aspect_ratio: 1.333333
VDec: vo config request - 320 x 240 (preferred csp: Planar YV12)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (320x240->320x240,flags=3,'MPlayer',0x32315659)
No accelerated colorspace conversion found
SwScaler: using unscaled Planar YV12 -> BGR 16-bit special converter
REQ: flags=0x403  req=0x0
VO: [fbdev] 320x240 => 320x240 BGR 16-bit  [fs] [vm]
VO: Description: Framebuffer Device
VO: Author: Szabolcs Berecz <szabi@inf.elte.hu>
Reading /etc/fb.modes: can't open '/etc/fb.modes': No such file or directory
FATAL: Cannot initialize video driver.

FATAL: Could not initialize video filters (-vf) or video output (-vo).

Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: liba52
uninit video: ffmpeg
Can't restore text mode: Invalid argument

Exiting... (End of file)
bash-2.05$


The mplayer config file should be the default version, as I haven't touched it.
Merardon
Can someone post a detailed list of packages to install, and in what order? I've installed everything any guide has said. Using the latest mplayer version, Tetsu's kernel, the kernel modules, bvvd, kino2, and nothing works. Ever. I've tried this several times, and it's getting increasingly frustrating.
drnick
QUOTE(Merardon @ Oct 7 2005, 01:38 AM)
Can someone post a detailed list of packages to install, and in what order? I've installed everything any guide has said. Using the latest mplayer version, Tetsu's kernel, the kernel modules, bvvd, kino2, and nothing works. Ever. I've tried this several times, and it's getting increasingly frustrating.
*


I have a c3000 so the it 'should' be similar.
1) Flash to Sharp Rom 1.11JP (this probably doesnt apply to you since there is no 1.11 for c3100)
2) get special kernal (18b) and updater.sh from Tetsu's site and Flash with OK+on
3) Open terminal and issue a uname -a to verify kernel is actually there
4) install kernel modules (18b) ipk for corresponding kernel
5) reboot
6) Install bvdd (0.4)
7) reboot
8) install mplayer (1.15) and Zplayer (0.1) (from atty.skr.jp)
9) reboot for good measure
10) find a video with a reasonable bitrate to test
11) play video.

i could never get kino2 to work.....ever although i havent tried the latest one.
Zplayer seems to work the best and I havent had to mess with any settings commmandline or GUI. Zplayer seems to know just what to do.
Cresho
check out my link at the bottom.

it is totally stupid proof! i even put up a video so you can test the result of installation and mind gou that the video was made for the sl5500 but works good on the c1000. you can make videos that look way better that will run with the setup i have.

let me know how it works and ill be expecting the thank you before you even get started. go to my zaurusvideo link now.

ps....dont use this one. kino2_0.4.2_arm.ipk

use the one from my site.
rob_figlabs
I'm using bvdd, mplayer and kino2. I've never used the special kernel so I can't comment on that. It took me quite a while of fiddling (and a new version of the ipks to appear) before it did work.

I installed:

bvdd_0.3.1-1_arm.ipk
mplayer-bvdd_1.1.4-1_arm.ipk
kino2_0.4.2_arm.ipk

In that order. Tested as working on stock Sharp ROM on C1000, C3000 and C3100. I always reboot after installing these, I don't know if that is necessary. I don't think I changed any of the kino2 preferences, but I might be wrong.
mickh
I installed kino2 exactly as described on Cresho's page (see link from his post above). It worked first time with no problems on my zaurus c3000 with standard rom.

I created a movie also basically as described on Chresho's site but I used DVDshrink instead of DVDdecrypter. A one and a half hour movie needs about 220MB.

Thanks Cresho,

Mick.
Merardon
I did a NAND restore, installed everything as per instructions, and also redownloaded all the codecs I had been using. Everything works fine now, thanks for the help! (I just use the Virtual Dub mod, don't like Vidomi at all)
Cresho
yes..... virtualdub mod is for advanced users. I havent updated the method of creating video on the zaurus since i owned my zaurus sl5500 and this method prooved to be the best way for me to watch videos without problems. The current tutorial works as well but I already know that you can achieve far better results than the current instructions. Happy movie transfering! Glad to see you found your legs too... cool.gif
bam
Final Fantasy VII - Advent Children.avi'<----where did you get this, pratel?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.