Help - Search - Members - Calendar
Full Version: Vanishing App?
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Qt/Qtopia
gregarican
I have a QPEApplication object created as a Ruby script. The object and its various children's objects, methods, etc. work fine. There is a suspect area. I have a series of push buttons that launch various documents various using Hancom Word. The code that I have to accomplish the actual launching is similar to:
CODE
system("qcop QPE/Application/HancomMobileWord 'setDocument(QString)' '/path/to/myDocument.doc'")

The Ruby system() method that wraps the qcop call simply launches a sub-shell that loads up Hancom Word set to a particular document. The problem is when I close Hancom Word the QPEApplication object disappears. When I check the active processes I see that my Ruby script is running but I can't seem to recover the GUI app I created. If I try to issue something like:
CODE
qcop QPE/Application/myGUIApp 'setDocument()'

there is a brand new instance of the GUI app I have. The original one still doesn't appear. Or if I try:
CODE
qcop QPE/Application/myGUIApp 'raise()'

nothing happens.

Since my Ruby script doesn't have anything displayed on the task bar I can't figure out a way to bring it back after exiting Hancom Word. Any suggestions?
gregarican
As a follow up I read about similar behavior when a script creates a new QPEApplication instance. Apparently since the script doesn't have a taskbar instance associated with it, when another Qtopia app is launched and exits the scripted QPEApplication object just disappears into the background. See http://lists.trolltech.com/qt-embedded-int...ead00043-0.html for details.

So if I launch my Ruby script from a Terminal session it will stay visible after Hancom Word exits. But the load that it adds having a Terminal session up is considerable. Is there an easy way to just create a taskbar instance for my Ruby script?
gregarican
Finally figured it out. Checking another forum on this site I ran across a similar Python scripting issue (http://www.oesf.org/forums/index.php?showtopic=5626&hl=). Making the Exec= value in the .desktop exactly match the QPEApplication.new() parameter in my Ruby script caused there to be a corresponding taskbar icon instance for my application. Now it doesn't disappear when Hancom Word exits. This seemed like a needle in a haystack, so I am going to post these results to a Ruby board or two just in case some Qtopia developer using Ruby runs into similar issues....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.