Help - Search - Members - Calendar
Full Version: Kismet & Intel Pro Wireless 2011b (sony Pega-wl100
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
magicbb
anyone got a intel pro wireless 2011b and is able to run kismet

when i start kismet, it says:
FATAL: Could not find 'monitor' private ioctl or use the newer style 'mode montor' command.

I am now using RC11, do i need to patch the driver in order to enable the monitor mode.

Please help
magicbb
after i insert the card, i look at /var/log/messages and find the following errors

Oct 5 15:53:47 cardmgr[140]: socket 0: Intel PRO/Wireless 2011B CF Card
Oct 5 15:53:48 cardmgr[140]: executing: 'modprobe hermes 2>&1'
Oct 5 15:53:48 cardmgr[140]: + modprobe: Can't locate module hermes
Oct 5 15:53:48 cardmgr[140]: modprobe exited with status 255
Oct 5 15:53:48 cardmgr[140]: module /lib/modules/2.4.20/pcmcia/hermes.o not available
Oct 5 15:53:48 cardmgr[140]: executing: 'modprobe orinoco 2>&1'
Oct 5 15:53:48 cardmgr[140]: + modprobe: Can't locate module orinoco
Oct 5 15:53:48 cardmgr[140]: modprobe exited with status 255
Oct 5 15:53:48 cardmgr[140]: module /lib/modules/2.4.20/pcmcia/orinoco.o not available
Oct 5 15:53:49 /etc/hotplug/net.agent: NET unregister event not supported
Oct 5 15:53:49 /etc/hotplug/net.agent: how do I bring interfaces up on this distro?
Oct 5 15:53:49 /etc/hotplug/net.agent: register event not handled

it seems that orinoco.o and hermes.o is missing, how can i find these two files?
Laze
Please read the FAQ on pdaXrom.org and also have look at: http://www.oesf.org/forums/index.php?showt...759&#entry44759
magicbb
now, it change to module /lib/modules/2.4.20/pcmcia/hostap.o not available
also there is no hostap_cs
magicbb
QUOTE(Laze @ Oct 5 2005, 09:51 PM)
Please read the FAQ on pdaXrom.org and also have look at: http://www.oesf.org/forums/index.php?showt...759&#entry44759
*


i have bought a new card "Ambicom" today and make changes according to the instruction, but still no luck
there is no hostap.o
and after changes the card to bind "hostap_cs" instead of "orinoco_cs", the card didn't work at all (light of the wifi card turn off)
Laze
Did you start by running the wifi setup tool in system settings?

Bascially do a clean install and then run the tool - after that try unpluging the card and insert. Then post dmesg and cardctl info
magicbb
Actually i have no problem in connecting the wifi to my router, i can browse the internet successfully, just can't run kismet. Anyway I have done a clean install and use the wifi tools, /var/log/messages is as follows:
Sep 28 09:53:27 cardmgr[694]: socket 0: Ambicom WL1100C 11Mbs Card 802.11b
Sep 28 09:53:27 cardmgr[694]: executing: 'modprobe hermes 2>&1'
Sep 28 09:53:27 cardmgr[694]: + modprobe: Can't locate module hermes
Sep 28 09:53:27 cardmgr[694]: modprobe exited with status 255
Sep 28 09:53:27 cardmgr[694]: module /lib/modules/2.4.20/pcmcia/hermes.o not ava
Sep 28 09:53:27 cardmgr[694]: executing: 'modprobe orinoco 2>&1'
Sep 28 09:53:27 cardmgr[694]: + modprobe: Can't locate module orinoco
Sep 28 09:53:27 cardmgr[694]: modprobe exited with status 255
Sep 28 09:53:27 cardmgr[694]: module /lib/modules/2.4.20/pcmcia/orinoco.o not av
Sep 28 09:53:29 /etc/hotplug/net.agent: NET unregister event not supported
Sep 28 09:53:29 /etc/hotplug/net.agent: how do I bring interfaces up on this dis
Sep 28 09:53:29 /etc/hotplug/net.agent: register event not handled

cardctl info is as follows:
PRODID_1="AmbiCom"
PRODID_2="WL1100C 802.11b CF-Card"
PRODID_3="2.2"
PRODID_4=""
MANFID=d601,0002
FUNCID=6
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

My case is exactly the same as this:
http://www.oesf.org/forums/index.php?showt...indpost&p=85339

do i need to use his way to use the kernel module from sharp rom?
Laze
How did you setup your kismet config file for the capture device?

Tried the cardctl scheme CardResume and the kismet trick?

Which Zaurus are you running - ALWAYS STATE that!
magicbb
already try the cardctl scheme CardResume, but still won't work
what kind of kismet trick are you referring to?
sorry, i am using c1000
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.