Help - Search - Members - Calendar
Full Version: Hdd3 Contents Lost
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
Mac
after recovering my Zaurus from a failed openbsd install, I restored everything, however hdd3 seems to be empty en read only.

in /home/zaurus Documents is symlink to /hdd3/Documents (and hdd3 is empty)

I tried fsck, found some problems but this didn't help. Also tried resetting the device back to factory settings, but hdd3 remains empty.

Is there anyone on this board who can help me? thanks!
gtJormungand
The original files on hdd3 were for the japanese dictionary and sample documents of assorted types, and these be found on the CDs that came with the Zaurus. It is strange that the drive is mounted as read-only, though; OpenBSD might have changed the partition type for hdd3. The Sharp ROM assumes that hdd3 is FAT32, and it could be trying to mount it as such. You can also change the script to use ext3 if necessary; just find all references to hdd3 in /root/etc/rc.d/rc.rofilesys and change the mount type from vfat to $LINUXFMT (defined in that file to ext3).

Other than that, create a Documents directory on hdd3 and the symlinks will work again.
Mac
Thanks gtJormungand for your reply.
I can't create a Documents folder on/hdd3, it's read only.

if I search for hdd3 in root/etc/rc.d/rc.rofilesys

I get:
##mount -t vfat -o noatime,quiet,umask=000,iocharset=utf8 /dev/${IDE1}3 /hdd3
## mount -t vfat -o noatime,quiet,umask=000,iocharset=utf8 /dev/${IDE1}3 /hdd3
## mount -t vfat -o noatime,quiet,umask=000,iocharset=utf8 /dev/${IDE1}3 /hdd3

do I have to uncomment those lines?

anyway I tried it, because when i manually enter
mount -t vfat -o noatime,quiet,umask=000,iocharset=utf8 /dev/${IDE1}3 /hdd3

I can write to /hdd3

but I can't save a modified rc.rofilesys.

thanks again for your help!
Mac
Status update; I managed to change /root/etc/rc.d/rc.rofilesys
and rebooted OK. Then I changed another thing in /root/etc/rc.d/rc.rofilesys
and now get a hdd1 error when I reboot.

no problem, I just boot with B+D , but /root is empty?
I backupped the original file, so I just have to place it back but /root is empty...
Mac
I asked to fast; I found most of the info on this forum.
this is how I managed to solve my problem

mount -o remount and rw /

change erything, next I used the script on http://www.xlfag.com/zaurus/ to rebuild the HD...


>> only thing I'm looking for is the original /root/etc/rc.d/rc.rofilesys
from the C3000 , anyone can post this for me?

thanks in advance!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.