Help - Search - Members - Calendar
Full Version: Zaurus Sl-5500 With A Usb Drive
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
togomenu
I was wondering if anyone was able to hook a usb drive, like a Jumpdrive, to te Zaurus 5500? I use many different PCs for retrieving data all are on landlines and I need a means to practacly transfer data back and forth. The only other solution I can think of is the USB host for the SD card. Any other ideas? Thanks.
craigtyson
you can use the 5500 as a usb drive with the cradel or a slimline cable. the driver to do it is on the ZUG downloads look for USB

If you wanted to use a usb device with the 5500 then you would need a USB master CF card to do so + drivers + config.
togomenu
I've looked for this for a couple of days before asking, but where does one find the Master CF USB host card you mentioned? That would be great. Were you talking about SD/USB adapters? I think I'm going that route when my SD comes in. Thanks.
craigtyson
Try http://www.ratocsystems.com/english/produc...ages/cfu1u.html
for a CF USB Host adapter with links to a zaurus driver. Iv not seen a SD version.

My other point was to get a UB cable for your Z and then use a software utility on the zaurus to make it look like a USB flash disk. the package can be got from here http://www.elsix.org/index.php?w=project&p=usbstorage_5500

It works on SHARP ROMS as far as I know.
togomenu
Well, I tried the app that makes the SL5500 look like a USB memory card and after a few different PCs and many failed attempts I am loosing hope. If my solid-state lexar can be plugged into nearly any box without much problem, other then loading a driver on older OSes, then why can't my awesome "pocket" PC, yes a little stretch, do something as basic? I'm actually just venting right now. I have no idea if there are settings I need to tweak or drivers I'm not suposed to install; on my primary home box the OS detected a new USB device and sought out the SL5500 drivers specifically, not generic memory card reader drivers. I can now use telnet and ftp with my main box and the zaurus, but that is not a solution, its more of an effect or symptom.

If anyone has experienced something similar or had a better experience, I would love to hear about it. Hope everyone is enjoying the leftovers.
togomenu
Sorry, I am using the latest Sharp ROM. The version I am running is the latest, it could be a Sharp issue.
craigtyson
I know It worked on tkc v1 as Iv used it. One thing to check though. try setting the PC link to Storage then reboot your Z. (not suspend)

Should work although I found it had problems with Win95 and usb patch.
lardman
You could also do it by hand, like my old scripts did.

Do lsmod and see whether storage_fd.o is loaded; sometimes you need to completely pull all of the usb modules and reload them as they get stuck (I could never be bothered to find out why).


Si
togomenu
Thanks. I am going to try that in a bit.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.