Help - Search - Members - Calendar
Full Version: zRoadmap can't find maps
OESF Forums > General Forums > General Support and Discussion > Software
Anonymous
I've been trying to install and use zRoadmap, but it appears that it cannot find any maps.

I've successfully installed zRoadmap_1.0-2.arm.ipk on my Zaurus 5600, which uses the latest Sharp ROM. (I had also tried this on Zynergy, but with the same results).

I put the usdir.rdm.tgz and usWA.tar.tz files in the QtPalmtop/share/roadmap directory of my compactflash card, and "gunzip"ed and "tar xf"ed them in place.

When I launch zRoadmap the first time, a Warning dialog box appears, saying "An error occurred when opening the". Apparently, it doesn't have room to complete the message. I tap the OK button, and RoadMap opens, but it displays nothing. When I choose "Map Disk Space" from the Find menu, the program says that there are 0 maps.

There are supposed to be three valid locations for maps:
/opt/QtPalmtop/share/roadmap
/mnt/cf/QtPalmtop/share/roadmap (the one I am using)
/mnt/card/QtPalmtop/share/roadmap

The behavior is the same if I move the usdir.rdm file to the path in /opt .

The /opt path has a symbolic link in it, so it really maps to /home/QtPalmtop/share/roadmap . I notice that this directory contains the preferences, schema, and sprites files. However, if you change the prerence settings in the program, the preferences file is saved to /home/zaurus/.roadmap/preferences . This is also where RoadMap's trips directory lives.

I'm discouraged and desperate; having street maps and a "find address" feature is, for me, the killer PDA app. Can anyone who is running zRoadmaps successfully clue me in?

thanks
RichS
I recently fought with getting zroadmap to work from sd card. I had about the same problems you're having now. Unfortunately, I have no short term memory and don't write things down...

I do see that I had modified the prefs file. It doesn't look modified to me and I don't remember making any actual changes to it, but I have a copy in my test_files folder. I also noticed that I have the permissions set to zaurus qpe instead of root. I think I made that change. There are two locations for the prefs file NOT on your card. I changed both...

I do remember getting the same errors, but then it just ran, but with a blank screen (meaning no map). It wants to get a location from a gps! You either have to find a location or enter one in. It woudln't accept my coordinates, but it did find a location for me and from there everything just worked fine with no more errors.

And the Map Disk SPace reads zero on mine also, along with being slightly distorted. I would chaulk that up to a bug...

If you can get the software running and get the blank map display, try finding a location. It seems to work fine once it knows where it is...
Anonymous
Thanks, I tried several addresses, and finally got zRoadmap to show a map. For anyone else trying to get zRoadmap to work, here's my tips:

1. Installing on the standard Sharp ROM for the 5600 should work fine, but getting it on the same machine using the Zynergy ROM is more complicated. You have to take the zRoadmap ipk package, un-tar it, then re-package using ar. (I don't have the detailed commands, maybe "tar -xf filename.ipk" and "ar blah blah blah"). You then install it from the console (or terminal) with the command "ipkg-new install filename.ipk". It will complain that it couldn't find one dependency, but ignore it. After it installs, use the Shutdown utility in the System tab. Don't actually shutdown the Zaurus, just click "restart Qtopia" in the Shutdown utility. This reloads the tabs, allowing you to start the zRoadmap program.

2. You'll need to put the usdir.rdm file in /mnt/cf/QtPalmtop/share/roadmap/ . Untarring this file from its usdir.rdm.tgz file requires two commands "gunzip usdir.rdm.tgz" and "tar -xf usdir.rdm.tar". (Perhaps this is obvious, but I someone had told me there was a way to do it in one tar command, but I couldn't get it to work successfully.) You'll need to do the same with one of the state map file archives to actually have maps.

3. When you first launch zRoadmap, it will complain that it can't open some file, though it probably leaves off the name of the file. Ignore this.

4. As RichS pointed out, zRoadmap will display a blank screen when you first start it. You have to tell it where to start bying entering a location, intersection, or address. I could not get it to find a location by latitude/longitude or intersection, and had to try a lot of addresses before it recognized one. Try entering an address that uses a named street (try "300 Elm", rather than "300 32nd"), and keep trying until you get a result. Once you find enter a recognized address, a map appears.

Impressions:
Unfortunately, zRoadmap is not that useful for someone who doesn't use a GPS device. I'm grateful to the volunteers who created it, but I'm looking for something that could function like a paper street map with a brain. The program doesn't display maps in a very readable way. Streets appear only as thin lines, and areas like lakes, oceans, or parks show only as colored outlines, without a fill. It also does not display street names. You can click on a location to see a street name and address, but you can't easily browse a map.

I also found that zRoadmap couldn't find a lot of addresses in Seattle, saying that the street name was not found. However, clicking on those same streets would show the street name. I suspect that its "find address" feature doesn't recognize streets with numbers rather than names.

I don't make these criticisms to disparage the folks who created Roadmap and zRoadmap. I provide this info as guidance for anyone who is looking for PDA map software.
tsackett
Oh, one more thing. If you run into problems with zRoadmap, there is an error log in /home/zaurus/.roadmap/postmortem . Note the '.' before 'roadmap'; it's a hidden directory that you can only access, I believe, from a terminal.
n8a
tsackett – i just recently got zroadmap running and i, too, wish that it a) would display/know about actual objects: municipal buildings, perhaps stores/hotels, etc. and cool.gif that it would replace mapquest.

i realize that the former is a BIT of a stretch and would require a multi-gig card wink.gif, but i certainly believe that the latter is doable, and i hope that – as zbones stated in a previous thread – the release of the SL-6000 and the continued popularity/increased use of this propels the development of zroadmap and other gps tools along. i’d gladly pay for some decent gps software. GLADLY.
n8a
Well, there is slight hope for some of the functionality that you/I are looking for. From the roadmap site:
“RoadMap is at an early stage of development. At this time there are no routing features implemented yet. The plan for the future is to implement some navigation features similar to those found in commercial street navigation systems. The main limit for implementing routing is the lack of navigation information in the US Census Bureau database (for example one-way street are not indicated). The US Census Bureau has clearly indicated that it does not plan to add these information in the future (the USCB does not need them).”

It doesn’t sound extremely hopeful, however, as they’d potentially have to find a reliable resource for one-way streets, best routes, etc.
spaul
The problem, as i understand it, is that maps sufficiently detailed to generate mapquest like directions, cost money. Seems reasonable as detailed maps do reflect intellectual property. I wish someone would modify zroadmap or gpsdrive or another linux gps ap so that it could input maps and generate realtime (correct as soon as you get lost) verbal directions from a popular and cheap widows maping program. I, and i suspect many here, would be happy to pay to have verbal directions from a zaurus. Right now i'm using an old windoze laptop (iguidance) and plan to use an ipaq for my wife's car
zbones
The only real hope here is that somebody release a commercial app for the zaurus (maybe with the new 6000 this may happen) or somebody discovers how to use the data from a commercial app from another machine.

With the exception of zroadmap (which I can't use as I am in the UK) all the other offerings use bitmaps for map data. This is great for telling you where you are, and also displaying points of interest around where you are, but cannot ever hope to guide you other than by a pre-coded route. The data needed simply isn't availible unless a group of people club together and license it.

You canot hope to get this functionality without the machine *knowing* about roads around you and whether they are one way streets, roundabouts or crossroads. Even if people clubbed together and provided gps co-ordinates of all major road junctions, this would be a huge task, and the data would be out of date even before it was actually completed.

The only real hope (other than somebody releasing a commercial app) would be to get a company to license their map data for use with a gpl app. A lot of trust would have to be placed with the developer(s) not to abuse this information. Maybe it could be possible to release a gpl app with no maps, that could decrypt and use some commercial maps that the user would need to buy/license for a fee close to that of buying a commercial pocket pc product.

If anybody wants to know how to get qpegps to guide you down a preselected route from autoroute (no voice commands yet) then ask me as this is fairly easy, but a little fiddly to do.

Peter
tsackett
One possible solution to a lot of these problems would be to create a Linux app that could read the format of Microsoft's Streets & Trips maps and their exported Pocket Streets map files (for Pocket PC). I'm pretty sure these maps use proprietary map data (which includes routing info, business, landmarks, attractions, etc), which you license from Microsoft when you buy the Streets & Trips package. Microsoft also gives away free maps that lack address information. It would be worth buying the MS software to get access to the map data.

By the way, I was just taking another look at the display of Pocket Streets. The main differences seem to be:
- color fills for parks, water, etc
- labels for cities, landmarks, and streets that appear/disappear depending on the scale and density of the map
- thicker lines for arterial roads, at some scales

At high zoom levels, the zRoadmap display looks just like that of Pocket Streets, with the exception of the labels.
n8a
QUOTE
At high zoom levels, the zRoadmap display looks just like that of Pocket Streets, with the exception of the labels.


but those labels are so dang important on a map! wink.gif

Seriously, it's almost a shame that zRoadMap gets as far as it does, as it basically is just a major tease - even telling you the upcoming street... but not giving you directions to locations or general map details.
Ethereal
I'm having the same problem--zRoadmap claims there are no maps. I've put usdir.rdm and all the usFL maps (untarred) into /mnt/card/QtPalmtop/share/roadmap, and I've changed ownership of all the files and directories to zaurus:qpe, but zRoadmap still finds no maps.

Ideas...?
RichS
did you manually enter in a location? Mine wouldn't work till I did. And after that, you have to set a zoom level or you still won't see anything.

I haven't looked into it (cause I got it to work), but my impression is that it defaults to getting the location from a gps. No gps and it probably goes to 0-0 for a location, which wouldn't be on any map.

What does it say when run from the command line?
Ethereal
Actually, I have gpsd running, and I have a three-sat fix (according to qpegps). I've tried looking for several, very simple street addresses (which I know exist); zRoadmap says they don't. I got what looked like a map for about 15 seconds while editing the "default zoomlevel" under the genereal tab in File > Preferences, but haven't been able to reproduce that, either.
RichS
Well, we know it does work which doesn't help... But if you got some kind of map, then it probably does. There are quirks though.

If it can't find the street address you entered, then it either doesn't know about it or you didn't enter it the way it's looking for it. You have to find one that it says it knows. Then you'll at least be inside a map and can play with the zoom level and move around to find something.

Try different numbers, case and abbreviations such as "123 Main Street", "123 main St", "123 main st" or just "123 main". But find someting that works.

And when run from the command line, it should put out messages that mean something...
Ethereal
OK, with gpsd running and having a valid satellite fix (I checked via telnet), here's what roadmap had to say:

ASSERT: "n < 1073741824U" in kernel/qgfxraster_qws.cpp (2843)

But I don't even know where to begin with that...
RichS
There's an error I can't help with...

My first suggestion would be to simplify. Don't run the gpsd. Run zroadmap by itself and find a location & map. Then add the gps. Maybe zroadmap by itself will either work or generate an error we'd understand?
Ethereal
OK, without gpsd running, and after adding a symlink to placate zRoadmap's expectation of findng fonts in /usr/local/qt-embedded/lib/fonts (only a problem when launching from the command line...?), all roadmap has to say is:

== roadmap_gps.c, line 232: cannot access GPS source gpsd://localhost

which is only to be expected, but still no maps, no ability to find any of several street addresses, and no files are listed under "Map Disk Space" or "Delete Maps."

Slightly more info:

$ ./roadmap --debug
-- roadmap_dbread.c, line 380: Opening database file usdir.rdm
== roadmap_gps.c, line 232: cannot access GPS source gpsd://localhost

So it claims it's opening the appropriate top-level database file (with no subsequent error message to suggest that opening failed), but it doesn't seem to actually be deriving any information from it.
RichS
I don't remember any font problem?

When I run roadmap fro the command line I get:

roadmap
== roadmap_gps.c, line 232: cannot access GPS source gpsd://localhost

and it runs, displays a map and generates no other messages.

My roadmap maps & preferences reside in: /mnt/card/QtPalmtop/share/roadmap/

The rest of the files reside in: /home/zaurus/.roadmap/

Take a look at the postmortem file in this directory. It may offer better messages related to your problem. And just for the heck of it, have you tried running it as root?

If postmortem doesn't show anything, then I would be pretty much out of ideas beyond the generic of low memory, crad problem, permission problem, etc...
Ethereal
Actually, I tried running it again with gpsd running and fixed, and in --debug mode, it gave the wierd ASSERT error I mentioned before, but went on to say it was opening usdir.rdm and then two of the numbered maps, which I presume corresponded to the location from gpsd. Still no display, however.

~/.roadmap/postmortem contains only messages about losing satellite fix.

Just in case: what is a reasonable default zoom level? 20 is the initial value, and I've stayed around there, but I guess that could be a wildly unreasonable number that results in a map too big or small to meaninfully display...
RichS
do oyu get the roadmap screen & menus?

My default zoom is also 20. Always meant to change that because it's not a good number.

I checked my session file. The General Zoom is set to 150, and that has a view of about 1/4 mile or so.

I just entered in a new default zoom of 200 and it was a nice value. About a half mile. I also managed to crash the program by trying the default zoom of 20, zoom in, zoom in, zoom in...lock-up... Nice program but not without bugs ;-)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.