Help - Search - Members - Calendar
Full Version: Opera
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
Pages: 1, 2
Cresho
1st install

opera_sl-5x00-7.30.9965_arm.ipk or Opera 7.55

2nd install

opera-cseries-fix_7.30_arm.ipk


third.

just because you installed these, it does not mean that you can bookmark since permissions are changed. in order for you to bookmark or save settings in opera, you need to change permissions for a certain directory.

change permission in /home/zaurus by
in the terminal
excuse my messy code but i hope some one can correct me

CODE
# su
# chown -R zaurus:qpe /home/zaurus/.opera
# chmod 700 /home/zaurus/.opera


use Zeditor and go to-
/home/zaurus/.opera/opera.ini
change
Scale=100
to
Scale=90

runs about 1000% faster. you can find the files by googling it. make sure it stays at 90% or it will be slow again....use the magnify to keep settung at 90%

I recommend qkonsole for a terminal. after install....hold icon down to open up new menu and the you can uncheck magnify. After that, you can issue those commands. I forgot to mention to change the font size since by default, its tiny.

change icons from boring look to modern cool look worthy of opera.
replace icons in /home/QtPalmtop/opera/buttons
dougeeebear
I see this post is pretty old (with no replies, I might add).
Anyway, I just received my new SL-C1000 yesterday, and I had the permissions problem you described after I installed Opera 7.55.

Thanks to your code, it now works perfect,

I really appreciate that info.

Regards,
Doug
Cresho
7.55? were? I am out of touch from opera but still use the old one.
chyang
http://zaurus.mol.ru/feed/operac3k_7.55.6079-c3k-2_arm.ipk

Oh, I haven't noticed that you are still using the 7.30 version.
Cresho
tried it on my z and opera dies after it appears. even after permission change.
dougeeebear
QUOTE(Cresho @ Jul 16 2006, 06:07 PM)
tried it on my z and opera dies after it appears.  even after permission change.
*

Try this one.
You still need to install opera-cseries-fix_7.30_arm.ipk
MrStaypuft
Hi,

I have an SL-C3200
I am running the Sharp Rom
My PCLink is configured for TCPIP advanced

I have installed Opera 7.55 as the instructions here documented.

It runs fine when I have my wireless network active (CF wireless card).

If I am USB connected to My PC (without the wireless connection) it gives me "no network connection" errors.

Netfront works fine in both environments.

Is it possible to run Opera over the USB network connection?

Thanks!
Cresho
Okay...this is important. I figured out something about opera 7.55 and same for the 7.3. The problem is big images load piss poor slow. I could'nt understand why it loaded slow in landscape but worked great in portrait. I found a workaround.

use Zeditor and go to

/home/zaurus/.opera/opera.ini

change

Scale=100

to

Scale=90

runs about 1000% faster
Cresho
I just updated everything. thanks guys. You added a better expirience to the opera for the c series. Look at the first top post for install instructions.
MrStaypuft
Thanks for all the info - any idea about my query?

Also (sorry if i seem stupid but hey it's early in my experience)

I've tried changing the text size by editing /home/zaurus/.opera/opera.ini
and changing the minimum font size to 10 (and 12)

I save this and it looks OK (I go back into editing it and it's still there)

however when I run Opera it has small fonts and then if I exit opera it's saved opera.ini back there with the nimum font size of 6!!

Thanks for your patience.

Stephen
Cresho
QUOTE(MrStaypuft @ Jul 17 2006, 07:59 PM)
Thanks for all the info - any idea about my query?

Also (sorry if i seem stupid but hey it's early in my experience)

I've tried changing the text size by editing /home/zaurus/.opera/opera.ini
and changing the minimum font size to 10 (and 12)

I save this and it looks OK (I go back into editing it and it's still there)

however when I run Opera it has small fonts and then if I exit opera it's saved opera.ini back there with the nimum font size of 6!!

Thanks for your patience.

Stephen
*



if you are using z editor, hold down icon and tick use root priv. you cannot edit files in other cases until done so.
dougeeebear
QUOTE(Cresho @ Jul 17 2006, 09:01 PM)
change

Scale=100

to

Scale=90

*

Wow!!!
You must have really good eyes smile.gif
I brought mine up to Scale=180 for the default.
It causes more horizontal scrolling, but at least I can read it.
Glad to see you've got it working.

And thanks for the cool buttons.
dougeeebear
@Cresho:
The opera buttons are very cool.
I do have one question though.
When there are no back or forward pages to go to, the location where the icon displays is just blank.
It does the same thing with the default buttons.
Is there any way you know of to display disabled back/forward buttons when no back/forward pages are available, instead of just the blank space?

Regards,
Doug
Cresho
I cant remember if those blank spaces occur with the default one....does it?
dougeeebear
The blank spaces do also occur with the default buttons.
It would be really nice if those empty "holes" could be filled in with disabled buttons when they aren't active.
I haven't found a way to do it though.
harvell
I noticed the toolbar icons are really small.... I tried loouking up the ini file to increase the pixels however can't.... Any Ideas????
MrStaypuft
Hi Thanks for your reply - I am doing this from vi on a console after running SU and as I said i check the ini afterwards and it has been modified - it only sets it back to 6 after I run opera again.

Any Ideas?

QUOTE(Cresho @ Jul 18 2006, 04:19 PM)
QUOTE(MrStaypuft @ Jul 17 2006, 07:59 PM)
Thanks for all the info - any idea about my query?

Also (sorry if i seem stupid but hey it's early in my experience)

I've tried changing the text size by editing /home/zaurus/.opera/opera.ini
and changing the minimum font size to 10 (and 12)

I save this and it looks OK (I go back into editing it and it's still there)

however when I run Opera it has small fonts and then if I exit opera it's saved opera.ini back there with the nimum font size of 6!!

Thanks for your patience.

Stephen
*



if you are using z editor, hold down icon and tick use root priv. you cannot edit files in other cases until done so.
*

Cresho
QUOTE(MrStaypuft @ Jul 18 2006, 08:26 PM)
Hi Thanks for your reply - I am doing this from vi on a console after running SU and as I said i check the ini afterwards and it has been modified - it only sets it back to 6 after I run opera again.

Any Ideas?

QUOTE(Cresho @ Jul 18 2006, 04:19 PM)
QUOTE(MrStaypuft @ Jul 17 2006, 07:59 PM)
Thanks for all the info - any idea about my query?

Also (sorry if i seem stupid but hey it's early in my experience)

I've tried changing the text size by editing /home/zaurus/.opera/opera.ini
and changing the minimum font size to 10 (and 12)

I save this and it looks OK (I go back into editing it and it's still there)

however when I run Opera it has small fonts and then if I exit opera it's saved opera.ini back there with the nimum font size of 6!!

Thanks for your patience.

Stephen
*



if you are using z editor, hold down icon and tick use root priv. you cannot edit files in other cases until done so.
*


*




No idea. I have the same issue. I tried it.
MrStaypuft
Hi,

Thanks for trying it - I noticed you said in your setup instructions to change the font size - how did you do that if it wasn't by changing the .ini file?

I couldn't see a setting elsewhere for it.

Thanks

QUOTE(Cresho @ Jul 19 2006, 04:04 PM)
QUOTE(MrStaypuft @ Jul 18 2006, 08:26 PM)
Hi Thanks for your reply - I am doing this from vi on a console after running SU and as I said i check the ini afterwards and it has been modified - it only sets it back to 6 after I run opera again.

Any Ideas?

QUOTE(Cresho @ Jul 18 2006, 04:19 PM)
QUOTE(MrStaypuft @ Jul 17 2006, 07:59 PM)
Thanks for all the info - any idea about my query?

Also (sorry if i seem stupid but hey it's early in my experience)

I've tried changing the text size by editing /home/zaurus/.opera/opera.ini
and changing the minimum font size to 10 (and 12)

I save this and it looks OK (I go back into editing it and it's still there)

however when I run Opera it has small fonts and then if I exit opera it's saved opera.ini back there with the nimum font size of 6!!

Thanks for your patience.

Stephen
*



if you are using z editor, hold down icon and tick use root priv. you cannot edit files in other cases until done so.
*


*




No idea. I have the same issue. I tried it.
*

Cresho
I did exactly what you did and it did not work. I changes it back to 6. you can zoom in though. hold magnifying glass icon down and you can adjust zoom in and fonts ill get bigger.
Cresho
crap, i had to redoo the instructions. it was very uninformative. ph34r.gif
Jon_J
I took Cresho's buttons and reduced them from 32x32 to 28x28
Meter buttons are reduced from 46x28 to 28x17
These match the size of the original buttons.
The "Holes" where the back/forward buttons were, will now be octagon shaped, (I'm not sure why this is.)
Extract buttons28 folder and rename it to buttons when placing in /home/QtPalmtop/opera
I renamed my originals to "buttons-bak"
dougeeebear
The "holes" take on the shape of the icons.
Jon_J
The "Holes" are round with the 32x32 buttons.
Anyway, that isn't the reason I'm posting.
I just discovered an undocumented feature. smile.gif
The 'H' key doesn't bring up Global History, like I've read about elswhere.
I have the 7.25 version from Cacko feed installed.
Just type this into the address bar, (accessed with the 'G' key)
opera:history
then hit Enter.
You can also now save it as a bookmark. smile.gif
dougeeebear
I made some arrow shaped back/forward buttons, and the "holes" took on the arrow shapes.

opera:history is a good find smile.gif
Jon_J
I wonder what other "commands" can be used this way?
opera:about = blu/silver screen with about info and paths.
opera:history = brings up global history page with most all previous sites visited.
opera:cache = opens cache page that shows [Filename] [Size] [Address] but the cache isn't being used, so this screen is empty.

I tried opera:config, but that doesn't work.
opera:config is used in version 9, as shown on this page:
http://www.opera.com/support/usingopera/operaini/
dougeeebear
To get rid of the "hole" on the very right end of the opera toolbar, delete the following two files in /home/QtPalmtop/opera/buttons

opvoice.png
opvoicerec.png

Most likely you don't use opera's voice feature on the zaurus anyway (at least I don't).
Jon_J
QUOTE(dougeeebear @ Jul 21 2006, 05:53 PM)
To get rid of the "hole" on the very right end of the opera toolbar, delete the following two files in /home/QtPalmtop/opera/buttons

opvoice.png
opvoicerec.png

Most likely you don't use opera's voice feature on the zaurus anyway (at least I don't).
*

I don't have the hole in the toolbar you mentioned. I'm using opera_7.25-lite-2_arm.ipk
I do have them where the forward/back buttons are disabled.
Look at the screenshot, I posted above.
dougeeebear
I'm using opera 7.55.
You can download it from a previous post of mine here:

http://www.oesf.org/forums/index.php?showt...ndpost&p=135375
Jon_J
I'm sticking with 7.25 for now, since it seems to be working fine.
I downloaded it, and will install it at a later time, whenever I need to re-flash, or start over.
(I have about 20 sequential backups from within Cacko Lite)
I've edited the buttons to "match" my blue background, (which I changed a long time ago by editing the color hex values in the blu theme.)
Previously, these buttons had a lighter background that looks white against my darker blue.
I know a couple of them need touching up, but on the Zaurus screen, you can hardly see the miscolored pixels.
dougeeebear
I know what you mean.
Once I get things configured, I hate to change (if it ain't broke, don't fix it) smile.gif
Jon_J
I've been using my Zaurus a lot more lately, since it's too hot to use my desktop PC.
I noticed that the favorites folders are somewhat difficult to discern between an open folder and a closed one.
So I edited the open folder to show as blue.
This is a 28 x 28 *.png file that is in the buttons directory, (as shown in previous post on page 2 of this thread).
Copy it to your buttons directory and rename your opdiropen.png to opdiropen-orig.png
Now rename this file from opdiropen-blu.png to opdiropen.png
I've posted a screenshot to show how it looks in Opera's bookmarks.
BTW, this is a 28 x 28 image and is intended to be used with the "buttons" files that I posted on page 2 of this thread.

EDIT, I know this isn't the best looking folder out there, but I haven't figured how to make Cloverpaint save to 28x28 instead of 480x640.
(It adds the entire background space, in it's window, to any image you save.)
I used Visual-Q to "reverse" the color.
kenknight
OK, this is definitely a question I hate to ask. But I am running Opera 7.30 on a C1000 with basic Sharp ROMs. I believe the C series fix is installed but am not certain (Opera does work and appear in landscape mode just fine).

But, when I click/hold the magnifying glass all I ever get is the Find dialog even though the Help says I should get the scaling slider dialog. What am I doing wrong?
dougeeebear
kenknight,
Try the +/- button smile.gif
kenknight
Yah, I thought they used to be on the screen someplace, I recall them on my 5600 but they're nowhere to be seen on the C1000.

QUOTE(dougeeebear @ Aug 3 2006, 06:03 PM)
kenknight,
Try the +/- button smile.gif
*
dougeeebear
Check in Add/Remove Software if you have opera-cseries-fix installed.
If not, you might have to install it.
I also have an SL-C1000 with the stock sharp rom, and all the icons show up for me.

In the meantime, you can just hit "S" to bring up the scale dialog.
kenknight
I should have been more specific. Afer I wrote the first message I did check and I had just not seen the cseries fix was installed. Very strange.

And very irritating that somehow I completely forgot about the S key and scale. Sheesh.

Now if I can just get VisualQ to run. The package I've found so far isn't be recognized by the Z. Sigh... Always something.

Thanks.

** Ken **

QUOTE(dougeeebear @ Aug 3 2006, 07:36 PM)
Check in Add/Remove Software if you have opera-cseries-fix installed.
If not, you might have to install it.
I also have an SL-C1000 with the stock sharp rom, and all the icons show up for me.

In the meantime, you can just hit "S" to bring up the scale dialog.
*
dougeeebear
Also, if you want to upgrade, you could give opera 7.55 a try.
It's available here
You still need to have opera-cseries-fix installed.

See this post for installation procedure.
xamindar
What does the c-series fix do anyway?
I don't think I have it installed and opera seems to work fine.
xamindar
Ahh thanks dougeeebear.

I have another question. I went up to the opera 7.55 version and was wondering how to change the font size. I tried changing the setting in the ini file from 6 to 10 but there was no change in opera. Is that setting invalid?

How do I get the column mode to be the full width of my c-series zaurus instead of only a third of the screen width? Looks like it is still set to a 5x00 screen width. The c-series fix package didn't appear to fix this part.
bam
my simple question is where is the source for 7.55 or greater for zaurus so I can build it myself and hopefully find a fix for the bloody font dealie.
kellyharding
QUOTE(bam @ Aug 4 2006, 08:53 PM)
my simple question is where is the source for 7.55 or greater for zaurus so I can build it myself and hopefully find a fix for the bloody font dealie.
*


Opera is closed source/commercial.

Kelly
dougeeebear
QUOTE(xamindar @ Aug 4 2006, 01:47 PM)
Ahh thanks dougeeebear. 

I have another question.  I went up to the opera 7.55 version and was wondering how to change the font size.  I tried changing the setting in the ini file from 6 to 10 but there was no change in opera.  Is that setting invalid?

How do I get the column mode to be the full width of my c-series zaurus instead of only a third of the screen width?  Looks like it is still set to a 5x00 screen width.  The c-series fix package didn't appear to fix this part.
*

1- The font size is controlled by opera
2- Try the layout mode toolbar button (check the help file)
xamindar
QUOTE(dougeeebear @ Aug 4 2006, 02:43 PM)
1- The font size is controlled by opera

Ok, so there is no way to change it sad.gif
QUOTE
2- Try the layout mode toolbar button (check the help file)
*


I don't see how that will fix the issue with column mode. The opera 7.25 that I was using before has it correct. I guess there is no benefit to upgrading opera.
dougeeebear
QUOTE(xamindar @ Aug 4 2006, 05:07 PM)
I don't see how that will fix the issue with column mode.  The opera 7.25 that I was using before has it correct.  I guess there is no benefit to upgrading opera.
*
Strange, 7.55 works great for me.
patrickcptsang
For changing font size, try edit /home/zaurus/.opera/opera.ini and add/edit:

[Font.Normal]
Height=20

Don't know how to set the column mode. It seems like the column width is hard coded for 320x240 devices.
dougeeebear
Well guys, 7.55 might not work as expected if you installed it over the older version, or even if you uninstalled the older version, and then installed 7.55.

That would mean you still had opera-cseries-fix_7.30_arm.ipk installed, and you probably wiped out the changes it made.

So I think you would need to uninstall opera-cseries-fix_7.30_arm.ipk as well at that point.

Then install opera 7.55 first, then install opera-cseries-fix_7.30_arm.ipk again.

That's my educated guess and theory.
xamindar
I don't think you understand what I mean. Here is a screenshot of opera 7.55 in column mode. You see how it only takes up a little side of the screen? It is supposed to fill the whole screen. I hope this is not hard coded in opera. Can it be changed in the ini?


So you don't have this problem with that version of opera, dougeeebear? I may just reflash my Zaurus soon anyway I guess and start fresh. It seems my IR has stoped functioning recently ?!?!
Cresho
yeah thats normal.. no source i guess.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.