Help - Search - Members - Calendar
Full Version: How Can I Use The 'at' (atd) Package Under Oz?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
grog
Hi all. I have need to get atd working on my poodle, but haven't had any luck. I've tried installing both the at & the atd packages without luck. While the 'at' package seems to have everything it needs (except the init.d script) & atd seems to run ok, it dies as soon as I try to submit a job. The 'atd' package only has the atd binary & the init.d script, but has no 'at' command. Trying to combine the two doesn't help; when the at command is issued it complains the atd daemon isn't running (when it is).

I tried replacing the call to the atd binary in the init.d script with a script to redirect it's output to a log:

CODE
$ cat /usr/sbin/atd-log
#!/bin/sh
exec 1>>/var/tmp/atlog 2>&1
exec /usr/sbin/atd


But that just produces an empty file, regardless of which atd binary I use.

After some searching (NB: don't try searching for 'at'. Doesn't get you very much usefull info smile.gif), I found this post, which seems to indicate that there's some problem with using atd in OZ in the first place. So has my quest been in vain?

thanks in advance
grog
I decided to 'play' with this again, now in OZ/GPE 3.5.4. Still the same problems, already reported in bug 470. One difference now under GPE is that the gpe-calendar tries to use atd & gpe-announce for it's popups, which *sometimes* works, but once in a while atd decides to bite the biscuit (die).

My first query is of course why is it dying. Second, how is gpe-calendar creating the atjobs files without the at command? Must be a manual process which I'd LOVE to reproduce.

Any comments welcome. Otherwise I'll continue talking to myself smile.gif.
grog
(might as well continue my ramblings ... smile.gif)

I've discovered that gpe-announce is a program separate from gpe-calendar which displays a given message, plays an alarm (as long as /dev/mixer isn't currently locked by another process, that is) and prompts for dismissal or snooze time. If you snooze, it creates a file under /var/spool/at/ which is then picked up by atd at the appropriate time.

Running gpe-calendar from a terminal allowed me to see this message when I tried to set an alarm for an appointment on 2006-04-31 @ 1400:

CODE
/var/spool/at/1145646000.104-100: No such file or directory

Sure enough, that file doesn't exist. gpe-calendar also showed it's error message box about there being an at daemon problem, which previously led me to assume atd had died. I'd love to figure out what the file name has to do with the time of the alarm. UNIX time?

So it seems that gpe-calendar has problems creating alarms for future events(?). In any case, even if the file was created, /var/spool is a volatile filesystem which is recreated on each reboot, so they'd be lost. That should be added to /etc/default/volatiles/00_core & symlinked to a non-volatile placeholder.

enough for now. Stay tuned for more exciting updates smile.gif
grog
I may as well continue adding to this 'journal' in case future generations are interested in the ramblings of that strange guy that called himself 'grog' smile.gif

I've entered a couple of new bugs: 887, 888 & 889. That about covers what I've discovered so far.

I also hacked an 'at' script so I can easily create my own atd events. Only thing is that it seems that atd only 'wakes up' every 10 minutes or so (if at all, a little flakey), not so great for my purposes. I'm going to look into a way to increase that.

'til next time.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.