Help - Search - Members - Calendar
Full Version: Bluetooth Gprs C3100 And Se W800i
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
xfaethorx
Hi guys,

I'm hoping someone can help here...

I've installed all the required bits and bats to get bluetooth working on the C3100.

I've been able to get my phone (sony w800i) to see my zaurus.

My phones GPRS settings are correct and i've followed everything to the letter on this site

http://www.filesaveas.com/gprs.html

my issue comes down to this...

if i supply the:

+CGDCONT =1,"IP","apn.address"

into the dialup(bluetooth) module , modem tab init string field

and try to connect I can see that blue tooth traffic is beggining but the modem does not initialize it just eventually times out after hanging on initializing...

however if this string is actually left as

ATZ

the phones modem is invoked and the connecting splash screen is shown, the zaurus says connected but the phone then drops out with an error saying the configuration settings are wrong and thus the gprs is not established.

I've tried hand editing the scripts for this to see if i can get any further but i'm completely stuck.

some sites have suggested changing the dial string to

*99***1# where 1 is the CID and leave the modem string blank but this doesn't work either. The ATZ is required as far as I can see to invoke the modem but after that I'll be f*cked if I can work out whats happening!

If anyone can help i'd appriciate it


xfx
xfaethorx
Just a bit of further info, I updated my phones firmware to the latest version to ensure that everything is working in that regard. However I've still got the same problem i cannot connect to the net via GPRS.

Is there any step or setting that I might have missed for setting up the bluetooth device?

i've used the information from here which seems spot on as when I start the network service the devices pair the first time round.

http://www.zaurususergroup.org/modules.php...ename=Bluetooth

it just says initalizing modem and then eventually goes to network offline using the guide found here http://www.filesaveas.com/gprs.html

it looks like the pairing is correct just nothing else is working sad.gif

help!
rob_figlabs
Try putting

QUOTE
ATZ+CGDCONT=1,\"ip\",\"apn address\"


into the modem init string box.
xfaethorx
hi, i've already tried that and it doesn't work sad.gif

from what i can gather , and this is my current thinking is

that all i need is the ATZ to get the modem up

and use

*99***X# where X is the right id of the profile, however so far, thats not worked either but i think this is how it is ment to work with the SE phones. From what I've read im not the only person and nor is the Z the only PDA that has problems with this.

I'll do a bit more digging and see what happens
xfaethorx
just doing a bit of testing with this, its still doesn't work but

ATZ+CGDCONT =1

or

ATZ +CGDCONT =1

however

ATZ +CGDCONT =1,"IP","goto.provider.uk"

doesn't

I've tried

ATZ +CGDCONT =1,0,0 and that fails as well

I'm wondering if the ppp peers file is having trouble with the characters,

but I have created a stand alone script for this before and pointed the peers file to that rather than an input string and this still doesn't work sad.gif

I'd really really like to know if anyone has had success with Zaurus GPRS!
xfaethorx
right! bloody buggering thing

I've done a bit of reading around and i've found the /tmp/bluetooth-pppd-log

inside that i can see the chat stuff getting established and the phone and pda negotiate the initialization

abort on (NO CARRIER)
abort on (NO DIAL TONE)
abort on (BUSY)
send (ATZ^M)
expect (OK)

ATZ^M^M
OK

-- got it

send (ATDT*99#^M)
expect(CONNECT)
^M
ATDT*99#^M^M
CONNECT

-- go it

Serial connect established.
using channel 10.
usign interface ppp0
Connect: ppp0 <--> /dev/rfcomm0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb45a5766> <pcomp> <accomp>]
Timeout 0x20084bc:0x203b440 in 3 seconds
rcvd [LCP ConfReq id=0x1 <auth pap> <accomp <pcomp> <asyncmap 0x0> <magic 0xd21674c1>]
lcp_reqci: returning CONFREJ.

<MORE REMOVED FOR EASE OF READING>

LCP: timeout sending Config-Requests
Connection terminated

abort on (NO DIALTONE)



Now i've successfully tested the device with the phone and my laptop running windows and I've been able to get net access with no issue.

so its deffo something on the zaurus at this stage
z_mentor
I have connected to the Internet with a C3000, a Longshine USB bluetooth dongle, the usb host cable and using several Nokia mobile phones:6680, 9500, 6230, 6310i.

I have checked my log in /dev/shm/tmp/qpe-pppd-log and I have noticed this difference with your log:

Your line: lcp_reqci: returning CONFREJ.

(connection rejected)

My line: lcp_reqci: returning CONFACK.

(connection acknowledged)

This means that from the first time your Zaurus fails from the first time it attempts to establish two-way connection because the default options instruct it to detect dial tone.

You can try one of the following to force it to disable dial tone detection:

1) Use the command ATX0 as the initialisation string or append X0 to your current initialisation string.

2) In the terminal:

ls /etc/ppp/peers/

You will see several files like DIALUP11123434 or IRDA124342 or BLUETOOTH242342342. Note the file beginning with BLUETOOTH****** because these is your dialup (bluetooth) profile files. Use this file on the command below:

vi /etc/ppp/peers/BLUETOOTH******

Go to the 3rd line and delete the portion which says:

ABORT "NO CARRIER" ABORT "NO DIALTONE"


Good luck with your efforts.

Please report back if you have success so that others can benefit.
xfaethorx
thanks for the information.. I thought it might have been that before..

however I've now run through your suggestions and a few others i decided i'd try myself (like removing all the aborts).

the result is sadly the same..it wont work sad.gif


now the questios are could it be the dongle

1. (ie its driver support) ? its a USB huatong HSK-BTHADTU ( tbh i doubt that to be the case because I wouldn't have expected it to do as much as it can if it didn't work!).

2. is it the phone? I'm wondering if theres something more specific to do with the phone? has anyone else had success with GPRS a Zaurus and a sony erricson phone?

3. does anyone know of any good sony erricson information sites that don't actually turn out to be bloody bleeding crappy ringtone sites with bloody bleeding crap adverts and bollocks on them that make me want to set fire to people!


biggrin.gif

ph34r.gif
z_mentor
Sorry to hear it didn't work.

First of all try the suggestion of the member oliverb in: http://www.expansys.com/forumthread.asp?co...LACK&thread=291 as it looks most promising for your case.

If it doesn't work, please check the following:

1) I also believe that you couldn't go that far if you had any problems with the usb dongle. But just to be on the safe side, you can check for sure if the USB Bluetooth dongle works:

Download minicom from: http://www.elsix.org/index.php?w=project&p=923 (direct link: http://users.adelphia.net/~dyson/zaurus/minicom_2.1.tar.gz) and follow the instructions: http://users.adelphia.net/~dyson/zaurus/minicom.txt for installing it.

After you install it, run minicom -s and on the serial port enter the device /dev/rfcomm0

If minicom initializes the phone, you can try the commands ati0, ati1, ati2 etc to see if the phone will respond identifying itself.

2) I think the problem probably is in the ppp settings on the Zaurus or in the W800i GPRS Settings. I imagine that you can access the internet from within the phone. Look here for some info: http://jimmac.musichall.cz/weblog.php/2005/Aug/14

3) I have tried to search further on the internet but because it is a new phone there is not much info.


I am sure you are very close to working it out smile.gif
xfaethorx
AHAHAHAHAHAAHAHAHAHAHAH!!!! GOT THE BASTARD! I finally have a PPP connection betweeen my zaurus and my W800i


and do you know what..after going round the bloody houses to find out what the problem was

the error im getting is with regards to PAP, the authentication is failing...

why?

my provider does not require a password field so i never bothered to supply one!

after reading this snippet

" Password
Same goes for the password as for the username, if you have one, enter it here, otherwise, enter anything, just as long as it isn't empty, or PalmOS will give you an error when you try to connect."

from a website to do with Palm devices i thought well that makes sense..


added password to the password field , just so it had something...


and it connected first time! after all that..pratting around....

bloody buggering bastard thing!

now I've got a connection i've just got to find out why it wont connect to a website etc...

thanks for the help...looks like i'd have been up and running ALOT sooner if i'd bothered to add some crap in the password field sad.gif.


ph34r.gif ph34r.gif
xfaethorx
ok this might be simple it might not be...i have the device up the connection is made..

but I can't ping anything , say for instance www.google.com.

in the log file i get.


Could not determine remote IP address: defaulting to 10.64.64.64

local IP address 10.193.31.104
remote IP address 10.64.64.64
primary DNS address 149.254.1.14
secondary DNS address 149.254.1.15


could it be a routing issue in PPP? could it not be setting up the default route to pass all net traffic over the established connection now?

thats the only thing i can think off atm :S
z_mentor
I am glad to hear that you finally found it biggrin.gif

Check /etc/resolv.conf

and make sure it looks like this:

# Domain name searches will fail until you point this to a real DNS server.
nameserver 149.254.1.14
nameserver 149.254.1.15

(make sure that the ip addresses 149.254.1.14 and 149.254.1.15 are in fact your provider DNS servers)

Also, get connected through GPRS and try the command

route

on the terminal and post the results here so that we can see what happens exactly.
xfaethorx
ok this is odd,

I have no resolve.conf file...so i find that a tad disturbing as that means no dns entries would work!

i ran route

and got

10.64.64.64 * 255.255.255.255 UH 0 0 0 ppp0
default 10.64.64.64 0.0.0.0 UG 0 0 0 ppp0

which to me looks right


however when i try to ping www.google.com as its ip 64.233.183.104

i get

ping: sendto: Operation not permmitted!

sad.gif

all very confusing...

I don't think its getting the remote host properly and subsiquently I'm not getting an IP address which works as with the one given I can't find my device and i should be able to if it was online correctly. (ie i cannot ping to my zaurus when its online).
xfaethorx
one thing i have noticed is in the log file the LAST entries are

local IP address 10.193.31.104
remote IP address 10.64.64.64
primary DNS address 149.254.1.14
secondary DNS address 149.254.1.15


the /etc/ppp/ip-up script doesn't get invoked?

is that right, back init'd day im sure you should then say the /etc/ppp/ip-up script being invoked?

if its not happening then why?

my head is now turning into melted cheese


---EDIT---

as a rule PPPD SHOULD invoke the ip-up script when a connection is made as far as I am aware.

im wondering now if i should just force it to start somewhere but to me that sounds wrong sad.gif. Funny that the wlan works fine sad.gif


---ANOTHER EDIT----

i added touch /tmp/wibble

to the ip-up script

so i know its getting invoked...

i'll add some echo's to pipes to trace the file

hopefully i'll find the prob soon
xfaethorx
right I've gone through everything and i can confirm that ip-up is getting called it just doesn't appear in the log...

now heres the sting , and i think its the final part of my problem...


the w800i has 2 profiles that make up the connection theres the datacomm profile which contains the APN address and PAP settings and theres the internet settings which contains the gateway address , proxy settings and comms type i.e http.


I've done a bit of testing which involved deleteing the working profiles off my phones and creating any old one that has bum settings...

I start the network and check the /tmp/bluetooth-ppp-log and guess what , it shows that it can't find the gateway etc.

So my assumption, based on what I've been doing is this...

I'm being able to invoke the modem on the phone, but its not invoking the connection profile , wether i give it the +CGDCONT version and use *99# or if I use the *99***1# version...

I now believe the issue likes in the peers/BLUETOOHXXXXX script, I've played around with the settings to the chat app and so I'm going back to try and play with that again.

What I would appriciate from someone is an upload of their WORKING peers file with a working +CGDCONT string in it so I can ensure the syntax is correct.

My friend at work has the w800i working on another phone network and another PDA and he told me that he had trouble with the +CGDCONT string format. I guess mines something to do with that and the modem init.

I'm close to getting it working i think its just a tetchy little bitch
zmiq2
Hi,

1) certainly a lot of operators have two gprs profiles: one that does log you in a 'private' lan thing, and another which really logs you in the open internet. Look in the sony-ericsson gprs configuration web site, to have the proper settings for the second being sms-send to you


2) here's my configuration, used to connect to my SE-K700i

peers file
# more BLUETOOTH1117576746
/dev/rfcomm0
115200
connect '/usr/sbin/chat -s -v -t 60 ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT "BUSY" "" "ATZ" OK "ATDT*99***2#" CONNECT'
crtscts
noipdefault
modem
user "XXXXXX"
usepeerdns
defaultroute
connect-delay 5000
remotename BLUETOOTH1117576746
xfaethorx
thanks for that, I know the settings for my gprs are correct due to the fact that with the phone on its own I can connect to the net.

I have a question for you, I'm assuming you use 2 in the dial program as 2 is the EID of the Data comm profile (not the net profile?) do you have 2 data comm profiles or just one datacomm and one internet profile?
zmiq2
I have 3 'Data Comm' settings; first (ID #1) is the restricted network, used for phone's wap browsing, and second (ID #2) is the unrestricted internet access, which is the one I use to cennect my zaurus to the internet. Third one is for MMS sending.

So, note that I have 2 data comm settings, one for surfing the net using the phone's browser (which is capped to wap), and the second, which is the one you may not have setup.

HTH
xfaethorx
ok i've found the problem!!!!! I just now need the solution

when the ppp connection is made it finds no default gateway as it showed before.

I decided to run it through the laptop again and sure enough that has no default gatweway either, it just uses the GIVEN IP ADDRESS!

if you look back up these posts you'll see thats the problem i've been having, i get given the address 10.64.64.64 as the default remote address as it can't work it out!

This fucks the routing.

What it needs to do is to fall back to automatically routing the traffic OVER the IP address

to prove this i did

route -del default gw 10.64.64.64
route -add default gw IPADDRESS

and when i pinged google

I GOT TRAFFIC BACK AT LAST!!!!!!!!!!!!!!!!!!!!!!

Thing is I need this to be done automatically! Is there a switch in PPPD something in the peers file or the like that will do this for me! Or will i have to script it myself

at least I've found the problem! I just need the final bit!

biggrin.gif

thanks for everyone help so far !


xfx
xfaethorx
OK i've done it! its all over! Success is mine!

Device: SL-C31000
Phone : Sony Ericsson (although tbh its not the phones at fault).
Serivce Provider : Virgin Mobile (uk) (t-mobile base provider).

Network profile Applet, you don't need anything more than either

initial string ATZ

phone *99# (which will dial the default connection)

or

initial string ATZ

*99***EID# (which will dial the profile of choice on your phone).

+-- the problem --+

Failing to route any traffic from the device when no default route is provided.

gateway comes back as 10.64.64.64 (set by pppd as default).

+-- the solution --+

The default gateway address should be the same as your IP address!

fix (as long as you only use ppp0 for GPRS)

first back up your /etc/ppp/ip-up script

su

edit /etc/ppp/ip-up

at the end of the script add the following

if [ "$1" = "ppp0" ]; then

route del default gw $5
route add default gw $4

fi

save and exit

what that does is on detecting a ppp0 connection remove the default gateway (10.64.64.64) and replace it with the current assigned IP address.

I can confirm its working here as I can now ping google on an IP UP!!!!!!

FINALLY!!!!

took me a while, been round the houses a few time but I've got it. Thanks to all who supplied their help.

If a mod could (or would like too) make this sticky or add it to a howto etc the please do it as I'll probably not be the only person whos having this problem! (just drop me a credit wink.gif ).

ph34r.gif
cmonex
QUOTE(xfaethorx @ Oct 21 2005, 08:41 PM)
If a mod could (or would like too) make this sticky or add it to a howto etc the please do it as I'll probably not be the only person whos having this problem! (just drop me a credit wink.gif ).

ph34r.gif
*



hey i'll try this. have same problem as you. if this works for me ... IF... then you're a great mind then that you found out the cause and worked out the solution wink.gif


update: didnt work or i did it wrong...

edit: and now i no longer get a dns server even though i got the original ip-up file back.. guess time for hard reset or whatever is it like with linux?
rob_figlabs
As an alternative, we now have some software to take care of this for you - it contains details of most worldwide networks and their settings, as well as phone specific settings as well - you just tell it where you live, what your phone is and who your network provider is.

Have a look here: http://www.figlabs.com/catalog/product_inf.../products_id/54
cmonex
QUOTE(rob_figlabs @ Mar 5 2006, 10:37 AM)
As an alternative, we now have some software to take care of this for you - it contains details of most worldwide networks and their settings, as well as phone specific settings as well - you just tell it where you live, what your phone is and who your network provider is.

Have a look here: http://www.figlabs.com/catalog/product_inf.../products_id/54
*


hi, thanks for the link, does this software support hungarian gprs providers too? smile.gif (i'm sure my phone is supported but hungary...?)
rob_figlabs
QUOTE(cmonex @ Mar 5 2006, 02:47 PM)
hi, thanks for the link, does this software support hungarian gprs providers too? smile.gif (i'm sure my phone is supported but hungary...?)


Looking in our settings database, we have entries for PannonGSM, T-Mobile and Vodafone in Hungary. I can't say that I've been to Hungary to test it (more's the pity) but we'll do all we can to get customers up and running in areas we haven't worked in, or with phones we've not yet tried.

Thanks,
cmonex
QUOTE(rob_figlabs @ Mar 5 2006, 04:15 PM)
QUOTE(cmonex @ Mar 5 2006, 02:47 PM)
hi, thanks for the link, does this software support hungarian gprs providers too? smile.gif (i'm sure my phone is supported but hungary...?)


Looking in our settings database, we have entries for PannonGSM, T-Mobile and Vodafone in Hungary. I can't say that I've been to Hungary to test it (more's the pity) but we'll do all we can to get customers up and running in areas we haven't worked in, or with phones we've not yet tried.

Thanks,
*




hi, exactly where can i contact you about this in private if possible?

thanks!
rob_figlabs
Just send a mail to enquiry@figlabs.com.

Thanks
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.