Help - Search - Members - Calendar
Full Version: Pdaxrom Rc12 For Sl-c7x0/7500/c860/c1000/c3100
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Pages: 1, 2
sashz
SL-C7x0/7500/C860
http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/
primary feed http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/feed

SL-C6000
http://mail.pdaxrom.org/rc12/Zaurus-SL6000/
primary feed http://mail.pdaxrom.org/rc12/Zaurus-SL6000/feed

SL-C1000/C3100
http://mail.pdaxrom.org/rc12/Zaurus-C1000-C3100/
primary feed http://mail.pdaxrom.org/rc12/Zaurus-C1000-C3100/feed

Cross SDK for all devices:
http://mail.pdaxrom.org/rc12/Zaurus-7x0-86...ftfloat.tar.bz2
http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/cross-sdk.txt
http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/cross-sdk.md5sum

Native SDK for all devices:
http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/zgcc-3.4.4.img
http://mail.pdaxrom.org/rc12/Zaurus-7x0-86....4.4.img.md5sum

current pdaXrom-builder system:
http://mail.pdaxrom.org/rc12/pdaXrom-build...8.10.05.tar.bz2

current sources (full):
http://mail.pdaxrom.org/rc12/src/

pdaX86 (pdaXrom for PC smile.gif and host system for pdaXrom-builder):
http://mail.pdaxrom.org/rc12/pdaX86/pdaXrom.iso
http://mail.pdaxrom.org/rc12/pdaX86/pdaXrom.iso.md5sum

NOTE for SL-C1000/C3100 and SL-6000 users: primary feeds for this models includes only platform denepded packages. All another apps (common for all devices) need install from corgi feed (setup it as second feed in the package manager)

Quick fix list:

ALL:
apmsleep fixed in the kernel for all devices - thank to albertr (need more tests)
openbox restarting if suspend more than 12 hours (that must fix locking during long suspend - need more tests)
package manager fixed - thank to pgas!

6000
xrand support
optimization for landscape mode
hot-plug mouse support smile.gif

C1000/C3100:
all patches from rc12 test thread
rmrfchik
Nice. Will feed's packages work in rc11?
sashz
QUOTE(rmrfchik @ Oct 28 2005, 04:57 AM)
Nice. Will feed's packages work in rc11?
*

yes
ltrm
Excellent news.

I'm downloading right now.


Apart from the bug fixes, what changes can C7xx/860 users look forward to? Is this just bug fixes with enhancements for the Cxx00 models?

Many thanks,

ltrm
Laze
All how downloaded before THIS post please download again and reflash.
gromituk
Thank you very much for fixing that horrible bug. I'd been holding off upgrading from RC10 for that (although of course it suffers from the same bug); now I'll take the plunge.

Well done to all concerned!
trichmon
Ok I have been testing apmsleep with my 6000l. If it is on battery power, apmsleep +00.05 does not work. The zaurus suspends but will not resume after 5 min. No errors when I do resume with the power button. Now if I apmsleep +00:05 and wait for the 5 min to pass, then put it in the cradle it will resume. If its in the cradle when i issue the apmsleep command it will not resume unless i remove it from the cradle and put it back, where it will resume when its put back. If its in the cradle, and suspended I can not ssh into it so I know its really suspended not just with a blank screen.

If any other test or info is needed please let me know.

-edit-

it seems to be power not just the cradle that is the important part.

Todd
sashz
sorry, apmsleep still problem for C7x0 and 6000 , will see this more...
jiangtao9999
wooooo~~~
downloading....
scoutme
sashz, any news about c860 xserver optimizations? Is the versione in RC12 better than the one in RC10? Or still the same?
bazmi
sashz,

what is the url for the 'corgi feed'? thanks

/bazmi.
pgas
corgi = SL-C7x0/7500/C860
so http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/feed
sds
Are the keyboard kernel modules and driver from Kopsis for Belkin/Pocketop keyboards included in RC12?
I don't see zkbdd in the feed.
ZDevil
I feel a noticeable speed improvement in this RC. Things are more responsive and smoother than before. Actually I do find it faster than Sharp/Cacko ROM now. Bravo! smile.gif

(About to fish my credit card from the pocket ... )
bazmi
QUOTE(pgas @ Oct 29 2005, 09:15 PM)



thaks a ton!!!

cheers

/bazmi.
agraef
Just upgraded from the RC12-test release. Works great over here (Akita, Toshiba 1GB CF and 512 MB SD for storage, D-Link DCF-660W for wlan). Being able to play back videos from an NFS-mounted partition with mplayer in fullscreen still amazes me. wink.gif Native and cross devkit is also very nice and complete. And KaPI/KoPI makes for a great PIM.

Thanks a lot for this great release! Your "ROM" really turns this device into something useful. A geek's dream come true.

Cheers,
Albert
scoutme
what about Xserver improvements?
sashz
QUOTE(scoutme @ Oct 30 2005, 02:17 AM)
what about Xserver improvements?
*


yes, that compiled with better optimization with gcc-3.4.4 smile.gif
rip
freshly flashed and running fine on my z6000l
will test built in wlan tonight.
xpdf , rox, gnumeric, abiword, tipterm, gaim, fltdj installed ok. will continue testing.
juanitomaille
is it possible to have a root archive for a dual boot easily ? (like RC10.4)
I have some problems to use it now, maybe RC12 resolves it.
thanks
sashz
QUOTE(juanitomaille @ Oct 31 2005, 05:55 AM)
is it possible to have a root archive for a dual boot easily ? (like RC10.4)
I have some problems to use it now, maybe RC12 resolves it.
thanks
*


hi!

uploaded:

http://mail.pdaxrom.org/rc12/Zaurus-C1000-...t-akita.tar.bz2
juanitomaille
Oh Yes thanks!!!
you're very fast!!

Good job.
adf
Xrandr works on my 6k! fullscreen quake! mplayer! Bravo!
gromituk
Has no-one else peered myopically at the left hand side of the desktop and noticed it says "the rom with at twist?" laugh.gif
iamphet
Is anyone experiencing problems on SL-C860? My Z just hangs after installation on "Rebooting system" sad.gif Md5sums of initrd.bin,updater.sh and tools.tar are ok. After NAND Flash restore I got the working RC11 so apparently it isn't a hardware problem.
pgas
I have flashed RC12 on my 860.

Did you format your user partition?
iamphet
pgas
I did. I've even repartitioned Z after the first failure just to have a guarantee.
Root had 118M in size so I've applied a >64M fix when I flashed rc9 or rc10.
pgas
I don't repartition my Z so it's one difference.

Did you try a hard reset (by removing the AC power and the battery)?
iamphet
I can only see a blank screen after this.
pgas
Just to be sure you didn't download the .zip right after the announcement right?

There was a probleme with the first images.
iamphet
pgas
Right! Look, I am so stupid I haven't seen Laze's message. I've downloaded image right after the announcement but managed to flash it only yesterday. Thanks a lot.
clofland
Just a quick note to say RC12 is working wonderfully on my 760. Of course, RC11 did too. smile.gif
Zauruman
Not sure what you've changed but the user experience in RC12 is far better than it was in RC11 - great work. I may even keep PdaXrom as my standard OS but I have to find a way to transfer my information from Cacko first biggrin.gif
phobos13013
hi i just downloaded the new rc12 ROM and tried to contact every feed i can find but the log gives a 404 error. It looks like it is trying to add "/Packages" to every string i give as a source. I cannot install any ipks because of this. Is this a problem with a config file for the Package Manager or something because i am not aware of one. I am pleased with all the other defaults for the new ROM tho... Any help would be greatly appreciated in the meantime.
pgas
the package manager now uses /etc/ipkg.conf for a config file.

The feed http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/feed/ seems be available at the time I write this.

Do you update before installing something?
is internet working on your zaurus?

I have some doc on managing package here : http://pierre.ellh.com/ipk.txt
(if someone feels like doing correction/modification he is welcome...)
tacc2
ipkg doesn't seem to work. No matter which feed I use I get:

sed: bad option in substitution expression
Downloading /Packages ...
/Packages: Unsupported scheme.
ipkg_download: ERROR: f\Failed to retrieve /Packages, returning
ipkg_update: Error downloading /Packages
to /usr/lib/ipkg/lists/http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/feed




Any idea what's going on?
I'm using a C1000.
pgas
I think you put the url instead of the name
name should be like "myfeed" and the url http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/feed


in ipkg.conf (from memory)
QUOTE
tacc2
QUOTE(pgas @ Nov 3 2005, 11:15 AM)
I think you put the url instead of the name
name should be like "myfeed" and the url http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/feed


in ipkg.conf (from memory)
QUOTE

*




Thanks pgas.
tacc2
Thank you, thank you, thank you!

RC12 is awesome! Kismet works pretty much out of the box once the hostap modules ipk is installed. The USB storage works. And whatever you guys did to mplayer, it runs so much better. xrandr also works, which is great for setting the resolution to 320x240 when using mplayer or snes9x. Great job. Thanks again.
ShiroiKuma
I think the filesystem IO charset under pdaXrom isn't UTF-8. This is a problem for me since I can't access many of my files and folder which have Japanese names.

Is there a way I can somehow specify the charset? It must be a low-level issue, since it affects chrooted debian under pdaXrom RC12 which under Cacko runs fine and accesses these Japanese files.

How can I do this?
gab74
Testing on C3100.... all seems well but when i suspend i cannot resume !
When i push the power button Zaurus flash up the screen and the power down......Any helps ?

After resuming.....i noticed the clock shows a wrong time.....
desertrat
QUOTE(gab74 @ Nov 4 2005, 07:57 PM)
Testing on C3100.... all seems well but when i suspend i cannot resume !
When i push the power button Zaurus flash up the screen and the power down......Any helps ?

After resuming.....i noticed the clock shows a wrong time.....
*


The instructions here works for me:

http://www.oesf.org/forums/index.php?showt...5618&hl=hwclock

cheers
-- desert rat
albertr
It should be in the FAQ really. Like previous post suggested, the hardware clock needs to be kept in UTC.
-albertr
puthreguy
/etc/pcmcia/bluetooth line 22 should state "/sbin/cardctl ident 0" instead
of "/sbin/cardctl ident" in order for bluetooth to work on 3100

PuthreGuy
MicDB
ROX-Session doesn't work with RC12. It needs ROX-Lib2 version 1.9.16; the version en the feed seems to be 1.9.15. ROX-Filer is OK.

Edit: Archive doesn't work either
maslovsky
QUOTE(puthreguy @ Nov 7 2005, 12:36 AM)
/etc/pcmcia/bluetooth line 22 should state "/sbin/cardctl ident 0" instead
of "/sbin/cardctl ident" in order for bluetooth to work on 3100

PuthreGuy
*


It should better say "/sbin/cardctl ident $SOCKET" to support both CF sockets properly.
gab74
QUOTE(desertrat @ Nov 5 2005, 06:30 PM)
QUOTE(gab74 @ Nov 4 2005, 07:57 PM)
Testing on C3100.... all seems well but when i suspend i cannot resume !
When i push the power button Zaurus flash up the screen and the power down......Any helps ?

After resuming.....i noticed the clock shows a wrong time.....
*


The instructions here works for me:

http://www.oesf.org/forums/index.php?showt...5618&hl=hwclock

cheers
-- desert rat
*



yes, but using ntp needs to connect to internet and i'm not always connected to the web...
huu
QUOTE(albertr @ Nov 6 2005, 08:30 PM)
It should be in the FAQ really. Like previous post suggested, the hardware clock needs to be kept in UTC.
*


Apparently so. However, the FAQ entry really should suggest some other method for doing this than hwclock --utc, now that there is no hwclock easily available. I don't remember exactly how it works, but it might be sufficient to write an /etc/adjtime that says, for example,

CODE
0.000000 1131415328 0.000000
0
UTC


If this is sufficient, wouldn't it be a good idea to put this in the root file system to start with? If not, wouldn't it be an equally good idea to include hwclock (and put the instructions somewhere)?
maswell
Hey guys...

This is my first upgrade, so bear with me. Do I need to reflash to upgrade? If I do that, I will lose all of my settings/icons/etc?!!? Im willing, as it sounds like R12 is worth it, but I hate to lose all my configs...
desertrat
QUOTE(gab74 @ Nov 8 2005, 11:10 AM)
yes, but using ntp needs to connect to internet and i'm not always connected to the web...
*


You don't /need/ to use ntp. And as per the instructions you don't even need ntpdate either (just use the date command (or whatever those instructions said) to set the clock initially.

After following those instructions my 3100 has been keeping the correct time (to the second) even through reboots. Just to be clear, after you've set the time correctly then there is "no need" to run ntp or ntpdate. By "no need" I mean no need to run it constantly. You may want to run it once a month or something to to correct any minor drifts. FWIW I've been running rc12 for nearly a week now and the time is still accurate to the second (as far as my eye can tell). With the Sharp rom I was losing a couple minutes per reboot!

Now that the hostap modules are available for rc12 (thanks agraef), pdaxrom (thanks sashz, Laze, et al) is a useable alternative to the dreaded Qtopia. Actually Qtopia isn't that bad, it's just that the way it implements the open file dialog is seriously outdated and was driving me insane smile.gif

--
cheers, desert rat
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.