Help - Search - Members - Calendar
Full Version: Confused About Ipk Compatibility
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
stac
Hi folks -

Perhaps someone could shed some light on a few questions I have about the ipk's... having just flashed to cacko 1.23 on my C1K, I was wondering what ipk's I can use other than those found in the standard cacko feed? Are there alternate feeds? How does one differentiate between ipk's that work on pdaXrom and cacko?

TIA,
Stac
GadgetGuy
QUOTE(stac @ Oct 31 2005, 03:52 PM)
Hi folks -

Perhaps someone could shed some light on a few questions I have about the ipk's... having just flashed to cacko 1.23 on my C1K, I was wondering what ipk's I can use other than those found in the standard cacko feed? Are there alternate feeds? How does one differentiate between ipk's that work on pdaXrom and cacko?

TIA,
Stac
*


You can use any (or nearly any) application written for the sharp rom...
pgas
pdaxrom and cacko/sharp ipks are generally incompatible.

You can generally distinguish the ipks by the place from where you get them.

(if not specified you have a good chance that it is a cacko/sharp compatible ipk)
tml
QUOTE(pgas @ Oct 31 2005, 11:08 PM)
pdaxrom and cacko/sharp ipks are generally incompatible.
*


Are you sure about this. IIRC I installed tcl/tk 8.4 from the pdaxrom feed -- for testing purposes -- and it worked well with an x server installed. (I downloaded several versions of tcl/tk and I am not quite sure which one I actually installed, though.)

Some ipks (especially OZ) need some repackaging but this doesn't rule out that they work. AFAIK both use a different gcc & glibc as used for sharp-compatible apps, so you could run into problems because of that. But if the app is statically linked then this shouldn't be a problem, I guess.
Meanie
Compatability depends on the libraries that are required by the compiled application. For the Sharp/Cacko rom for example which runs Qtopia and uses glib 2.2.2, anything that is compatible with that will run. Some additional libraries might be required, but most qpe apps will run and the older pdaXrom packages will also work. Even the X applications in pdaXrom will run if X/Qt is installed. However, the newer packages for the kathrin releases in pdaXrom are not compatible with the stock Sharp/Cacko rom due to the difference in soft float use and/or glib versions incompatabilities in some of the applications. But despite that, a lot of ipk packages work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.