Help - Search - Members - Calendar
Full Version: Backup/restore Problems
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
GadgetGuy
I have just done a fresh install of Cacko on my C3100 ( to clean up some issues caused by the Automounter package).

I wanted to make a backup, so that in the future if something messes up, I can just restore the backup, without having to reinstall everything.

However backup ( backing up to an Ext3 SD card) froze up on my several times. ( No applications were running)

It froze up at different stages:
- once it froze up when I started ( qtopia desktop visible, but locked up)
- once it froze up after the backup was complete ( starting qtopia screen visible, locked up)

I have always rebooted ( actually resetted ) - and now the last two backups ( I have not changed anything on the C3100 during the 4 backups ) went fine.

Anyone any idea why that is? Is backup/restore overall a somewhat sensitive program, which sometimes lockes up? Or is there anything I need to take care off before doing a backup?

Thanks for any ideas...
Cresho
i tried it same here. backup and restore problems

i kinda nailed it down to Mieanies automounter in the sharp rom

this could have the same effect on cacko. that is why i uninstalled it but was too time consuming to debug for me. I left it as is

im gona talk to meanie about the automounter not allowing backups and restore.

---------------------------------------
problem solved.

if your using meanies x/qt jumbo crams for c1000

CODE
su
/etc/rc.d/init.d/mntloop stop

before doing any backup or restore operations.



CODE
su
/etc/rc.d/init.d/mntloop start

to turn it back on by running
Meanie
If you remount the cramfs images under /mnt instead of /home then you can backup without restarting automounter. The updated installer for the cramfs will now create mount points under /mnt instead of /home, however, those who already have mount points under /home will need to move them to /mnt manually.

Just unmount the cramfs images, ie run

CODE
automounter stop

or
CODE
/etc/rc.d/init.d/mntlopp stop


if you are running the newer clamshell devices with the automounter package, or unmount the cramfs images manually


CODE
umount /home/xqtgtk
umount /home/xqtapps
umount /home/java


move the mount points to /mnt

CODE
mv /home/xqt* /mnt
mv /home/java /mnt


now edit /etc/fstab and change references to /home to /mnt for the cramfs images

Now, just remount them from their new location.
If you have automounter installed, just run

CODE
automounter start

or
CODE
/etc/rc.d/init.d/mntlopp start


Finally, you can just create symlinks from the old mount locations to the new ones, ie

CODE
ln -s /mnt/xqtapps /home/xqtapps


or just re-run the xqt setup scripts

ie

CODE
cd /mnt/xqtapps
./xqtapps-setup
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.