Help - Search - Members - Calendar
Full Version: Opera7.55 For Oz/opie 3.5.4-rc
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Pages: 1, 2
Greg2
Here is a modified opera7.55 ipk that has been requested by some users for use in 3.5.4-RC... I will attach it at the end of this post.

I've simply modified MrSquishy's repackaged opera7.55.ipk extracted from the IBM multimoda.ipk... that has worked for me and many others on OZ3.5.2 official and the Hentges OZ3.5.2 and 3.5.3 versions without problems.

I've modified MrSquishy's opera.ini (that already reflects his directory changes) to increase the cache size that was causing some problems with users.

I've modified MrSquishy's postinst to properly symlink '.opera' and '.operasave' with the new '/media/card/packages/' directory now used.

Replaced a 'couple' of the Crystal icon buttons with the original opera buttons (as per my taste), and the original opera desktop icon from an older opera version.

Repackaged the ipk with ipkg-utils-1.7 for OZ compatibility.

Please note that this is for an SD-card install... and you should remove or edit the postinst for any other install destination.

DISCLAIMER: The instructions and ipk contained in this post are provided AS IS. This has only been tested on the collie and poodle.

Instructions for SD-card installation-

Install the sharp-compat-libs, opie-sh and the qte-font-helvetica-large ipk (or the helvetica size of your choice) from the opie feed.

Copy the attached ipk to your CF-card and open a terminal:
CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.OZ3.5.4_arm.ipk
cd
ipkg-link add opera
exit

Go to the Settings tab, click "Reload Icons"

Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.

Click on the opera icon and enjoy.

Please note that because of the latest sharp-compat-libs you may need to click on the opera icon twice to open or close the browser.

I would like to thank and give credit to MrSquishy for originally modifying this.
Edit: I would also like to thank the OZ and OE devs for making this new release. smile.gif

Greg

Here it is:
EdbO
Thanks it is working now biggrin.gif after I installed the qte-fonts-common and the qte-font-helvetica. Because I forgot to install these packages, Opera gives me a segfault.

I typed this on my Z with Opera smile.gif
MrSquishy
Wow, thanks for the kind words.
I had no idea anyone used that package.

Thanks for the work, I'll have to put 3.5.4 back on my other 5500.
Looks like my Zaural hiatus is over.
Greg2
QUOTE(EdbO @ Nov 4 2005, 02:01 PM)
Thanks it is working now biggrin.gif after I installed the qte-fonts-common and the qte-font-helvetica. Because I forgot to install these packages, Opera gives me a segfault.

I typed this on my Z with Opera smile.gif
*

I'm glad it's working for you.

It would appear that the sharp-compat-libs don't support some of the new fonts used with OZ3.5.4-rc?

Greg
Greg2
QUOTE(MrSquishy @ Nov 4 2005, 02:27 PM)
Wow, thanks for the kind words.
I had no idea anyone used that package.

Whaaat! Look at the second post in this thread:
http://www.oesf.org/forums/index.php?showtopic=10612&st=30

Over 630 d/l's biggrin.gif

Greg
Hrw
libqte used in sharp-compat-libs does not work with TrueType fonts (which are default in 3.5.4) so you have to install some of QPF fonts to get any application which use sharp-compat-libs working.
netsomnia
'Repackaged the ipk with ipkg-utils-1.7 for OZ compatibility.'

Will these utils give me the libraries option in settings? I currently don't have that option.
Greg2
QUOTE(netsomnia @ Nov 22 2005, 08:59 PM)
'Repackaged the ipk with ipkg-utils-1.7 for OZ compatibility.'

Will these utils give me the libraries option in settings? I currently don't have that option.

No, they are scripts for building .ipk packages.

That's the settings tab in your opie gui not opera? If you don't have a libraries icon in your settings tab... did you:

ipkg-link add sharp-compat-libs
ipkg-link add opie-sh

then reload icons or restart opie

Give that a try

Greg
netsomnia
"That's the settings tab in your opie gui not opera? If you don't have a libraries icon in your settings tab... did you:

ipkg-link add sharp-compat-libs
ipkg-link add opie-sh

then reload icons or restart opie

Give that a try

Greg"

Correct. I appreciate the help. I want the libraries icon in my opie settings tab. I did not get as far as linking the libraries because during the ipkg install I received the message for a missing opie-base dependency. Isn't the opie-base package already installed be default with 3.5.4RC or is this a compatibility issued where I need to install and older version of opie-base?
netsomnia
QUOTE(netsomnia @ Nov 23 2005, 01:13 PM)
"That's the settings tab in your opie gui not opera? If you don't have a libraries icon in your settings tab... did you:

ipkg-link add sharp-compat-libs
ipkg-link add opie-sh

then reload icons or restart opie

Give that a try

Greg"

Correct. I appreciate the help. I want the libraries icon in my opie settings tab. I did not get as far as linking the libraries because during the ipkg install I received the message for a missing opie-base dependency. Isn't the opie-base package already installed be default with 3.5.4RC or is this a compatibility issued where I need to install and older version of opie-base?
*


I was succesful adding the libraries icon to my settings menu. Thanks for all the pointers!
ricey
with the help from this thread i can now surf the web, yay!

many thanks smile.gif


-------------------------------------
SL-5500
3.5.4-rc/opie1.2
Jinidog
I know got opera working, but before it can completly loads a webpage it ends up with SegFaults or illegal instructions.
Very strange. I have a poodle with a PXA-250.
And I use swap, so there is enough RAM.

EDIT:
Got it, had to use the right opera.ini
GREAT smile.gif
MrBryan
QUOTE(Jinidog @ Jan 10 2006, 06:14 PM)
I know got opera working, but before it can completly loads a webpage it ends up with SegFaults or illegal instructions.
Very strange. I have a poodle with a PXA-250.
And I use swap, so there is enough RAM.

EDIT:
Got it, had to use the right opera.ini
GREAT smile.gif
*


What did you change?

It segfaults on me with OZ 3.5.4 release:

/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: vxmplugin.so: cannot open shared object file: No such file or directory
Segmentation fault

I installed qpe-font-helvetica(x)... any help appreciated
skliarieh
QUOTE
What did you change?

It segfaults on me with OZ 3.5.4 release:

/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: vxmplugin.so: cannot open shared object file: No such file or directory
Segmentation fault

I installed qpe-font-helvetica(x)...  any help appreciated
*


I use OZ 3.5.4 opie on SL-5500. It segfaulted for me as well:

# opera
/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault
#

QUOTE
libqte used in sharp-compat-libs does not work with TrueType fonts (which are default in 3.5.4) so you have to install some of QPF fonts to get any application which use sharp-compat-libs working.


ipkg install -force-overwrite qpf-helvetica-240
( Used -force-overwrite because both qpf-helvetica-240 and qte-fonts-common
provided the binary /usr/sbin/update-qtfontdir)

But still, the segfault persists.

Can anyone help me please?
Greg2
QUOTE(skliarieh @ Apr 10 2006, 07:01 AM)
I use OZ 3.5.4 opie on SL-5500. It segfaulted for me as well:

# opera
/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
-snip-

Guys,

If this is the ‘only’ opera ipk that you have tried to install... then there should only be one opera.ini on your system? If this is true then your ipkg-link has missed a symlink. To correct this, in terminal do:
CODE
ipkg-link mount /media/card/packages
or to be sure that you have a symlink do:
CODE
ln -s /media/card/packages/opt/QtPalmtop/opera/.opera /home/root/.opera
For the record this has been tested on the collie and poodle with the final release of OZ3.5.4.

Greg

I’ll attach an image of your post here:
skliarieh
QUOTE(Greg2 @ Apr 10 2006, 06:54 AM)
QUOTE(skliarieh @ Apr 10 2006, 07:01 AM)
I use OZ 3.5.4 opie on SL-5500. It segfaulted for me as well:

# opera
/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
-snip-

Guys,

If this is the ‘only’ opera ipk that you have tried to install... then there should only be one opera.ini on your system? If this is true then your ipkg-link has missed a symlink. To correct this, in terminal do:
CODE
ipkg-link mount /media/card/packages
or to be sure that you have a symlink do:
CODE
ln -s /media/card/packages/opt/QtPalmtop/opera/.opera /home/root/.opera
For the record this has been tested on the collie and poodle with the final release of OZ3.5.4.

Greg

I’ll attach an image of your post here:
*



Ok, I managed to launch opera. tongue.gif
Turns out that the package looks into directory /packages/... for its files, assuming that it was installed onto SD and /packages is link to the SD.

I have altboot to boot opie from SD, so I don't have the /packages directory.
After I did following commands, opera started working:
cd /
ln -s / packages

The opera.ini has assumption that home directory is /root. On OpenZaurus the home directory is /home/root:
cd /
ln -s /home/root

The .opera symlink in root's home directory must point to /opt/QtPalmtop/opera, and not /opt/QtPalmtop/opera/.opera (as I initially thought).

Still, the opera start is not flawless - I have got following messages during launch:
# opera
/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: libvxm.so: cannot open shared object file: No such file or directory
QDir::readDirEntries: Cannot read the directory: /media/ROM/.operasave
QDir::readDirEntries: Cannot read the directory: /var/.operasave
QDir::readDirEntries: Cannot read the directory: /media/card/.operasave

blink.gif
Greg2
QUOTE(skliarieh @ Apr 10 2006, 10:29 AM)
I have altboot to boot opie from SD, so I don't have the /packages directory.

OK... that is the problem. You should have removed the postinst script from the ipk ‘before’ installing for your setup with altboot. Now you will have to find and remove the symlinks to /packages and rerun the ipkg-link script. smile.gif

Greg
Storm
All right, this is making me crazy. I have tried everything I know to get this working. Between the bash problem and the suspend problem, I decided to roll back from Hentges 3.5.4.1 to 3.5.4rc. I've gotten everything back up and running except Opera.

I was running 7.55.6079, however I decided to try the 7.55.OZ3.5.4 version this go round. So I got rid of *opera* on the entire system, and installed 7.55.OZ3.5.4. Followed the advice in this thread, including making sure the symlink to /root/.opera pointed to /media/card/packages/opt/QtPalmtop/opera and reinstalling qpf-helvetica-240. I still get

# opera
/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault

Anyone got any pointers?

Thanks,
--Storm
skliarieh
QUOTE(Storm @ Jun 6 2006, 03:48 PM)
All right, this is making me crazy. I have tried everything I know to get this working. Between the bash problem and the suspend problem, I decided to roll back from Hentges 3.5.4.1 to 3.5.4rc. I've gotten everything back up and running except Opera.

I was running 7.55.6079, however I decided to try the 7.55.OZ3.5.4 version this go round. So I got rid of *opera* on the entire system, and installed 7.55.OZ3.5.4. Followed the advice in this thread, including making sure the symlink to /root/.opera pointed to /media/card/packages/opt/QtPalmtop/opera and reinstalling qpf-helvetica-240. I still get

# opera
/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault

Anyone got any pointers?

Thanks,
--Storm
*


Create symlink /opt/QtPalmtop/opera/ini to point to /media/card/packages/opt/QtPalmtop/opera/ini

opera needs to be run using sharp-compat-libs. Verify, that
# ls -l /opt/QtPalmtop/bin/opera
lrwxrwxrwx 1 root root 28 Mar 13 02:15 /opt/QtPalmtop/bin/opera -> /opt/QtPalmtop/bin/runcompat

On 5500 I strongly recommend you to go with root-on-SD, it would free up you from many headaches. I think it is good tradeoff against 16MB ROM that you would loose.
Storm
QUOTE(skliarieh @ Jun 7 2006, 01:44 AM)
Create symlink /opt/QtPalmtop/opera/ini to point to /media/card/packages/opt/QtPalmtop/opera/ini


Did that. Now its only complaining about standard_mouse.ini:

/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
Segmentation fault

Searched, there is no standard_mouse.ini on my system.

QUOTE
opera needs to be run using sharp-compat-libs. Verify, that
# ls -l /opt/QtPalmtop/bin/opera
lrwxrwxrwx    1 root    root          28 Mar 13 02:15 /opt/QtPalmtop/bin/opera -> /opt/QtPalmtop/bin/runcompat


It is.

QUOTE
On 5500 I strongly recommend you to go with root-on-SD, it would free up you from many headaches. I think it is good tradeoff against 16MB ROM that you would loose.
*


It is.


Thanks,
--Storm
nik42
QUOTE(Storm @ Jun 7 2006, 12:41 PM)
Did that. Now its only complaining about standard_mouse.ini:

/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
Segmentation fault

Searched, there is no standard_mouse.ini on my system.

Thanks,
--Storm
*


Hi,

I had the same problem and just copied the "standard_mouse.ini" from my desktop installation of opera. That's working fine.

nik
Greg2
QUOTE(nik42 @ Jun 7 2006, 09:42 AM)
I had the same problem and just copied the "standard_mouse.ini" from my desktop installation of opera. That's working fine.

I just had to d/l an opera rpm and extract the "standard_mouse.ini" from it and copy it to my recent (5-24-06) OZ/Opie build to make this work. To 'keep' it working I had to edit the opera.ini with:
CODE
command control and content navigation by voice enabled=0
This will be the last bit of help I have to offer in this thread. sad.gif

As the OZ devs work to improve their distro... this 'old opera ipk' becomes less and less compatible with it. Just to be 'very' clear on this... I'm 'not' placing the OZ devs at fault here!

In case you haven't read any of these... FYI:
http://article.gmane.org/gmane.comp.handhe...aurus.devel/825
and
http://www.oesf.org/forums/index.php?showtopic=19827

So... for the record the opera binary can be 'made' (very ugly hack) to work. But... your on your own now making (or trying to make) it work.

As a side note... maybe in the future we will have an up to date Konqueror that will have a smaller footprint. smile.gif

Greg
LukeLuke
where opera, by the default, search the ini files?

I have try to creste the symbolic link and when i launch opera it go in segmentation fault, i have modify the opera ini like say Greg2. And now opera say:

# opera
/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault


but the the link are right !

what can i do ?

THANKS

Bye
LukeLuke
OKKKK!!!!! NOW IT' S OK!

I post my configuration step for make work opera:

1- verify that the /root/ and the /home/root/ have:

.opera -> /mnt/card/opt/QtPalmtop/opera/.opera
.operasave -> /mnt/card/opt/QtPalmtop/opera/.operasave

2 - Edit file opera.ini and verify this string:

command control and content navigation by voice enabled=0
[Disk Cache]
; Small: Size=2000, Medium: Size=3000, Large: Size=4000
Size=16000


3 - verify that the symbolic link in /usr/share/opera is right, in my Z the link was to -> /media/card/packages/opt/QtPalmtop/opera/ but in my SD is not the directory Packages, so i link to -> /media/card/opt/QtPalmtop/opera/

4 - if you don't have the standard_mouse.ini get this pippo.bmp and rename in standard_mouse.ini. Copy this file in the directory ini of the opera.

Bye
Luca
LukeLuke
i have a question:

with this porting of opera isn't possible to configure the proxy ???

I try to configure it by the gui but there isn't a form for insert the proxy ......
I try to configure it by the opera.ini file, but when the opera start, it's cancel my manual setting....

how can i do ?

THANKS

Bye
MrBryan
quote: 3 - verify that the symbolic link in /usr/share/opera is right, in my Z the link was to -> /media/card/packages/opt/QtPalmtop/opera/ but in my SD is not the directory Packages, so i link to -> /media/card/opt/QtPalmtop/opera/

end quote


This worked for me -- but i installed to root because i have root on SD

so i did:

rm /usr/share/opera

and ln -s /opt/QtPalmtop/opera /usr/share/opera

and installed qte-font-helvetica-small, qte-font-helvetica-large (common, fixed, etc)

works great.


Cheers
guitara
Ok i think a summary is in order here. I'm sure the original ipk could be modified easily to include the proper path changes. But, since I don't know how to repackage, here goes. To install opera follow the instructions under the proper heading. I'll repost Greg's instructions for ease of use here as well. Thanks to mr Squishy, Greg, and the others in this thread. I've tested this on a fresh install. You don't need to worry aout editing any ini files, or copying anything else over.

1) Install the sharp-compat-libs, opie-sh and the qte-font-helvetica-large ipk (or the helvetica size of your choice) from the opie feed.

2) Copy the attached ipk to your CF-card and open a terminal:

CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.OZ3.5.4_arm.ipk
cd
ipkg-link add opera


3) Go to the Settings tab, click "Reload Icons"

4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.

If you have root on internal flash:
CODE
rm /usr/share/opera
ln -s /opt/QtPalmtop/opera /usr/share/opera


If you have root on SD:
CODE
rm /usr/share/opera
ln -s /media/card/opt/QtPalmtop/opera /usr/share/opera


If you have root on CF:
CODE
rm /usr/share/opera
ln -s /media/cf/opt/QtPalmtop/opera /usr/share/opera
walts
I admit to being a n00b and stupid, so please don't flame me.
I have Opie 3.5.4.1 installed on a c1000 (Akita), and I want very much to run Opera, since the included Konqueror browser is so bad.

I have tried to follow the instructions in this thread:

QUOTE(guitara @ Jul 9 2006, 04:36 AM)
Ok i think a summary is in order here. I'm sure the original ipk could be modified easily to include the proper path changes. But, since I don't know how to repackage, here goes. To install opera follow the instructions under the proper heading. I'll repost Greg's instructions for ease of use here as well. Thanks to mr Squishy, Greg, and the others in this thread. I've tested this on a fresh install. You don't need to worry aout editing any ini files, or copying anything else over.

1) Install the sharp-compat-libs, opie-sh and the qte-font-helvetica-large ipk (or the helvetica size of your choice) from the opie feed.

Where? I have the opie feed as http://ewi546.ewi.utwente.nl/mirror/www.op...4.5.1/feed/opie (if I typed that correctly) and there is nothing "sharp-compat" there. The others are installed.

QUOTE
2) Copy the attached ipk to your CF-card and open a terminal:

CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.OZ3.5.4_arm.ipk
cd
ipkg-link add opera


3) Go to the Settings tab, click "Reload Icons"

done.

QUOTE
4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.

Again, nothing. There is no Libraries icon on the settings tab.

QUOTE
If you have root on internal flash:
CODE
rm /usr/share/opera
ln -s /opt/QtPalmtop/opera /usr/share/opera


*

Done.

The Opera icon is in my Applications tab, and when I click on it, it "flashes" once and stops.
I see lots of log entries in ths thread showing things that went wrong. Please where are the log files? I could probably learn more about what' going wrong if I could look at them.
LukeLuke
if you launch opera from the konsole, the Z what say?

bye
walts
QUOTE(LukeLuke @ Jul 13 2006, 10:07 PM)
if you launch opera from the konsole, the Z what say?

bye
*


Thanks for the reply.

Running from /home/root (freshly started Konsole) is says

CODE
opera: symbol lookup error: opera: undefined symbol: _7QString.shared_null



Walt
Greg2
QUOTE(walts @ Jul 13 2006, 05:02 PM)
Where? I have the opie feed as http://ewi546.ewi.utwente.nl/mirror/www.op...4.5.1/feed/opie (if I typed that correctly) and there is nothing "sharp-compat" there. The others are installed.

This is why:
http://www.oesf.org/forums/index.php?showtopic=19827

This is also why you have that error in your last post.

You may still find what you need in the 3.5.3 feeds?

Greg
LukeLuke
ok! you must do this:

4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.
walts
QUOTE(LukeLuke @ Jul 14 2006, 02:30 PM)
ok! you must do this:

4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.
*


Do you mean the "Settings" tab on the desktop? There is no "Libraries" icon there. I don't mind doing something from the command line, if you would give me the command.

Walt
McChubby
QUOTE(walts @ Jul 14 2006, 04:03 PM)
QUOTE(LukeLuke @ Jul 14 2006, 02:30 PM)
ok! you must do this:

4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.
*


Do you mean the "Settings" tab on the desktop? There is no "Libraries" icon there. I don't mind doing something from the command line, if you would give me the command.

Walt
*


To get the "Libraries" Tool under the "Settings" tab, you need to install the sharp-compat-libs IPK (or use Hentges as it is installed by default). However as previously stated, this does not guarantee your particular application will work. I like some of the EON games, however only a few of them "work", so good luck. As far as I remember the sharp-compat-libs IPK has been removed from 3.5.4.1, so you'll have to use from a previous version feed (I think 3.5.3 has it).
walts
Thanks!

OK, we're making progress. I got the sharp-compat library from the 3.5.3 feed (after reading Hrw's caveat; I can always re-flash the rom) and then started getting the message about standard_mouse.ini.

I downloaded the file attached a few posts back in this thread, and put it in /opt/QtPalmtop/bin/opera/ini where the voice and keyboard ini files are found. Now, when I start Opera from the command line, the GUI displays briefly followed by

opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: libvxm.so: cannot open shared object file: No such file or directory.
Segmentation fault

...

I verified that the standard_mouse.ini file is there, and is protected the same as the other 2 files. It looks reasonable except that it is commented for version 7.0. Anyway, the issue seems to be that Opera is not seeing it. I don't know what to do about th libvxm.so thing.

Thanks for your patience and help!

Walt
arminphys
[quote=LukeLuke,Jul 4 2006, 07:34 AM]

2 - Edit file opera.ini and verify this string:

command control and content navigation by voice enabled=0
[Disk Cache]
; Small: Size=2000, Medium: Size=3000, Large: Size=4000
Size=16000


In which section does this string go?

I tried several setctions, but had no success. My opera.ini was from the desktop version
8.54, as the one I found in .opera on my zaurus after installation was nearly empty.

Could you pleas post a working config?

Thank you

Armin
7_feet_up
I couldn't get opera to work in openzaurus 3.5.4.2-rc2. In previous versions I could, with minor and major hassles. Because opie's konqueror-embedded is about three years old and cannot be made to work with wifi hotspots like those in the Netherlands. Thus, I gave up on opera and built the development version of konqueror-embedded. Get the ipk here.
Hrw
Users and unmaintained applications post is worth reading.
moi
QUOTE(Hrw @ Oct 12 2006, 04:35 PM)


the link/site doesn't work... sad.gif
koen
It works over here:

QUOTE
Users and unmaintained applications

As most of you know I maintain OpenZaurus distribution. We provide few graphical enviroments - OPIE is most popular one. And here comes a problem…

Years ago OPIE forked from Qtopia but it’s still compatible - mostly on source level (any Qtopia application/library can be built for OPIE). Years ago OpenZaurus moved from gcc 2.95.x to more modern compilers - 3.3.x was choosen. This broke binary compatibility and ‘oz-compat’ aka ’sharp-compat-libs’ package was born - it contain libqte2 and libqpe1 from SharpROM to get possibility to run old binaries under new edition of OZ.

But with OpenZaurus 3.5.1 we started to use ’soft-float’ toolchain (ARM cpu lack FPU and use FPU emulation on kernel level - soft-float replace FPU instructions with extra code so emulator is not used). This change broke ’sharp-compat-libs’ - some apps was working, some not but even if something worked then not always correct (for example spreadsheets gave wrong results from calculations).

Newest version of OZ (3.5.4) does not provide ’sharp-compat-libs’ so users start to request old, dead upstream, not fetchable applications to be added into OpenZaurus. I tried to get one of them working - as usual code required some changes to get it build with gcc 3.4.4 but finally it built. But then new question came: How to manage such dead software… If any problem will arrive no one will fix it rather. So I asked other developers and final version is: no support for such crap at all.

I know that some users will complain more now but sorry - who will maintain such stuff
speculatrix
has anyone actually considered asking Opera to do an up-to-date port to OZ? I'm sure there'd be enough alpha and beta testers to support them? It can't be *too* difficult for them to create a development environment in order to build it.

Or maybe their qtopia port was, genuinely, a one-off. But even then, a recompile against OZ/Opie-latest would be useful?
koen
QUOTE(speculatrix @ Oct 16 2006, 10:35 PM)
has anyone actually considered asking Opera to do an up-to-date port to  OZ? I'm sure there'd be enough alpha and beta testers to support them?  It can't be *too* difficult for them to create a development environment in order to build it.
*


I went trough the motions of all their support and contacts forms kindly asking for a new qt/e port and non maemo gtk2 port, outlining how OZ and angstrom users would like to have opera on their devices.

"thank you for your inquiry"

sigh.
undrwater
I've got opera running on rc2. Used the instructions from earlier in this topic, then used the compat libs on opera's bin file. I didn't grab it from the list, I specified the file.

This seems to work much better for anything that requires the compat libs.

Koen, is the newer version of konq-embedded going to be in the feeds any time soon?
ofels
QUOTE(undrwater @ Jan 16 2007, 07:16 AM)
I've got opera running on rc2.  Used the instructions from earlier in this topic, then used the compat libs on opera's bin file.  I didn't grab it from the list, I specified the file.

This seems to work much better for anything that requires the compat libs.

Koen, is the newer version of konq-embedded going to be in the feeds any time soon?
*


Doubt it- newer versions of konq all rely on qte3 which is a no-go for embedded devices in general and Opie in special biggrin.gif

Oliver
undrwater
Sounds like Opie's future is bleak then, unless another browser can be developed for it.

I feel you then...

sigh
speculatrix
QUOTE(undrwater @ Jan 16 2007, 11:23 PM)
Sounds like Opie's future is bleak then, unless another browser can be developed for it.

I feel you then...

sigh
*


what about dillo? is it purely gtk to run on OZ/GPE or pdaXrom?
orujillo
Hola y perdonar que hable en espaol,habria algien que me pudiese decir como instalar opera en zaurus sl-5500 con openzaurus 3.5.4,y si se puede instalar en la sd si tener el sistema en la sd,gracias y un saludo.

pd:si puede ser en espaol os lo agradeceria ya que no entiendo casi nada de ingles,gracias y un saludo.
joewandy
Everytime I download the ipk from the first post (in page 1), the resulting file appears to be broken. Does anybody have a mirror somewhere? THanks!!
Jon_J
QUOTE(joewandy @ Apr 10 2007, 04:19 AM)
Everytime I download the ipk from the first post (in page 1), the resulting file appears to be broken. Does anybody have a mirror somewhere? THanks!!
*

I just downloaded it using firefox, but I was unable to test it because I don't have OZ, and I cannot open and verify OZ IPKs
The filesize is 2.46MB or 2,588,910 bytes (this is on my windows box)
To download from the forum, since attachments are not working correctly, In firefox right click the file, and save link as, then paste in the full filename.ipk into the save dialog.

EDIT: I later found out that the "ar" command opens these files.
I tested opera_7.55.OZ3.5.4_arm.ipk on my cacko zaurus and it extracted with no problems.
joewandy
QUOTE(Jon_J @ Apr 10 2007, 09:36 AM)
QUOTE(joewandy @ Apr 10 2007, 04:19 AM)
Everytime I download the ipk from the first post (in page 1), the resulting file appears to be broken. Does anybody have a mirror somewhere? THanks!!
*

I just downloaded it using firefox, but I was unable to test it because I don't have OZ, and I cannot open and verify OZ IPKs
The filesize is 2.46MB or 2,588,910 bytes (this is on my windows box)
To download from the forum, since attachments are not working correctly, In firefox right click the file, and save link as, then paste in the full filename.ipk into the save dialog.

EDIT: I later found out that the "ar" command opens these files.
I tested opera_7.55.OZ3.5.4_arm.ipk on my cacko zaurus and it extracted with no problems.
*



Thanks, Opera now works well on my OZ 3.5.4.

One thing that bothers me is the font used to render page is very jagged. Is there any package I can install / options to enable to smoothen it?

I can see the following config parameter in opera.ini

CODE
[Font.Normal]
FaceName=helvetica


But what are other possible values here and where can I see the font face that are already installed in the system?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.