Help - Search - Members - Calendar
Full Version: Gaim Issue In Rc12
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
terencek
I install GAIM into RC12 and it work for a few times. Subsequently, it couldn't launch from the GUI. It complains of missing libao from lauching from the command line. After re-installing libao, GAIM is able to launch but can't connect to MSN as complains that "SSL support is needed for MSN..". Re-install gnutls but still having the same problem.

Anyone can help? Much appreciated. Thanks!
web-angel
Same probleme ... I have try many ssl client but nothing work ...
I should use jabber network with passerelle to msn ...
web-angel
So nobody use Msn network with Gaim under RC12 ?
badog
gaim is not work in RC12 ?
pgas
works for me...including msn
web-angel
QUOTE(pgas @ Dec 11 2005, 07:19 PM)
works for me...including msn
*


mmhhh have you only installed "gnutls" for the ssl support or do you use anything else compatible with gaim ?
pgas
QUOTE
have you only installed "gnutls" for the ssl support or do you use anything else compatible with gaim ?


I don't remember doing something special
attach the list of currently install packages
web-angel
I have seen openssl in your package list pgas ... maybe installing this package solve the problem ... I will try when I go back to home ...
badog
i have installed openssl and gnutlus, but the gaim is not work still.
web-angel
QUOTE(badog @ Dec 12 2005, 05:50 AM)
i have installed openssl and gnutlus, but the gaim is not work still.
*


Right ... but when Pgas say "it work" ...

Pgas , aybe can you send me your gaim package ? it's maybe not the same alse us ... I have mine from the PdaXrom feed for Sl860 RC12
pgas
hmm, i'll try to see what I use, maybe I installed gaim from a previous feed...
pgas
maybe you can try gaim from the RC11 feed
http://mail.pdaxrom.org/rc11/Zaurus-7x0-860/feed/
web-angel
Trying the RC11 feed :

Ssl support is needed for msn please install a supported ssl library.

I have look on the gaim website in the faq but I didn't found any ssl supported library that has benn compiled for pdaxrom ...
pgas
maybe libgcrpyt? libgpg-error? gnu-tls?

some info about ssl:
http://gaim.sourceforge.net/faq-ssl.php
badog
i installed libgcrpt & libgpg-eeror again.but giam is not work still.
i installed giam for RC11 & for RC10. but the problem (need ssl) is exist alway.

installed ssl* list:

libssl.so
libgnutls-openssl.so.11.0.10
libgnutls-openssl.so.11
libgnutls-openssl.so
libssl.so.0.9.7
libssl.so.0
libssl3.so
ssl-gnutls.so
ssl-nss.so
ssl.so
ssl-modules.conf

please Mr pags list abot *ssl*,OK?
pgas
have you also gnu-tls installed?
maybe try to issue "ldconfig" in a terminal
Hrw
Guys - when you will start to add correct dependencies to packages? User should be able to "ipkg install gaim" without searching, guessing which packages should be installed first.
pgas
QUOTE
Guys - when you will start to add correct dependencies to packages? User should be able to "ipkg install gaim" without searching, guessing which packages should be installed first.


that's what I've done.

QUOTE
# ipkg info gaim
Package: gaim
Source: http://ovh.dl.sourceforge.net/sourceforge/...m-1.5.0.tar.bz2
Priority: optional
Section: Internet
Maintainer: Alexander Chukov <sash@pdaXrom.org>
Architecture: armv5tel
Version: 1.5.0
Depends: libao, audiofile, gnutls, gtk2
Description: IM client that supports many protocols.
Size: 2.4M

# ipkg info gnutls
Package: gnutls
Source: http://www.mirrors.wiretapped.net/security...s-1.0.10.tar.gz
Priority: optional
Section: Libraries
Maintainer: Alexander Chukov <sash@pdaXrom.org>
Architecture: armv5tel
Version: 1.0.10
Depends: libtasn1, opencdk, libgcrypt, openssl
Description: This is a TLS (Transport Layer Security) 1.0 and SSL (Secure Sockets Layer) 3.0 implementation for the GNU project.
Size: 674.0k
koen
QUOTE(Hrw @ Dec 12 2005, 02:15 PM)
Guys - when you will start to add correct dependencies to packages? User should be able to "ipkg install gaim" without searching, guessing which packages should be installed first.
*


The debian shlibs code can be used with virtually no changes in *any* buildsystem, even the superior ones
pgas
QUOTE
in *any* buildsystem, even the superior ones


Now, who's trolling......
koen
QUOTE(pgas @ Dec 12 2005, 02:20 PM)
QUOTE
in *any* buildsystem, even the superior ones


Now, who's trolling......
*



I think that would be SashX, since I never called any buildsystem superior to others...

Just repeating the propaganda tongue.gif
badog
i have solved the problem.
gnutlus.ipk needs some libXXX.
web-angel
QUOTE(badog @ Dec 12 2005, 04:10 PM)
i have solved the problem.
gnutlus.ipk needs some libXXX.
*


So what's all the files that we need please ?
badog
gnu-tls, libtasn1, opencdk, libgcrypt, openssl
Hrw
QUOTE(pgas @ Dec 12 2005, 04:16 PM)
that's what I've done.
*


Then why that 'dependency hell' posts?

hmm.. maybe that old shell based ipkg does not know how to use it... (I don't know - last time I used it nearly 2 years ago)
koen
The deps of a gaim: http://ewi546.ewi.utwente.nl/drupal/?q=ipk...etails&pnm=gaim
pgas
Stop using pdaxrom now, use this far better, up to date, well maintained distribution that is openzaurus with GPE if you like X.

happy now?
web-angel
QUOTE(badog @ Dec 12 2005, 05:18 PM)
gnu-tls, libtasn1, opencdk, libgcrypt, openssl
*


Have try to install all this package but problem still the same ... have you maybe miss to write a package ? huh.gif
badog
i am sorry. i missed one pcakage:libgpg-error
web-angel
QUOTE(badog @ Dec 14 2005, 03:12 AM)
i am sorry. i missed one pcakage:libgpg-error
*


YEAH biggrin.gif Now it works fine rolleyes.gif thank's !
terencek
QUOTE(terencek @ Nov 25 2005, 01:06 PM)
I install GAIM into RC12 and it work for a few times. Subsequently, it couldn't launch from the GUI. It complains of missing libao from lauching from the command line. After re-installing libao, GAIM is able to launch but can't connect to MSN as complains that "SSL support is needed for MSN..". Re-install gnutls but still having the same problem.

Anyone can help? Much appreciated. Thanks!
*


I finally figure out what my problem was, which is due to missing symlinks. Somehow after every reboot some symlinks are gone and affecting Gaim and a few other programs. When I do a ipkg-link mount /mnt/user, I am able to get back the symlinks, temporary, until the next reboot which I will have to do the same to prevent the problem. I have pdaxrom installed in my c860 and c3100 and both of them have the same problem.
Does anyone know why do the symlinks always missing after a reboot? And should I overcome this rather then using the temp ipkg-link workaround?
Thanks!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.