Help - Search - Members - Calendar
Full Version: SD Card mounts in Read-Only mode
OESF Portables Forum > General Forums > General Discussion
gami
Hello Everyone,

need a little help. for some reason, my SD card is mounting in read-only mode. I tried forcing it in read-write mode, but that doesnt work.

what do i need to check/do to fix this ?

any help would be appreciated.

regards,
Gami
bb
QUOTE
Hello Everyone,
need a little help. for some reason, my SD card is mounting in read-only mode. I tried forcing it in read-write mode, but that doesnt work.
what do i need to check/do to fix this ?

I've experienced my SD card toggling from being rw-mounted to ro-mounted when I had a problem with it because of a write gone bad.
In the end I had to re-format the card. After that I experienced no problems.
# umount /mnt/card
# mkfs.vfat /dev/mmcda1
lardman
before you re-format try: fsck /dev/mmcda1 (you need to unmount it first as shown above).

Si
sefthuko
I type in:
fsck.vfat /dev/mmcda1

And receive:

dosfsck 2.8, 28 Feb 2001, FAT32, LFN

Got 0 bytes instead of 512 at 0
Stubear
I get the SD card mounted read-only occasionally if I remove it while the Z is powered on, or remove the card without software ejecting it.

To fix it I software eject the card, put the Z into suspend mode then power on again - this almost always remounts the SD read-write.

If not try rebooting, and if that don't work try fsck (or check for errors in windows using a card reader), if that still don't work then you'll need to try reformatting.

Not I only have a C760 so don't know about the 5x00 models

Stu
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.