Help - Search - Members - Calendar
Full Version: C700 Boot Problem
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > Cxx0 Hardware
I've had my C700 since March 2003. After 12 months of returns to Japan, it was finally fixed in Summer 2004. Worked since util now.

I run Cacko 1.21, a 256mb CF, and a 512mb SD. Last week, went to turn on after it sat for 5 days. No turn on. Soft and Hard resets failed. I tried to get to Japanese Flash menu. Won't go.

I got into Service menu (D+M) ok. I'm afraid of all the NAND stuff, it's not obvious which is a real diagnostic and which will kill the RAM/ROM/FLASH.

I have flashed a new ROM and I have done the emergency restore (C+D with CF card files). No go. I can still get the service menu, but no luck on the Flash menu.

I can get the Boot to Command prompt. and can "cd" around the file system.

Should I try a NAND restore from a virgin JP NAND file on the CF Card? Then restore my CACKO ROM? Will the NAND restore give me back the Flash Menu?

My C700 was great after my 3 returns to Japan (none cost me) for the final fix. I want to get another 6 months out of it.


I repeated the recovery steps, but no good.

I downloaded 2 different NAND files for the C700. One was named original, one was named original 1.5, whatever that implies (I think the "original is version 1.2??).

I ran the various NAND diagnostics. They all passed, no bad blocks, RAM was good.

I ran the NAND restore from my CF card. Restoration completed satisfactorily.

I ran the NAND SUM diagnostic. I get a bad check-sum for the PRESETS memory block.

I tried the other version. I get different numbers, but the PRESETS memory glock still gave me a NG (no good??).

I even tried to redo the "recovery" exercise ((C+D)) after the NAND restore to see if I could overwrite the PRESETS file. The files updated, but the NAND SUM gave me no check sums for the individual files, even though the total checksum was OK.

All the other memory diagnostics run OK. I can still (D+cool.gif to the Linux command prompt.

I ran the NAND Erase from the other diagnostics menu, then repeated the NAND restore. No change.

I finally ran the NAND AGE program which seemed to overwrite all the NAND areas with "ones". Then I ran the NAND restore again. I still get the PRESET block checksum error. The "M" column says OK.

I still have the same original problem. I can't get the flash menu to come up so I can reflash the ROM. It just won't come up.

Is there another C700 NAND file other than the 1.2 or 1.5??

Even though all the other diagnostics but NAND SUM finish with no errors, does this mean I have doomed flash ROM/RAM and my C700 is finally dead?

Any other ideas?

Update 2.

I re-read the post related to mine.

Am I doing things backwards? Do I HAVE to run the recovery, THEN the NAND Restore? Aren't the 9 file blocks in the recovery process the same as in the NAND Restore?

I don't know. Again, I get no bad blocks anywhere, just the singel bad checksum when I run NAND SUM. Oh, and I still don't get the Flash Menu to comeup.


your post sounds like a blown charger circuit.
The Zaurus will refuse to boot or do anything (except
the Diag menu) without a properly charged battery.

If possible, try the battery in another Zaurus (or another
battery in your Zaurus).


Marc Stephan
Thanks for your reply. I thought about the charging circuit. I have 4 batteries (I have a SL-5500 as well and the external charger, I just have to remember where I put it). I understand how the Li battery charging system works harware-wise (+and - terminals, and the 3rd temperature sensor terminal to control charge rate...I'm an EE who's still learning Linux and this little PDA). I understand that without a functional battery and charger, the system won't boot. It does boot... but only to the command prompt via the D+B key sequence. I'm assuming if the charging system was hosed, I wouldn't be able to do the D+B boot to the command line. I could be wrong about that.

The my wall wart is functional, and it appears that the batteries are charging properly in the C700. When I left work yesterday, I put a different EA-BL06 battery in the PDA and plugged the charger in. The light came on, indicating it was charging. I came in this morning and the light was off. I then pulled the battery and left the PDA off, open, with the battery out for a few hours. I'm going to try the sequence again.

The thing is, I can do the boot to command prompt (battery switch to lock, while holding the D+B keys down). I can "LS" around the file system. The cards aren't mounted, but their mount references are their.

I keep trying the sequence, with the same results (isn't that one sure sign of insanity, doing the same thing over and over expecting different results??). Maybe my first battery was getting weak, affecting the flash restore process. Maybe I have a flaky CF card that's corrupting the NAND or Recovery files. I may try the recovery or NAND from SD (I can't remeber if I can even do it with an SD versus a CF card). I have reformatted the CF card to FAT16 twice.

I still end up with every diagnostic passing, exept the PRESET block checksum. No bad blocks, all read/write sequences pass. But, NO japanese Flash Menu.

I'm wondering if there is a manual, external, command promp way to do the ROM flash so I can bypass the flash menu.

Do you know if the sequence is important on the NAND Flash REstore versus the "Recovery" (C + D + battery lock and read the 9 files off the CF card)? I was assuming the NAND Flash Restore was a deeper, more fundamental change over the "recovery" process. I tried the sequence both ways, made no difference.

Any more suggestions? I'm afraid of "wearing out" my flash RAM by the repeated erase/restore/erase etc. Is this a valid concern for the memory on this PDA? I've not researched it enough to know for sure.

(still not giving up)

Of course, I feel like an idiot!!

I started playing with my 4 batteries, and how they charged in my SL-5500. I took the battery that registered the highest in the diagnostic screen (4.0 volts). The battery I used yesterday, I must have mostly drained it with the diagnostics and stuff.

I also changed to my old Casio charger (5 volts, 1.6a). My generic Rat Shack 5 volts 2 amp charger WORKS IN EVERY OTHER RESPECTS.

Anyway, the combination of fresher battery, different charger, NAND restore, and recycle power and VIOLA Flash screen.

I put the Cacko back in, and .....

I'm waiting for the final reboot....


Now I wait to see if the problem reoccurs. I've been using this battery for over a year. I'm going to change and cycle through my spares. I've had a problem before with a calendar alarm and the PDA sitting with a dying dead battery.

Now for the restore.


Fresh, fully charged battery. BEST CHARGER YOU HAVE, Preferably and original. It may have been the battery, but who knows?

I know alot more about my C700. Maybe another year's use??




BEST CHARGER YOU HAVE, Preferably and original.

what are we telling over and over and over and over ?
If you love your Zaurus and don't live in Japan, only use the EA-70S for charging !

Good to hear that your Zaurus is back alive again.


Marc Stephan
QUOTE(TRIsoft @ Nov 30 2005, 10:57 AM)

BEST CHARGER YOU HAVE, Preferably and original.

what are we telling over and over and over and over ?
If you love your Zaurus and don't live in Japan, only use the EA-70S for charging !

why?! ph34r.gif i was thinking of buying a 100-240V worldwide ac adapter ...

at the moment, using EA-72S (C760's original charger), with a 230V-110V voltage inverter (or whatever)..
QUOTE(cmonex @ Mar 10 2006, 10:47 PM)
why?! ph34r.gif i was thinking of buying a 100-240V worldwide ac adapter ...

simply because the EA-70 is the one and only official EU/US type.
Technical problems with Zauri are to 99% caused By third-party
AC adapters.
Use the forum search function (or Google for fried Zauri) and you'll
see that there's a lot of trouble.


Marc Stephan
Does the nand checksum still has NG error when you use your new battery?
My C860 have similar problem,but it can boot system normally,can't install pdaXrom anymore.error appear while the progress bar display 51%
I can install the sharp rom,the nand checksum have one NG,can boot into Qtopia
I can install cacko,but the nand checksum have four NG,can boot into qtopia
I can install oz 3.5.4 ,the nand checksum have two NG this time,also can boot into SYS
can not install pdaXrom,if use the DBK rom restore, X cannot start

my battery have a low voltage charge one time,but now it use normally.
I want to try the C+D mood,but I cannot find the 9 files to download...
can you give me some help?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.