Help - Search - Members - Calendar
Full Version: Kdepimpi For Rc12 On 3100
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
rsay
Does someone have a version of kdepimpi that works on RC12 with a 3100?

I had version 2.2.3 working on rc12 test but I can't seem to get it going again. More specifically, kopi and pwmanager work fine but kapi gives an error message about not being able to find libmicrokabc_qtopia.so and libmicrokabc_sharpdtm.so

the lib files are present in /mnt/ide3/usr/lib and they are symlinked to /usr/lib and /opt/kdepim

If you have it working I would appreciate information about what steps you took to install it:)

SashZ, could we please get this added to the 3100 feed for RC12 so this is easy? Is there a working version for a 3100 on RC12 in another feed?
desertrat
QUOTE(rsay @ Nov 29 2005, 12:33 AM)
Does someone have a version of kdepimpi that works on RC12 with a 3100?


I'm using kdepim_2.2.3_armv5tel.ipk which was gotten from an attachment somewhere in this forum. Sorry you'll have to search for it smile.gif

QUOTE
I had version 2.2.3 working on rc12 test but I can't seem to get it going again. More specifically, kopi and pwmanager work fine but kapi gives an error message about not being able to find libmicrokabc_qtopia.so and libmicrokabc_sharpdtm.so

the lib files are present in /mnt/ide3/usr/lib  and they are symlinked to /usr/lib and /opt/kdepim

If you have it working I would appreciate information about what steps you took to install it:)


Where did you get your copy of kdepim from? If different from above then try the above. I don't remember having to do anything special, it just worked.

-- cheers
rsay
The copy was from the forums.

md5sum
2ec055c9cffa33c5839a8926dfa2a91d kdepimpi_2.2.3_armv5tel.ipk

I downloaded it and installed it as follows

ipkg -d ide3 install /mnt/ide3/Documents/Install_Files/kdepimpi_2.2.3_armv5tel.ipk

I also tried without the -d ide3

afterwards I get the following error:

KLibLoader::library could not find library: libmicrokabc_qtopia.so
KLibLoader::library could not find library: libmicrokabc_sharpdtm.so
KLibLoader::library could not find library: libmicrokabc_qtopia.so
KLibLoader::library could not find library: libmicrokabc_sharpdtm.so
KLibLoader::library could not find library: libmicrokabc_file.so
KRES::Factory::resource(): Factory creation failed for the library microkabc_file No resource available!!!
cattin
there are two problems with this version of kdepimpi I know of (they have all been reported in this forum):

1. kapi expects the libraries to be in a different place than kopi. simple links should solve this problem.

CODE
cd /opt/kdepimpi
ln -s /usr/lib/libmicrokabc* .


2. when you start kapi the window manager doesn't automatically show kapi's window. you can, however, activate it with ALT-TAB. I have seen this behaviour with MB, in fvwm it seems to work properly.

regards
danr
QUOTE(rsay @ Nov 29 2005, 12:33 AM)
Does someone have a version of kdepimpi that works on RC12 with a 3100?


I've compiled 2.2.7 for RC12, on my SL-C860. It contains kapi, kopi, kammu - see attachment.

Dan
clofland
QUOTE(danr @ Nov 29 2005, 05:15 AM)
I've compiled 2.2.7 for RC12, on my SL-C860.  It contains kapi, kopi, kammu - see attachment.


Thanks a million!

I wish we could get the developer to release pdaxrom versions of these so we don't have to keep compiling them at random. smile.gif
rsay
QUOTE(danr @ Nov 29 2005, 05:15 AM)
I've compiled 2.2.7 for RC12, on my SL-C860.  It contains kapi, kopi, kammu - see attachment.


This is very nice and it works. Interestingly, I get almost the exact same error message on startup about the libraries but the program seems to work:) This version starts normally for me without the start minimized bug described above. (no more alt-tab!)

Do you have pwmanager compiled? I juggle a million passwords and I dont feel safe keeping them unencrypted in the address book. Alternatively, could you tell us the stps that you took to compile the other programs so I can take a stab at it?
LadyBug
QUOTE(rsay @ Nov 29 2005, 11:21 AM)
Do you have pwmanager compiled? I juggle a million passwords and I dont feel safe keeping them unencrypted in the address book.


If the pwmanager angle doesn't work out, try PortaBase which can be found in the feed. I keep my passwords in a PortaBase database. PortaBase is also available for Windows, which is good.
zautrix
QUOTE(clofland @ Nov 29 2005, 03:41 PM)
QUOTE(danr @ Nov 29 2005, 05:15 AM)
I've compiled 2.2.7 for RC12, on my SL-C860.  It contains kapi, kopi, kammu - see attachment.


Thanks a million!

I wish we could get the developer to release pdaxrom versions of these so we don't have to keep compiling them at random. smile.gif
*




Hehe. Yes, why not?
I would like to give pdaXrom a try.

But I would need a second Z to install pdaXrom and test Kx/Pi.
Does anybody have a spare Z 760/860 to give/sell it to me?

z.
cattin
As I need the password manager as well, I cross compiled the most recent version 2.2.7 of pim/pi. This ipkg contains kopi, kapi, kammu, pwmpi, and ompi. Beware that I changed one small thing. In particular I removed the sampling rate option '-r ...' when ko/pi calls 'playwave' in case of an alarm, as this option is not supported on my RC12's playwave.

regards, Philippe


PS: In a separate post I will describe my solution to the alarm problem for ko/pi on my 3100.
rsay
cattin,

I just tested your compile of kdepimpi on the new 1.1.0beta1 release and it still works great.

Thanks
gromituk
Well done cattin. Is the "14% constant CPU usage by KA/PI" issue still there?
cattin
QUOTE(gromituk @ Jan 7 2006, 02:56 AM)
Well done cattin.  Is the "14% constant CPU usage by KA/PI" issue still there?
*


unfortunately this version of KA/PI still uses precious CPU resources even when idle.

Philippe
cmpayc13
Hi All,

I still have the prob with kapi complaining about not existing libmicrokabc_sharpdtm.so and libmicrokabc_olaccess.so. The trick with symbolic link in /opt/kdepimpi seems to not work with beta1 (the is no /opt/kdepimpi, it's /opt/kdepim-2.2.7, ok). I created the symbolic links as described above, but kapi still cant find this libs.
Any idea to solve this is very appricated

Thanks a lot in advance

Best regards

Cmpayc
zautrix
QUOTE(cattin @ Jan 7 2006, 08:20 PM)
QUOTE(gromituk @ Jan 7 2006, 02:56 AM)
Well done cattin.  Is the "14% constant CPU usage by KA/PI" issue still there?
*


unfortunately this version of KA/PI still uses precious CPU resources even when idle.

Philippe
*




Strange.

I really have to figure out why that happens ...

z.
zautrix
QUOTE(cmpayc13 @ Jan 7 2006, 10:51 PM)
Hi All,

I still have the prob with kapi complaining about not existing libmicrokabc_sharpdtm.so and libmicrokabc_olaccess.so. The trick with symbolic link in /opt/kdepimpi seems to not work with beta1 (the is no /opt/kdepimpi, it's /opt/kdepim-2.2.7, ok). I created the symbolic links as described above, but kapi still cant find this libs.
Any idea to solve this is very appricated

Thanks a lot in advance

Best regards

Cmpayc
*


There is nothing wrong if you get these messages on pdaXrom.
Theses libs are not available for pdaXrom.

And libmicrokabc_olaccess will never be available for any platform ... I have to remove that message ...

z.
cmpayc13
Thanks a lot, zautrix!

Best regards

Cmpayc
macstibs
QUOTE(zautrix @ Jan 7 2006, 06:03 PM)
QUOTE(cmpayc13 @ Jan 7 2006, 10:51 PM)
Hi All,

I still have the prob with kapi complaining about not existing libmicrokabc_sharpdtm.so and libmicrokabc_olaccess.so. The trick with symbolic link in /opt/kdepimpi seems to not work with beta1 (the is no /opt/kdepimpi, it's /opt/kdepim-2.2.7, ok). I created the symbolic links as described above, but kapi still cant find this libs.
Any idea to solve this is very appricated

Thanks a lot in advance

Best regards

Cmpayc
*


There is nothing wrong if you get these messages on pdaXrom.
Theses libs are not available for pdaXrom.

And libmicrokabc_olaccess will never be available for any platform ... I have to remove that message ...

z.
*



I don't have an /opt directory and when I try to create one it tells me the filesystem is read-only. I think I missed something when I installed the rom maybe or do I need to remount it rw and create a symlink?

Thanks.


------------
SL-C3000 : Linksys WCF12 : 128mb SD
pdaXrom rc12
ntrolls
I am using the 2.2.7 version. When I try to move the data storage path using the global settings, ko/pi changes to the new path and stores its data there.

However, ka/pi seems to stick to /home/root/kdepim no matter what I do. It only works normaly when the storage path is set to /home/root/kdepim. If I change it to, say, /mnt/card/kdepim, ka/pi won't save the data when exiting - which makes it load with empty list next time.

What am I missing here?
desertrat
QUOTE(ntrolls @ Sep 30 2006, 12:55 AM)
However, ka/pi seems to stick to /home/root/kdepim no matter what I do. It only works normaly when the storage path is set to /home/root/kdepim. If I change it to, say, /mnt/card/kdepim, ka/pi won't save the data when exiting - which makes it load with empty list next time.

You could use a symlink to point /home/root/kdepim to the actual directory you want to use. I use that to save wear and tear on the flash.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.