Help - Search - Members - Calendar
Full Version: Phone Connection Difficulties
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
kakos
So, I'm running a fresh install of OZ 3.5.4 on a Zaurus C860 (2.6.x kernel). I set up my phone with both IR and Bluetooth, which appear to be working. I start either one and they seem to work fine, but will then immediately disconnect with the phone in the middle of the dial up. Any ideas on how to fix this?
lardman
In the middle of the dialup, or as it's about to authenticate?

I had this issue a long time ago and it was because I was using the wrong pap/chap settings (using the wrong one).

You should be able to put -V in the chat script to make it more verbose - might be worth running the whole lot from the command line to you can see the output.

http://www.ibiblio.org/pub/Linux/docs/HOWT.../PPP-HOWTO.html

Might be of use to work out how the various bits stick together.


Si
Lurker
I am experiencing the same issue after much research and struggle to get a USB bluetooth dongle working with my C3000. My exact issue is that the phone shows "Spitz Connected" when the Zaurus is initializing the modem, but at the authentication part of the connection process the phone shows "Spitz Disconnected". The PPP Dialer GUI shows as Online, though, with no obvious errors except for the fact that the IP and DNS entries are all zeroes. I used the settings listed in the Opie BluetoothGPRS HowTo, with the T-mobile initialization string 2.
It is a bit disheartening to be soooo close to success only to hit another wall. I will of course continue to (attempt to) troubleshoot this issue myself, but any ideas would be greatly appreciated.
telemetric_au
having same prob with my 5500 and xircom 56k cf,

disconnect very shortly after the green modem lights comes on, seems similiar to when i was trying to do dialup with debian x86 for the first time, had to add noauth argument... tried that but didnt help...

anyone have any other suggestions...
telemetric_au
just this in another thread:

"Logs are in /tmp "

was wondering where they were, am away from z right now, so will get back when looked in there...
telemetric_au
checked in /tmp and nothing , i figure that it may be there when run from command rather than from gui
telemetric_au
well i got it working, not shore exactly which of what i did did it... wink.gif

basically added "noauth" into /etc/ppp/options and a few other places...
sdjf
QUOTE(telemetric_au @ May 24 2006, 07:01 PM)
checked in /tmp and nothing , i figure that it may be there when run from command rather than from gui
*


No, whether you run it from the command line or GUI probably doesn't matter. It gets erased when the system is preparing to write a new log.

If you want to see what a log looks like, check it while you are online...there had better be one there then!

Have the same problem with my sl5500 and gonna see if telemetric_au's trick of adding "noauth" into /etc/ppp/options will make a difference. I wonder where else he put it?

I was blaming Opera for my problems, but the same problem occurs when I run NeIC. My temporary fix has been to just kill the current pppd process to get the GUI to act properly.

sdjf
agosine
Has anyone gotten this working? I determined the right channel using

# sdptool browse 00:60:57:79:F9:E7

My RAZR uses channel 8. Modified rfcomm.conf.

Strange as it was working for a couple of days and stopped. I didn't install or change anything. Base install of Opie 3.5.4.1.

[Update] There was a spelling mistake in my username after I did the fresh install. The log did not indicate this so be sure to double check everything. Actually the log was blank.
sdjf
If anyone is still having this type of problem, please PM me. I think we can use a combination of qcop and cardctl commands to resolve it, but don't want to be talking just to myself.

I also want to solve the "missing log" problem with various types of connection, such as eth0 over pppd, using some code resembling what I posted in a "dhcpcd logs" thread:

http://www.oesf.org/forums/index.php?showtopic=23784

The only catch is that if you are using BusyBox ps, you will need to also install a full-featured version. I discuss this and give downlload links at:

http://www.sdjf.esmartdesign.com/commands/ps.html

If you want to continue using your busybox ps, it won't replace it...you can give the additional ps a different name, as Antikx illustrates doing in the dhcpcd log thread.

sdjf
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.