Hey guys,

I'm having a problem entering Japanese text in QT Designer 2.3. Here is an outline of what happened...

About a week ago I went ahead and burned the latest Mandriva 2006 cds, and installed Mandriva on my computer. I went ahead and set up Japanese support/input (making sure to use a utf-8 font), and everything worked fine - I could see/type in Japanese on the desktop (when I make a new folder, file, etc...), I could see/type in Japanese in Firefox, etc. I could even enter Japanese text when making forms in QT Designer. This is using SCIM/ANTHY, by the way.

I did, however, have a problem. When I installed Mandriva that time, I installed all the developement stuff with it, which included a newer version of gcc. The problem was that, as you all know, in order to do Zaurus QT developement, you need to have gcc 2.95 installed if you want to build (so you can test) for the x86 environment.

Anyway, since I wanted to try a new install anyway (There was a bunch of other stuff that I decided I didn't want installed), I went ahead and deleted/reinstalled Mandriva. I got everything setup again (including Japanese input/support with SCIM/ANTHY again), and everything seemed fine - I could use Japanese everywhere...

However, now I have installed the qtopia 1.5 sdk again, and I absolutely cannot use Japanese in QT Designer anymore. For example, if I create a new button on a form, and try entering some Japanese for the button's text, it comes out as "????". I looked at the font that is being used for the form/button, and it says it's using a Japanese font ("Sazanami"), but it just doesn't matter.

Does anyone have any idea what I am doing wrong? I KNOWI was able to use Japanese the first time. And now, well... I've tried everything to get it working again. I've reinstalled Mandriva multiple times - with Japanese as the only language; with all the development stuff included again; etc... Nothing works.

If you guys have any ideas, please try to help me out.