Help - Search - Members - Calendar
Full Version: How To Complie Qt ?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Pages: 1, 2
wjping119
I need recompile qt with a patch,after I patch the source ,I created armv5tel-linux-g++ directiry in mkspecs and
copy files from linux-g++ and tune the qmake.conf compare from pdaXrom-builder-02.36_29.11.05/pdaXrom-builder/config/pdaXrom/3.3.5-armv5tel-linux-g++/qmake.conf

then I begin configure ,

./configure --host=armv5tel-cacko-linux --build=i686-linux -qt-gif -thread

sysytem display:
--host=armv5tel-cacko-linux: invalid command-line switch
--build=i686-linux: invalid command-line switch

WARNING: /usr/X11R6/lib/libGLU.so is threaded!
The Qt OpenGL module requires Qt to be configured with -thread.

then systerm will display the qt configure help ,can not configure any more.My cross complier can complie some applications correctly,so should not it`s fault
can someone tell me what can I do in this situation? if something wrong with my configure?can you give me the configure details?

My systerm is full install slackware 10.0,and use the cross-sdk from [url=http://mail.pdaxrom.org/rc12/Zaurus-7x0-860/cross-sdk-armv5tel-cacko-linux-3.4.4-2.2.5-softfloat.tar.bz2[/url]

Thanks.
pgas
read what is written in ./configure --help

The configure script is not the usual autoconf, and you must use different options (-xplatform IIRC)

Note you can find a source tree compiled qt with the uim patch applied here:

http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2

I didn't tried it
wjping119
QUOTE(pgas @ Dec 13 2005, 07:17 AM)
read what is written in  ./configure --help

The configure script is not the usual autoconf, and you must use different options (-xplatform IIRC)

Note you can find a  source tree compiled qt with the uim patch applied here:

http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2

I didn't tried it
*

sorry to bother several times
now I can understand you
Thank you!
pgas
no problem, sorry if I haven't be clear enough in my pm.

Why didn't you told me so?
wjping119
pgas,I can not complie successfully
my configure is ./configure -xplatform armv5tel-linux-g++ -thread -qt-gif -no-cups
there are hundreds of warnings and some errors,and the most important inputmethods plugins cannot build successfully.do someone give some help,it is very improtant for me.


../../../../src/3rdparty/libjpeg/jmemnobs.c:106: warning: unused parameter 'cinfo'
../../../../src/3rdparty/libjpeg/jmemnobs.c:100: warning: unused parameter 'cinfo'
../../../../src/3rdparty/libjpeg/jmemnobs.c:87: warning: unused parameter 'info'
../../../../src/3rdparty/libjpeg/jmemnobs.c:88: warning: unused parameter 'total_bytes_needed'
../../../../src/3rdparty/libjpeg/jmemnobs.c:73: warning: unused parameter 'cinfo'
../../../../src/3rdparty/libjpeg/jmemnobs.c:73: warning: unused parameter 'min_bytes_needed'
../../../../src/3rdparty/libjpeg/jmemnobs.c:74: warning: unused parameter 'already_allocated'
../../../../src/3rdparty/libjpeg/jmemnobs.c:61: warning: unused parameter 'cinfo'
../../../../src/3rdparty/libjpeg/jmemnobs.c:61: warning: unused parameter 'sizeofobject'
../../../../src/3rdparty/libjpeg/jmemnobs.c:55: warning: unused parameter 'cinfo'
../../../../src/3rdparty/libjpeg/jmemnobs.c:41: warning: unused parameter 'cinfo'
../../../../src/3rdparty/libjpeg/jmemnobs.c:41: warning: unused parameter 'sizeofobject'
../../../../src/3rdparty/libjpeg/jmemnobs.c:35: warning: unused parameter 'cinfo'
In file included from qnoneinputcontextplugin.cpp:44:
qnoneinputcontextplugin.h:44:33: qinputcontextplugin.h: No such file or directory
In file included from qnoneinputcontextplugin.cpp:44:
qnoneinputcontextplugin.h:49: error: expected class-name before '{' token
qnoneinputcontextplugin.h:51: error: ISO C++ forbids declaration of `Q_OBJECT' with no type
qnoneinputcontextplugin.h:51: error: expected `;' before "public"
qnoneinputcontextplugin.h:56: error: ISO C++ forbids declaration of `QInputContext' with no type
qnoneinputcontextplugin.h:56: error: expected `;' before '*' token
qnoneinputcontextplugin.cpp:50: error: definition of implicitly-declared `QNoneInputContextPlugin::QNoneInputContextPlugin()'
qnoneinputcontextplugin.cpp:50: error: declaration of `QNoneInputContextPlugin::QNoneInputContextPlugin()' throws different exceptions
qnoneinputcontextplugin.h:49: error: than previous declaration `QNoneInputContextPlugin::QNoneInputContextPlugin() throw ()'
qnoneinputcontextplugin.cpp:65: error: no `QInputContext* QNoneInputContextPlugin::create(const QString&)' member function declared in class `QNoneInputContextPlugin'
qnoneinputcontextplugin.cpp:83: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp: In member function `QString QNoneInputContextPlugin::displayName(const QString&)':
qnoneinputcontextplugin.cpp:89: error: `tr' undeclared (first use this function)
qnoneinputcontextplugin.cpp:89: error: (Each undeclared identifier is reported only once for each function it appears in.)
qnoneinputcontextplugin.cpp: At global scope:
qnoneinputcontextplugin.cpp:88: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp: In member function `QString QNoneInputContextPlugin::description(const QString&)':
qnoneinputcontextplugin.cpp:94: error: `tr' undeclared (first use this function)
qnoneinputcontextplugin.cpp: At global scope:
qnoneinputcontextplugin.cpp:93: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp:98: error: expected constructor, destructor, or type conversion at end of input
qnoneinputcontextplugin.cpp:98: error: expected `,' or `;' at end of input
gmake[4]: *** [.obj/release-shared-mt/qnoneinputcontextplugin.o] Error 1
gmake[3]: *** [sub-imsw-none] Error 2
gmake[2]: *** [sub-inputmethods] Error 2
gmake[1]: *** [sub-plugins] Error 2
gmake: *** [init] Error 2
pgas
did you read the readme.txt :

http://www.kde.gr.jp/~daisuke/immodule_for...h/ReadMe-en.txt

creating the symbolic links as in 2 should solve your problem.

I'll try to give you the options passed to the ./configure by the pdaxrom builder tonight.

(also there is an include to add in simple output plugins..I'll tell you more asap)
wjping119
I read it,but in http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2 this file,It provide a script called "make-symlinks.sh" to accomplish making symbolic links
I run it ,but I donnot know if it really works.
wjping119
QUOTE(wjping119 @ Dec 14 2005, 08:56 AM)
I read it,but in http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2 this file,It provide a script called "make-symlinks.sh" to accomplish making symbolic links
I run it ,but I donnot know if it really works.
*


if someone can help me complie "fcitx",who is a very small application(http://www.fcitx.org/main/?q=node/9) successfully,I need not recompile qt any more. sad.gif
pgas
make-symlinks seems to create other links.

(to tell you the truth, I forgot about the symlinks when I compiled it and modify the Makefiles to add other include dirs, but making the symlinks should work fine)

The modification I made was to include algorithm in /plugins/src/inputmethods/qsimpleinputcontext.cpp

QUOTE
#include <qglobal.h>
#include <algorithm>
pgas
QUOTE
if someone can help me complie "fcitx",who is a very small application(

open an other thread and expose your problem smile.gif
(I didn't have time to look at it yet)


QUOTE
I need not recompile qt any more. sad.gif


don't give up your are doing well!!

Also you could use my archive which is allready compiled, make install should work
wjping119
QUOTE(pgas)
Also you could use my archive which is allready compiled, make install should work
*

are you mean the http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2 archive?
I have already tested it by installing it in my c860,when I run qtconfig,systerm display "cannot execute binary file"
how you configure it?
pgas
yes, it should be compiled for arm, I haven't tried it though, so something might be wrong...
jgrauman
QUOTE(wjping119 @ Dec 12 2005, 10:56 PM)
I need recompile qt  with a patch,after I patch the source ,I created armv5tel-linux-g++ directiry in mkspecs and
copy files from linux-g++ and tune  the qmake.conf compare from pdaXrom-builder-02.36_29.11.05/pdaXrom-builder/config/pdaXrom/3.3.5-armv5tel-linux-g++/qmake.conf


I don't know if this is helpful, but... pgas helped me to compile qt, it wasn't too bad using distcc after I got over a couple problems. See the thread he started about distcc for info.

Josh
wjping119
pgas,it seems you compile it for x86,cannot run on zaurus.

I recompile it add your
#include <qglobal.h>
#include <algorithm>
and still can not build the inputmethod plugins

cd inputmethods && make -f Makefile
make[3]: Entering directory `/tmp/qt-x11-free-3.3.4/plugins/src/inputmethods'
cd imsw-none && make -f Makefile
make[4]: Entering directory `/tmp/qt-x11-free-3.3.4/plugins/src/inputmethods/imsw-none'
armv5tel-linux-g++ -c -pipe -Wall -W -g -D_REENTRANT -fPIC -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_NO_DEBUG -I/tmp/qt-x11-free-3.3.4/mkspecs/armv5tel-linux-g++ -I. -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include/freetype2 -I. -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include -I../../../../include -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include -I.moc/release-shared-mt/ -o .obj/release-shared-mt/qnoneinputcontextplugin.o qnoneinputcontextplugin.cpp
qnoneinputcontextplugin.cpp: In member function `virtual QInputContext* QNoneInputContextPlugin::create(const QString&)':
qnoneinputcontextplugin.cpp:72: error: `getenv' undeclared (first use this function)
qnoneinputcontextplugin.cpp:72: error: (Each undeclared identifier is reported only once for each function it appears in.)
qnoneinputcontextplugin.cpp: At global scope:
qnoneinputcontextplugin.cpp:83: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp:88: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp:93: warning: unused parameter 'key'
make[4]: *** [.obj/release-shared-mt/qnoneinputcontextplugin.o] Error 1
make[4]: Leaving directory `/tmp/qt-x11-free-3.3.4/plugins/src/inputmethods/imsw-none'
make[3]: *** [sub-imsw-none] Error 2
make[3]: Leaving directory `/tmp/qt-x11-free-3.3.4/plugins/src/inputmethods'
make[2]: *** [sub-inputmethods] Error 2
make[2]: Leaving directory `/tmp/qt-x11-free-3.3.4/plugins/src'
make[1]: *** [sub-plugins] Error 2
make[1]: Leaving directory `/tmp/qt-x11-free-3.3.4'
make: *** [init] Error 2
root@darkstar:/tmp/qt-x11-free-3.3.4#
pgas
add stdlib.h in the list of includes in /plugins/src/inputmethods/imsw-none/qnoneinputcontextplugin.h

#include <qstringlist.h>
#include <stdlib.h>
wjping119
QUOTE(pgas @ Dec 15 2005, 07:44 AM)
add  stdlib.h in the list of includes in /plugins/src/inputmethods/imsw-none/qnoneinputcontextplugin.h

#include <qstringlist.h>
#include <stdlib.h>
*

I added it .now I can compile two inpuntmethod plugins libqimsw-multi.so and libqimsw-none.so,but I saw the archive qt-x11-free-3.3.4-uim.tar.bz2 you provided have another two plugins libqsimple.so and lib qxim.so ,I use the -inputmethod-ext

still have some errors

kernel/qapplication_x11.cpp: In member function `bool QETWidget::translateKeyEventInternal(const XEvent*, int&, QString&, int&, char&, int&, QEvent::Type&, bool, bool)':
kernel/qapplication_x11.cpp:5128: warning: unused variable 'status'
kernel/qeventloop_x11.cpp: In member function `virtual bool QEventLoop::processEvents(uint)':
kernel/qeventloop_x11.cpp:319: warning: 'ret' might be used uninitialized in this function
kernel/qinputcontext.cpp:707: warning: unused parameter 'x'
kernel/qinputcontext.cpp:707: warning: unused parameter 'button'
kernel/qinputcontext.cpp:707: warning: unused parameter 'state'
kernel/qinputcontext.cpp:681: warning: unused parameter 'x'
kernel/qinputcontext.cpp:681: warning: unused parameter 'y'
kernel/qinputcontext.cpp:681: warning: unused parameter 'w'
kernel/qinputcontext.cpp:681: warning: unused parameter 'h'
kernel/qinputcontext.cpp:681: warning: unused parameter 'f'
kernel/qinputcontext.cpp:479: warning: unused parameter 'event'
kernel/qinputcontext.cpp: In member function `virtual QString QInputContext::identifierName()':
kernel/qinputcontext.cpp:770: warning: control reaches end of non-void function
kernel/qinputcontext.cpp: In member function `virtual QString QInputContext::language()':
kernel/qinputcontext.cpp:791: warning: control reaches end of non-void function
kernel/qinputcontext_x11.cpp:66: warning: unused parameter 'keywidget'
kernel/qinputcontext_x11.cpp:66: warning: unused parameter 'event'

qnoneinputcontextplugin.cpp:83: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp:88: warning: unused parameter 'key'
qnoneinputcontextplugin.cpp:93: warning: unused parameter 'key'
qmultiinputcontext.cpp:255: warning: unused parameter 'newIndex'
qmultiinputcontextplugin.cpp:66: warning: unused parameter 'key'
qmultiinputcontextplugin.cpp:71: warning: unused parameter 'key'
qmultiinputcontextplugin.cpp:76: warning: unused parameter 'key'
qmultiinputcontextplugin.cpp:81: warning: unused parameter 'key'
qsimpleinputcontext.cpp:48:2: invalid preprocessing directive #in
qsimpleinputcontext.cpp:49:2: invalid preprocessing directive #clude
qsimpleinputcontext.cpp:182: warning: unused parameter 'x'
qsimpleinputcontext.cpp:182: warning: unused parameter 'y'
qsimpleinputcontext.cpp:182: warning: unused parameter 'w'
qsimpleinputcontext.cpp:182: warning: unused parameter 'h'
qsimpleinputcontext.cpp:182: warning: unused parameter 'f'
qsimpleinputcontext.cpp: In member function `bool QSimpleInputContext::checkComposeTable(uint*, const QComposeTable*)':
qsimpleinputcontext.cpp:239: error: `lower_bound' is not a member of `std'
gmake[4]: *** [.obj/release-shared-mt/qsimpleinputcontext.o] error 1
gmake[3]: *** [sub-simple] error 2
gmake[2]: *** [sub-inputmethods] error 2
gmake[1]: *** [sub-plugins] error 2
gmake: *** [init] error 2
pgas
have you done this?
QUOTE
The modification I made was to include algorithm in /plugins/src/inputmethods/qsimpleinputcontext.cpp

QUOTE

#include <qglobal.h>
#include <algorithm>
wjping119
yes,I have done it.and could not compile out the qtconfig binary at all
pgas
hmm, any error trace?

attached is the ipk created from my previous compile.

please test, remove qt-mt with
CODE
ipkg remove qt-mt

and install the attach file
CODE
ipkg  install qt-mt-uim
or
ipkg -d /mnt/card install qt-mt-uim)


use the command line as the gui packagemanager uses qt,
qtconfig runs for me.

Please tell me is something is missing in the ipk
wjping119
I installed it,and it works well tongue.gif
but I want to know,how you compile it,why so many warnings and errors emerge when I compiling it?
ShiroiKuma
QUOTE(pgas @ Dec 17 2005, 08:17 AM)
ipkg  install qt-mt-uim

What is the qt-mt-uim for? Is it as I assume to enable you to use uim-xim as an input method in qt apps?

I.e. in Konqueror etc?

If so, how do you do it? Just install this and then uim will work in qt apps? This is interesting...
wjping119
QUOTE(ShiroiKuma @ Dec 17 2005, 12:02 PM)
What is the qt-mt-uim for? Is it as I assume to enable you to use uim-xim as an input method in qt apps?

I.e. in Konqueror etc?

If so, how do you do it? Just install this and then uim will work in qt apps? This is interesting...
*


yes,you are right.some qt apps cannt input chinese by using scim input method((others I donot know),so it need patch the qt to build the inputmethod plugins
pgas
I compiled it with the help of the builder the configure options are (I should have give you this first sorry):
CODE
./configure  -xplatform armv5tel-linux-g++ -release  -shared -system-libjpeg -system-libpng -system-zlib -qt-gif -xft -xrender -sm -no-stl -no-g++-exceptions -no-cups -no-nis -no-nas-sound -no-tablet  -no-xkb -thread -disable-opengl -no-ipv6 -plugin-imgfmt-mng -no-xinerama


(you need the mkspecs/armv5tel-linux-g++ in the src tarball of the compiled tree)

The first error was due to the .h that are not in the include path if you don't make the links .
The algorithm missing is perhaps related to the gcc version.
The stdlib i don't know.

Warnings might be related to various things, gcc version, bad programming, arm platform...I didn't remember how many warnings I was having...
wjping119
Thank you very much,pgas,you are a kindhearted man.

Then I need compile scim-qtimm( http://prdownloads.sourceforge.net/scim/sc...ar.bz2?download )
although it is very small,but it seems have more problem
it can successfully finish configure

CODE
[root@MagicLinux scim-qtimm-0.9.3]# make
make  all-recursive
make[1]: Entering directory `/root/Desktop/scim-qtimm-0.9.3'
Making all in src
make[2]: Entering directory `/root/Desktop/scim-qtimm-0.9.3/src'
if /bin/sh ../libtool --silent --mode=compile --tag=CXX armv5tel-cacko-linux-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/qt/include -I/usr/X11R6/include -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include/scim-1.0   -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include/scim-1.0 -I/opt/cross/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include    -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -g -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common  -MT qsciminputcontext.lo -MD -MP -MF ".deps/qsciminputcontext.Tpo" \
 -c -o qsciminputcontext.lo `test -f 'qsciminputcontext.cpp' || echo './'`qsciminputcontext.cpp; \
then mv -f ".deps/qsciminputcontext.Tpo" ".deps/qsciminputcontext.Plo"; \
else rm -f ".deps/qsciminputcontext.Tpo"; exit 1; \
fi
qsciminputcontext.cpp:36: error: expected init-declarator before '<' token
qsciminputcontext.cpp:36: error: expected `,' or `;' before '<' token
qsciminputcontext.cpp:81: error: `ScimInputContextRepository' does not name a type
qsciminputcontext.cpp: In member function `void scim::QScimInputContextGlobal::finalize()':
qsciminputcontext.cpp:451: error: `ScimInputContextRepository' has not been declared
qsciminputcontext.cpp:451: error: `iterator' undeclared (first use this function)
qsciminputcontext.cpp:451: error: (Each undeclared identifier is reported only once for each function it appears in.)
qsciminputcontext.cpp:451: error: expected `;' before "it"
qsciminputcontext.cpp:453: error: `it' undeclared (first use this function)
qsciminputcontext.cpp:453: error: `input_contexts' undeclared (first use this function)
qsciminputcontext.cpp: In constructor `scim::QScimInputContext::QScimInputContext()':
qsciminputcontext.cpp:625: error: 'class scim::QScimInputContextGlobal' has no member named 'input_contexts'
qsciminputcontext.cpp: In destructor `virtual scim::QScimInputContext::~QScimInputContext()':
qsciminputcontext.cpp:674: error: 'class scim::QScimInputContextGlobal' has no member named 'input_contexts'
qsciminputcontext.cpp:675: error: 'class scim::QScimInputContextGlobal' has no member named 'input_contexts'
qsciminputcontext.cpp: In static member function `static scim::QScimInputContext* scim::QScimInputContext::find_ic(int)':
qsciminputcontext.cpp:1299: error: 'class scim::QScimInputContextGlobal' has no member named 'input_contexts'
qsciminputcontext.cpp:1300: error: 'class scim::QScimInputContextGlobal' has no member named 'input_contexts'
make[2]: *** [qsciminputcontext.lo] error 1
make[2]: Leaving directory `/root/Desktop/scim-qtimm-0.9.3/src'
make[1]: *** [all-recursive] error 1
make[1]: Leaving directory `/root/Desktop/scim-qtimm-0.9.3'
make: *** [all] error 2
[root@MagicLinux scim-qtimm-0.9.3]#  
pgas
adding
CODE
#include <map>

in src qsciminputcontext.cpp seems to fix that.

I have recompiled scim to build this, it should work with the libs in the rc12 feed (I hope)

I didn't test the attached ipk as I have no clue as to how this works.

If it works it would be nice if you could write a simple howto that I will add to http://mail.pdaxrom.org/contrib wink.gif
pgas
while I was at it I also compiled (natively) fcitx

http://www.fcitx.org/main/?q=node/10

I didn't test this one either.....
ShiroiKuma
QUOTE(pgas @ Dec 17 2005, 08:17 AM)
attached is the ipk created from my previous compile.
*

pgas, could you provide the compiled qt with includes, unstripped, and so? So that I can use it for building stuff?

This is related to me trying to build KDE 3.5. I've compiled Ot 3.3.5 but probably it's messed up somehow, because when I use it, I get strange character text behavior, characters missing, and tons of errors relating to bad windows positions or something. It took two days and nights to build on the Z, don't wanna do it again...

Thanks.
pgas
http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2

is the compiled source tree, I cross compiled this one

PS: it would be nice if someone tell me if the qt/scim fictx stuff is usefull....
ShiroiKuma
QUOTE(pgas @ Dec 19 2005, 10:02 AM)
PS: it would be nice if someone  tell me if the qt/scim fictx stuff is usefull....
*

Thanks for the sourcetree, I'll test it...

Not an answer to your question, but I think it doesn't work with uim, at least I tried briefly and doesn't seem to be. I'll try some more when I get done with my tries, successful or unsuccessful, of compiling the KDE stuff...
ShiroiKuma
QUOTE(pgas @ Dec 19 2005, 10:02 AM)
http://pierre.ellh.com/qt-x11-free-3.3.4-uim.tar.bz2

is the compiled source tree, I cross compiled this one
*

Is this Qt compiled without jpeg support? If I use the Qt 3.3.5 I've compiled, which is messed up, and log into KDE I see my desktop jpg wallpaper. With this version, I don't see no wallpaper, and also the logout screen show no picture, just the text.
pgas
it's compiled with -system-libjpeg (see the configure options above).
Now I didn't test it a lot
ZDevil
Great work, pgas!

I've tried both the qt-mt-uim and scim-qtimm packages. But I have yet to get them loaded. Both install fine, but both inputmethods don't seem to load in/together with my QT apps.

QUOTE(wjping119 @ Dec 17 2005, 01:37 PM)
I installed it,and it works well tongue.gif
but I want to know,how you compile it,why so many warnings and errors emerge when I compiling it?
*

How do you load the input method actually?

Despite many attempts to make sense of them, I still find the inputmethod issues rather confusing. tongue.gif So here are a few questions. It would be marvelous if someone can give a clear user guide:

1. Apart from qt-mt-uim, what other inputmethod related packages are required in order to get it to work?

2. What is the proper setting in qtconfig for the inputmethods: on the spot, over the spot, root, or disabled?

3. Do I need to edit .xinitrc? If yes, how? How should I set the followings:

export XMODIFIERS=
export XIM=
export XIM_PROGRAM=
export GTK_IM_MODULE=
export QT_IM_MODULE=

I've tried 'scim' in these and it works for GTK apps but still not QT ones. unsure.gif
And I cannot figure out how to bring up qt-mt-uim. unsure.gif
Pardon my ignorance I still couldn't figure out how they work after reading the related pages:
http://uim.freedesktop.org/wiki/UIM_2dXIM?...hlight&value=qt (qt uim?) Am I reading the right stuff?
http://immodule-qt.freedesktop.org/wiki/So...2fimmodule_2dqt (scim-qtimm) The page says "How to use: See README.immodule included in the patch." But I fail to find that doc anywhere.

4. Also how about the locale settings (export LANG= ,export LC_ALL, export LC_TYPE). Do they matter?

Many many many thanks to all your kind souls for your hard work. smile.gif smile.gif

PS Sorry one more question:
5. Now we have scim (including scim-qtimm), qt-mt-uim, and gcin. Can they co-exist and work side by side in the system?
wjping119
I am testing it too,you should know the qt_mt_uim was compiled for scim-qtimm,in order to scim support input chinese and other languages in qt apps.

at first,you should setting
export XMODIFIERS="@im=SCIM" (not scim)
export XIM=SCIM
export XIM_PROGRAM=SCIM
export GTK_IM_MODULE=scim (not SCIM)
export QT_IM_MODULE=scim (not SCIM)

qtconfig >> over the spot

that all.but I can not test it successfully too
you can go to www.scim-im.org to find it's wiki
ZDevil
QUOTE(wjping119 @ Dec 19 2005, 03:35 PM)
I am testing it too,you should know the qt_mt_uim was compiled for scim-qtimm,in order to scim support input chinese and other languages in qt apps.

at first,you should setting
export XMODIFIERS="@im=SCIM (not scim)
export XIM=SCIM
export XIM_PROGRAM=SCIM
export GTK_IM_MODULE=
export QT_IM_MODULE=SCIM

qtconfig >> over the spot

that all.but I can not test it successfully too
you can go to www.scim-im.org to find it's wiki
*


Thanks for your kind reply! I tried both 'scim' and 'SCIM' in the setting, and they seem to make no difference to me (scim runs anyway).
But I still can't get the qt packages to work.

Ok, let me first sum up the scim story a bit. This is the most I can do for now. Please correct me if I'm wrong anywhere.

==============================================================
SCIM for GTK & QT apps: How-to (rough draft)
Step 1
In order to use scim in both GTK and QT apps, one has to install (at least) these four packages:

scim_1.4.0-1_armv5tel.ipk (in the feeds)
scim-tables_0.5.3-1_armv5tel.ipk (in the feeds)
scim_qtimm_0.93_armv5tel.ipk (in this thread)
qt_mt_uim_3.3.4_armv5tel.ipk (in this thread; ipkg remove qt-mt first as suggested by pgas)

Step 2
And then go to the terminal, and type this and [Enter]
CODE
gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules


Step 3
Launch qtconfig,
then go to the Interface tab,
set the XIM Input Style to "Over The Spot",
save and exit.

Step 4
Edit .xinitrc (under /home/root),
Add the following lines in the beginning, below "test -f $HOME/.profile && ..."
CODE
export XMODIFIERS="@im=SCIM
export XIM=SCIM
export XIM_PROGRAM=SCIM
export GTK_IM_MODULE=SCIM
export QT_IM_MODULE=SCIM

Save the file,
and then exit,
and start the window manager again to let the new settting take effect.
ShiroiKuma
QUOTE(pgas @ Dec 19 2005, 12:37 PM)
it's compiled with -system-libjpeg (see the configure options above).
Now I didn't test it a lot
*

What does this option do? What would be the diffence when compiled without it?
ShiroiKuma
QUOTE(ZDevil @ Dec 19 2005, 03:13 PM)
and then exit,
and start the window manager again to let the new settting take effect.
*

What is a good Qt ap in which you can test whether the input is working?
ZDevil
QUOTE(ShiroiKuma @ Dec 19 2005, 04:22 PM)
QUOTE(ZDevil @ Dec 19 2005, 03:13 PM)
and then exit,
and start the window manager again to let the new settting take effect.
*

What is a good Qt ap in which you can test whether the input is working?
*



Er.... Sorry I can't tell you now, just because for the moment I don't have enough intelligence to make qt-mt-uim and scim-qtimm function on my 860. The rough guide is supposed to work, in theory (I hope). tongue.gif
wjping119
QUOTE(wjping119 @ Dec 19 2005, 01:35 PM)
I am testing it too,you should know the qt_mt_uim was compiled for scim-qtimm,in order to scim support input chinese and other languages in qt apps.

at first,you should setting
export XMODIFIERS="@im=SCIM" (not scim)
export XIM=SCIM
export XIM_PROGRAM=SCIM
export GTK_IM_MODULE=scim (not SCIM)
export QT_IM_MODULE=scim  (not SCIM)

qtconfig >> over the spot

that all.but I can not test it successfully too
you can go to www.scim-im.org to find it's wiki
*

please note it should be above context,I modyfied it.still in testing.....
pgas
Maybe it's not working....and was not built correctly sad.gif
wjping119
QUOTE(ShiroiKuma @ Dec 19 2005, 02:22 PM)
What is a good Qt ap in which you can test whether the input is working?
*

you can install kopi_178-1_armv5tel.ipk in the RC11 feed http://mail.pdaxrom.org/rc11/Zaurus-7x0-860/feed/
ShiroiKuma
QUOTE(wjping119 @ Dec 19 2005, 03:55 PM)
QUOTE(ShiroiKuma @ Dec 19 2005, 02:22 PM)
What is a good Qt ap in which you can test whether the input is working?
*

you can install kopi_178-1_armv5tel.ipk in the RC11 feed http://mail.pdaxrom.org/rc11/Zaurus-7x0-860/feed/
*


You're right, I could never input Japanese there. I'll try and test it...
ZDevil
QUOTE(pgas @ Dec 19 2005, 04:48 PM)
Maybe it's not working....and was not built correctly sad.gif
*


So far I've tried snotes, tuxcards, and vym. SCIM is not working with them.
Nevermind, pgas. I just can't say enough thanks to you for your great effort all along the way.
It is an extremely promising project indeed, and will benefit the Chinese, Japanese, and many other non-english Z communites tremendously. Although I can't do any coding and hardcore compiling, I'd always be ready to test any result and give feedback here. smile.gif smile.gif
wjping119
QUOTE(ZDevil @ Dec 19 2005, 03:03 PM)
Nevermind, pgas.  I just can't say enough thanks to you for your great effort all along the way.

yes,so do I.pgas make great effort for CJK user,all of us should thank him a lot.
now I want to know,how to test the inputplugins in qt and the scim-qtimm compiled correctly not by though test like this?
pgas
QUOTE
I want to know,how to test the inputplugins in qt and the scim-qtimm compiled correctly not by though test like this?


recompile everything with debug, run it inside gdb...
one thing that might be wrong is that I am perhaps missing a switch in configure for the input method, though it seems compiled with support for it.

Oh btw, did you try fcitx?
wjping119
QUOTE(pgas @ Dec 19 2005, 03:28 PM)
Oh btw, did you try fcitx?
*


yes,I tested it,but it only use for chinese simplified,it start well but cannot use, and I cannot setting it to make it working,I can not find anything I should do for it.I will look for some help from it's author.
pgas
while looking for xpaint I found this:

http://wing.nagaokauniv.ac.jp/wiki/index.php?files

It seems qt compile with uim is available there.
ZDevil
Thanks for the pointer! But it's in Japanese, and I still don't qutie get it after Babelfishing it:

"uim http://uim.freedesktop.org/wiki/UimDownload
There is qt-immodule.
Because the configuration file is insufficient, uim of feed is put and the superscription.
uim_0.4.7_armv5tel.ipk"

Anyone who can read japanese explain this to the rest of us? smile.gif

Anyways I'll try that package and see what it does. rolleyes.gif
ShiroiKuma
QUOTE(pgas @ Dec 23 2005, 03:53 PM)
while looking for xpaint I found this:

http://wing.nagaokauniv.ac.jp/wiki/index.php?files

It seems qt compile with uim is available there.
*

Anyone tried this package? I keep getting the error:
CODE
error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
when I try to run apps with this ipk installed?

Installed mesa3d which contains the libGL.so.1 and am trying it now to see if input works with this qt version.
ZDevil
Well, I tried these three packages, but still no luck. sad.gif

qt-mt_3.3.4_armv5tel.ipk
uim_0.4.7_armv5tel.ipk
scim-uim_0.1.3_armv5tel.ipk

I'm being kinda overwhelmed by the loads of info about locales and ways of activating the inputmethods.
Although I managed to launch the uim-toolbar-qt screen from the terminal, it seems to fail to do any effect; moreover uim-im-switcher seems to fail to see any table installed.
Still need quite some time to study them as the qt-uim sites tells much more technical details than a plain user how-to.
Tried the same way to scim-uim as I did to scim (including modifying .xinitrc) but nothing happened. What is the proper way to call scim-uim with scim?

Also strangely qtconfig is missing, or is it what this means?
QUOTE
qt-mt ftp://ftp.trolltech.com/qt/source/
immodule(http://www.kde.gr.jp/~daisuke/immodule_for_qt/pukiwiki/)が入っています.
qtconfigなどが無いので,feedのqt-mt3.3.3を入れてから上書き.
qt-mt_3.3.4_armv5tel.ipk


Any hint more straightforward than those on the source sites are most appreciated. Thanks ...
ShiroiKuma
QUOTE(ZDevil @ Dec 24 2005, 11:45 PM)
Well, I tried these three packages, but still no luck.  sad.gif

qt-mt_3.3.4_armv5tel.ipk
uim_0.4.7_armv5tel.ipk
scim-uim_0.1.3_armv5tel.ipk

Did the same, doesn't work...

QUOTE
Also strangely qtconfig is missing, or is it what this means?
QUOTE
qt-mt ftp://ftp.trolltech.com/qt/source/
immodule(http://www.kde.gr.jp/~daisuke/immodule_for_qt/pukiwiki/)が入っています.
qtconfigなどが無いので,feedのqt-mt3.3.3を入れてから上書き.
qt-mt_3.3.4_armv5tel.ipk


Any hint more straightforward than those on the source sites are most appreciated. Thanks ...
*


Just means to overwrite the qt-mt installed first from the feed with the above ipk, that way you'll have qtconfig... That doesn't help though...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.