Help - Search - Members - Calendar
Full Version: Possible To Have Hotlinks In Sharp Email
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
tombraider
I installed Opera 7.30 and it works fine, but I sure would like to be able to click on a hotlink in my email and go to Opera instead of NetFront. I get the NYTimes each morning by email and like to just click on the hotlinks like I do with my SL5500 and read the articles in Opera.

NetFront displays the NYTimes articles with the print ruinning down the left side like this:
T
o
d
a
y

i
n

I
r
a
q

Am I the only one having that difficulty with NetFront???? I have tried all the different settings...."Disabled". "JustFit", "SmartFit"....it all displays the same way.
loc4me
you need to chage the mime types to reference opera. There are multiple threads on it. So a search and you will find them. If not i can post a link here.
tombraider
I found out how to do it on meanies site, however, opera.desktop is blank and cannot be edited. Permission problem?? netfront3.desktop is blank also and cannot be written to. What now?

Thanks.

QUOTE(loc4me @ Dec 15 2005, 08:49 PM)
you need to chage the mime types to reference opera. There are multiple threads on it. So a search and you will find them. If not i can post a link here.
*
Cresho
you should of tried my way if installing opera. It fixes all kinds of problems and corrects permissions. also, makes it the default application for opening html files.

http://www.oesf.org/forums/index.php?showt...=15584&hl=opera

if you are still having file association problems, then ill post on how to fix it too.

...hmmmm list the type of file extension the mail is reffering too.. another thing, are you using the build in mail applications from sharp?
Greg2
QUOTE(tombraider @ Dec 16 2005, 10:58 AM)
opera.desktop is blank and cannot be edited.  Permission problem?? netfront3.desktop is blank also and cannot be written to.  What now?

If you install and use the ZEditor to open those files, I think you will find that they are not blank.
Here:
http://satoshi.web5.jp/f_soft/dw_engzd.htm

After you install it, hold on icon and check 'Execute with root privilege'.

Greg
tombraider
Actually, I DID follow your instructions for the Opera install including the permission instructions, and the html files are already associated with Opera, it's just the darn email links that pop up in Netfront! Thanks for those great instructions. Worked like a charm.

Yes, it's the original Sharp email package on the c1000. I'm not sure I can tell what form the links are in...they just appear in a bright blue font.

I also managed to open the opera.desktop and netfront3.desktop files on my Windows computer and they both contained MimeType=text/html
so I deleted the reference in netfront3.desktop and rebooted and still no joy.

It has to be a setting in the Sharp email utility itself that calls up Netfront. I wonder if it's in the .conf file or something. I'll check it out tomorrow and compare files of the email utility on the c1000 to the files on my sl5500.

I'm running out of steam for today...have installed JustReader, Zsafe, ZUC, Qtopia Alarm, Clipboard (need a bigger icon in the tray for that), Zeecookbook, Zbedic with tons of dictionaries, IQNotes, the beautiful screensavers from Screensavers, a new bootup screen with a picture of my daughter.....and many other ipks which I have now forgotten. :-)

Fooled with Kismet for hours and could not get an install to work even though I have it working on both my 5500's. That's something for another day also.

I tried your method of installing video and the last package install - kino2 failed with that "Sorry something went wrong" message, but I really don't need to install the mplayer anyway since the built in player plays my mpeg videos and I have an Archos AV420 to play all the large videos I want (20 GB drive).

Thanks for trying to help. :-)

QUOTE(Cresho @ Dec 16 2005, 09:06 PM)
you should of tried my way if installing opera.  It fixes all kinds of problems and corrects permissions.  also, makes it the default application for opening html files.

http://www.oesf.org/forums/index.php?showt...=15584&hl=opera

if you are still having file association problems, then ill post on how to fix it too.

...hmmmm list the type of file extension the mail is reffering too.. another thing, are you using the build in mail applications from sharp?
*
Cresho
here is a modified clipboard application with a nice clipboard applet and also..

http://www.oesf.org/forums/index.php?showt...160&#entry89160
tombraider
Bump...

I have NEVER solved this problem...I cannot get the HOTLINKS in QtMail to open with Opera instead of NetFront AND BEFORE EVERYONE JUMPS all over me about all I have to do is modify the mimes.types file and modify the opera,desktop file - that DOES NOT WORK. All html files on my C3200 DO open with Opera but the HOTLINKS in emails DO NOT!

(Hee, hee, I'm shouting because this is extremely annoying to me.)

Now the Cacko ROM DOES have the hotlinks in QTMail open with Opera so there must be some way to do it! I just don't want to flash to Cacko ROM only for this one issue.

Is there any guru out there who knows how to solve this problem?

Thanks a million in advance.

QUOTE(tombraider @ Dec 15 2005, 03:42 PM)
I installed Opera 7.30 and it works fine,  but I sure would like to be able to click on a hotlink in my email and go to Opera instead of NetFront.  I get the NYTimes each morning by email and like to just click on the hotlinks like I do with my SL5500 and read the articles in Opera.

NetFront displays the NYTimes articles with the print ruinning down the left side like this:
T
o
d
a
y

i
n

I
r
a
q

Am I the only one having that difficulty with NetFront????  I have tried all the different settings...."Disabled". "JustFit", "SmartFit"....it all displays the same way.
*
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.