Help - Search - Members - Calendar
Full Version: Noia Theme For The Sl-6000
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 6000 - Tosa
Cresho
I need a beta tester.

back up your pda and install this.

this is what i am looking for------

1. startup png in place and also default wallpaper working properly.

2. icons all covered in noia theme and no missing anything and stuff out of the ordinary.

also, email screenshots to cresho@earthlink.net so i can post...add your username in the forums to give you credit.


one last thing. after you boot up, rotate landscape and portrait mode. I would like to see if the image works properly in both formats. i may need to create another wallpaper to insure that it looks like to fit in both formats..... dry.gif


thanks.

cresho

http://www.zaurusthemes.org/oddpics/test.zip
the_oak
Got error message:

"Not enough internal memory for working"

How much internal memory is needed? I have 3784 KB.
the_oak
Uninstalled some programs and had about 9000 KB free internal memory. Installed your noia icon beta (using the Add-Remove Software app), and got the following results:

Error message: "The extract of some files are failed. This application may not execute normally. When you cannot operate the application, please remove it."

No noia icons appeared after the flawed install. Tried uninstalling noia theme, which removed all icons, including Sharp defaults. Reinstalled noia icons, and got the same message as above. Was missing icons for:

Calendar, ToDo List, Email, Text Editor, Hancom Sheet, Hancom Word, Voice Recorder, Calculator, Help Browser, Media Player, Imaging, and on the Settings Tab was missing icons for: Network, Appearance, Add-Remove Software, Security, Application Key, Date/Time, Backup Restore, System Info, and Beam Receive.

Also missing are the icons for moving up in the Files Tab, and red and blue dots in Add_Remove Software app.

Rebooted and never saw boot screen image, just a blank screen (After the default Sharp screen). Then taskbar icons were too tiny to see, and CF taskbar icon was gone.

Wallpaper looks fine in landscape mode, but looks "stacked" in portrait mode. This is probably because it needs to be 640x640 resolution. I extracted the 640x480 version from your ipk and made a 640x640 version that works well with my regular Sharp setup. Here it is:

Hope this helps with getting noia icons for 6000. Thanks for all your hard work.

Edit: forgot to mention that Opera icon was there, so whatever is different about that icon may be the key. Also, any suggestions about other things to try to get this working?
Cresho
okay. i did the suggested and added to the new ipk. Please try again.


This time on a fresh install. or try giving your pda more free space. Since i added a bunch of some useless and more usefull icons in the "xtra" folder to cover custom applications, it covers around 7mb of needed space on your internal drive.

so this time.....

leave around 15mb free space

reboot after install.

http://www.zaurusthemes.org/oddpics/testpart-2.zip

report background image if it works both landscape and portrait, can see bootup screen, and any missing or abnormal icons.

thanks.
BarryW
Had to install as root in console. Boot screen looks good! Background looks good in portrate, but tiles funny in landscape. I don't see any missing icons. I like this theme.
Cresho
when you tried to install using the package manager, what errors did you get? i used the same process as the gant one. so what is the difference between the gant and the noia?
the_oak
Had 11696 KB internal memory free and used Add-Remove Software app to install theme again. Got the same error message as before:

"The extract of some files are failed. This application may not execute normally. When you cannot operate the application, please remove it."

But more stuff copied over this time. Startup screen was there on reboot, and only icon problem is the Q (start) button in lower left corner of screen is still the Qtopia one. Also on Documents tab, the SD card icon is small. All other icons are there and beautiful. But rotating the screen causes problems. I get a taskbar on the right AND on the bottom of the screen and desktop wallpaper does not rotate. I use right-hand rotate, and if I change to left-hand rotate, then everything works as it should. So I suppose that these few problems are because of not freeing enough internal memory before installing.

After the install, I have 6300 KB of internal memory left.

I am restoring my nand backup and trying to free up more space as you suggested, but was hoping not to need quite so much for this theme. Is it possible to make a lite version of this ipk without "extra" icons? (For those of us with low internal memory space left.) I would like to "have my cake and eat it too" (have all my programs installed AND this theme if I can fit them all).
Cresho
thanks oak..

It helped me figure out what causes the problem. Ill have something up in 2 days since i ran out of free time.



------------------------

here is something interesting, i found that my installer throws the files in different locations.

can sombody test the defaults vs the gant one? i would like to see what kind of errors people are getting>? I assume the defaults one causes errors as of the gant does not. Please report finding. I may need to update these as well.


thanks.
the_oak
OK, uninstalled some more apps to free up space and used Add-Remove Software app to install noia theme. Everything is there, with no error messages. Left-hand rotate works perfectly, but right-hand rotate still does not work right. I still get taskbars on left and bottom if I rotate the screen right. Also desktop wallpaper and icons don't rotate (they remain in portrait mode). Guylhem's rom also does this only with right-hand rotate, and he thought it was a font problem. Are the fonts changed in this theme?

All in all, if users have the memory space and if right-hand screen rotation is not used, this theme is very nice indeed. attached are 2 portrait screenshots.

Edit: Forgot something VERY important: A big THANK YOU!!
the_oak
2 more screenshots (left-hand rotated landscape):
Cresho
okay!

I never had anybody test this one but its been up for days...months.

its to restore the theme to stock rom

http://www.zaurusthemes.org/content/zaurus...000_1.0_arm.zip

i am wondering if it works..can anybody test?
the_oak
I think I know why right-hand rotate did not work. If you used the 640x640 wallpaper that I posted earlier, it was a png image. I just noticed that it does not rotate to the right with the default icon set either. I should have saved it as a jpg. So here is a jpg of that same image. It fixed the right-hand rotate for the default icon set, and I think it will for the noia theme too.

I think I will go back and change the attachment I posted earlier too.

This also saves about 211 KB of space smile.gif
ceffyl
QUOTE(Cresho @ Dec 17 2005, 02:47 AM)
okay!

I never had anybody test this one but its been up for days...months.

its to restore the theme to stock rom

http://www.zaurusthemes.org/content/zaurus...000_1.0_arm.zip

i am wondering if it works..can anybody test?
*


I'll test it and let you know. I currently have the Gant 6k theme installed. I'll let you konw if this one works or not.

Ceffyl
Cresho
QUOTE(ceffyl @ Dec 19 2005, 07:35 AM)
QUOTE(Cresho @ Dec 17 2005, 02:47 AM)
okay!

I never had anybody test this one but its been up for days...months.

its to restore the theme to stock rom

http://www.zaurusthemes.org/content/zaurus...000_1.0_arm.zip

i am wondering if it works..can anybody test?
*


I'll test it and let you know. I currently have the Gant 6k theme installed. I'll let you konw if this one works or not.

Ceffyl
*








biggrin.gif
loc4me
Cresho:
Is there any reason why the themes cant be installed to the SD card. If it is formated ext2 can't the ipkg installed just rename the original pics dir then make simlinks to the new theme dir on the sd card. This seems like it would be really easy. Then when uninstall the ipkg just renames the original pic dir back to default and removes the sim link.

I guess there is some reason why this doesnt work b/c some one would have done this if it was really that easy. ????????????????????

Thanks
ceffyl
QUOTE(Cresho @ Dec 19 2005, 05:42 PM)
biggrin.gif
*


Greetings.

I uninstalled the Gant theme and rebooted. When the Z. came back up, most of the icons were missing, which was expected. I unpacked the default icon IPK from the Zip archive and copied it to my Z. When I tried to install the package using the Add/Remove Programs interface, I received an error message that some of the files could not be extracted. The package did not install properly.

I tried recopying the file to my Z, but had the same result. Is there another IPK I should try?

~Ceffyl
Cresho
here is the link to the new ipk. Please just take a quick moment and check for missing anything.


rolleyes.gif

http://www.zaurusthemes.org/content/zaurus...000_1.1_arm.zip
neuroshock
Hey guys,

Nobody crucify me here- but I've NEVER tried to install a theme on any of my Zaurii. Ever. Will these work with pdaXrom? Do they work with all Roms or just Sharp's?

This one and the Gant one are just eye poppers and I'm getting ready to redo my SL-6000L now that I've got my C3100 in enough shape to take over most of my day-to-day duties, and I'd like to include a theme change.

Thanks all!,
-NeuroShock
Cresho
will not work for pdaxrom..but i did see a pdaxrom theme with gant on it a while back...i accidently bumped into it long ago.
Cresho
QUOTE(Cresho @ Dec 19 2005, 05:37 PM)
here is the link to the new ipk.  Please just take a quick moment and check for missing anything.


rolleyes.gif

http://www.zaurusthemes.org/content/zaurus...000_1.1_arm.zip
*



anybody try this one out yet?
Cresho
QUOTE(Cresho @ Dec 19 2005, 05:37 PM)
here is the link to the new ipk.  Please just take a quick moment and check for missing anything.


rolleyes.gif

http://www.zaurusthemes.org/content/zaurus...000_1.1_arm.zip
*



anybody try this one out yet?
ceffyl
QUOTE(Cresho @ Dec 22 2005, 10:55 AM)
anybody try this one out yet?
*


Just got back from vacation. I'll try this out in the next day or so.

Ceffyl
bluedevils
Same here. I came home last night. I'll try and install it soon

QUOTE(ceffyl @ Dec 27 2005, 01:38 PM)
QUOTE(Cresho @ Dec 22 2005, 10:55 AM)
anybody try this one out yet?
*


Just got back from vacation. I'll try this out in the next day or so.

Ceffyl
*

ceffyl
QUOTE(Cresho @ Dec 22 2005, 10:55 AM)
anybody try this one out yet?


Hi, Cresho.

I just tried installing the default icons for the Z 6k version 1.1 that you posted here. Iniitially everything seemed to install fine. The IPK was recognized and seemed to install find. However, when I closed the package installer to return to Qtopia, the Z. hung. I had to remove the battery and reboot.

The Z. came up and all of the icons appeared to be there. The only ones that looked strange were Nethack (missing) and the Close and Help icons in the upper right corner of the application windows. Whenever a Z is rebooted, it has an annoying habit of always asking for the date/time to be set. The help and close icons on this screen seemed too small. Everything else seemed to be okay.

I had some trouble uninstalling version 1.0 of the Z default icons. I have three version 1.0 ipks listed in my installed packages (displayed when choosing Add/Remove Programs and Uninstall). I wanted to see if this version had the same problem.

When I viewed the list of applications to install, the Z. icons version 1.1 was not shown as installed. However, the Z icons version 1.1 were listed in the set of installed packages that could be chosen to be uninstalled. I uninstalled the icons, rebooted, and everything came up normal.

So a definite improvement. All of the icons appear to be there (except for Nethack). I don't know if the wierdness I experienced during installation was just a quirk on my Z or maybe a conflict with another app I have installed.
Cresho
yeah these needs to be installed on a fresh install. that way i can get a baseline on whats going on.

thanks for trying.

ohh...one last thing....the time adjustment pop up, did this pop up before?
ceffyl
QUOTE(Cresho @ Dec 29 2005, 03:03 AM)
yeah these needs to be installed on a fresh install.  that way i can get a baseline on whats going on.
thanks for trying.
ohh...one last thing....the time adjustment pop up, did this pop up before?


Sorry about the non-default state. It is the stock 6k ROM, although I have several apps installed that didn't ship with the ROM.

This is the first time I've had any trouble with the Z hanging when installing icons. That was very unusual. I'm tempted to uninstall and reinstall and see if that changes anything.

~Ceffyl
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.