Help - Search - Members - Calendar
Full Version: Cacko 1.23 + Stowaway Bluetooth Keyboard Problems
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Sharp ROMs
Hallo! Firstly I'd like to say THANK YOU to Anton Maslovsky and all those who have helped with debugging and testing and suggestions for Cacko. I installed it on my C3100 (after previously using a hideously hacked up kernel amongst other things) and it is WONDERFUL.

I've gotten everything working on it right out of the box and it's been a pleasure to use. Really my hat is off to all of you.

Now to my reason for posting: I use a ThinkOutside Stowaway Bluetooth Keyboard. I am able to get it recognized easily with Cacko and my Socket 2.5+ Bluetooth Card Rev G. but my keyboard mapping is haywire. I previously had it working quite well using Tetsu's v18b kernel for the C3100 and a re-worked hidp.o that I got from:

Something Interesting Archives (Japanese)

When I switched over to Cacko 1.23 naturally my modifications were gone but I had somehow hoped upon hope that my bluetooth keyboard would work just fine (everything else did so I thought I was on a roll biggrin.gif .)

Unfortunately, that just isn't the case. I've tried replacing the hidp.o and usbkbd.o that I had from my Tetsu kernel and the modified one from the Something Interesting Archives blog but to no avail. Nothing works. It seems the keys are off and just aren't responding right. I can't use KeyHelper to remap some of the keys it seems as some of them are making Sharp Special codes like 0x200e or some such and they just show up as ffff in KeyHelper and I can't input the correct letter for those.

Anyone have any ideas? Cacko 1.23 has made me a believer biggrin.gif I can't say thank you enough for all the work that's gone into it. I'll definitely be a regular financial supporter of this project here on out and I'd definitely not have any problems being a guinea pig, especially if it involves fixing the keyboard wink.gif

Thanks for any help whatsoever!
guess not eh... *sigh*
wahhh... ok... i'm ok now. sad.gif
There is another variable that controls the keyboard setting, in
This variable gets modified (in order to support East European character sets?) when you install Cacko.

Its a longshot, but maybe you should try changing it back.
See item 10 of this post:

Good luck.
Have the same problem with Think Outside Slim BT keyboard from Stowaway.
It gets connected through BlueZ but the key mapping is off.
Have you found a solution?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.