Help - Search - Members - Calendar
Full Version: Mounting A Remote Nfs Volume
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
JerryAttrix
RC12 is a smooth piece of work, and most things work out of the box. However, I'm trying to mount a remote NFS volume:

mount -t nfs {url}:{exported path} /mnt/net

and it just hangs. (It all works fine under Cacko.) Is this a problem anyone else has?
pgas
http://www.pdaxrom.org/index.php?showid=26&menuid=8

Q:
When i try to mount an NFS share it takes a long time/forever?
A:
Use the -nolock parameter when mounting. Some people also recommend using the server:/zaurus /mnt nfs noauto,hard,intr,nolock,async,nfsvers=2 0 0
JerryAttrix
Many thanks for the pointer. I tried an FAQ search but failed to turn that up. Must try harder.

The command that worked in the end was:

mount {server}:{path} /mnt/{mountpoint} -t nfs -o noauto,hard,intr,nolock,async,nfsvers=2
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.