Help - Search - Members - Calendar
Full Version: Comments, Bugs & Questions For C3000 Pdaxrom Beta
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
pgas
Danboid (who has trouble registering) says:

I've been playing with the first pdaXrom beta for the C3000 today and I'm very impressed- big thanks to Thc, sashz and the rest of the pdaXrom devs for putting together such an amazing distro for the Z. I followed Thc's install instructions and it installed fine. However, I had a few problems that I'd like to point out.

VIRTUAL KEYBOARD

Didn't work at all for me, so of course this means I can't use my Z in portrait mode with the keyboard tucked away. Pushing the 'ABC' icon in the panel did nothing. I went to 'Panel' in the pdaxrom menu and chose 'Virtual keyboard' and so now I've got 2 abc icons that don't work in my panel. How do I get rid of the second one (or any panel icon under matchbox)?

USB CONNECTIVITY

This was the other big thing missing for me. USB connectivity was better than under Cacko in one respect as I could connect first time (I normally have to unplug, say 'No' to 'Alert USB..' then plug the Z back in again to get the 'Communicating' screen up under Cacko) but sadly there is no option to mount the /hdd3 internal HD partition as a USB disk like under Cacko, only the CF of SD card slots. I presume this feature is planned for the next release?

PACKAGE MANAGEMENT

I thought it was fantastic being able to download new progs with a click over WiFi on my Z- I just wish the pdaXrom package manager resolved the dependencies for you. Installing gnumeric took an age, mainly due to all the errors that come up on this beta when installing stuff- each package takes about 5mins to download and install! I'm sure that will be fixed in the next release. As has already been mentioned in the beta announcement thread, before you can get packages to install you must edit /etc/ipkg.conf and change /mnt/ide to /mnt/hdd1, /mnt/ide2 to /mnt/hdd2 etc. The official pdaxrom feed sites were down when I last tried them so I used this URL instead:

http://zaurus.spy.org/feeds/cacko/pdaXrom/1.1.0/rc12/feed

Don't put a / on the end, that seemed to break it for me. I installed a few packages, not many though, before I was told that I'd run out of space and couldn't install any more. On that same beta announcement thread, somebody said that I need to change /tmp so it is located on hdd2. I was told I couldn't delete /tmp (which was linked to /dev/shm/tmp) as it was a RO filesystem so I did this

***DONT DO THIS, IT WILL WRECK PDAXROM!***

cd /dev/shm
rm -rf tmp
ln -s /hdd2/tmp tmp

I was hoping that would fix it but now I can't start anything under pdaxrom or even quit out of it to the shell sad.gif Are there any instructions on how to re-install a borked pdaxrom install and then I need to know the proper commands for changing the /tmp directory or whatever it is I need to do to get more program install space.

SUSPEND

When I close the screen on my C3000 under Cacko it puts the Z into suspend mode. This doesn't seem to be the case with the C3000 beta.

HIDING PANEL/ RESIZING WINDOWS/ RUNNING GIMP

I installed The GIMP but when I ran it I couldn't click through the setup screens as the 'Next' and other buttons were either covered by the panel or off the physical screen area. I tried resizing the window but had no luck. Is there no way to minimise/move the Matchbox panel or a keyboard shortcut for resizing windows?

VIRTUAL DESKTOPS

Wha? No virtual desktops under Matchbox? sad.gif

VIDEO PLAYBACK

After a bit of experimenting, I found the best command to play vids was

mplayer -fs -vo sdl moviefile

When I've got pdaxrom running again I've got to try installing the shared-mime-types package and getting vids lauched with a click from under rox-filer.

MISSING PACKAGES

dillo isn't good enough for most people as it doesn't support javascript and so can't access sites such as Yahoo! mail. I'd like to see either Firefox, Embedded Konqueror or another, better browser installed as standard instead. Why is there no GUI file manager installed by default? Rox-filer or xfe as standard would be nice! I would imagine most people install mplayer and I would like to see gnumeric as a default app too as I think most PDA users want a speadsheet and it is such a pain to install. Are there legal issues with bundling mplayer? Maybe so. Also, I do realise that gnumeric needs the GNOME libs and that will significantly increase the size of the ROM image, maybe hold a vote for that one?

UNTESTED

There were only a few things I wanted to test before I bricked my install, and hence aren't really as important questions as the ones before as I'll find out soon enough but it would be still nice to know:

Wake-on-alarm under Ko/pi (does this work?)

Adding and removing my own program links and folders to the Matchbox interface

Printing diect to my printer via USB

Running another desktop instead. When I change X to launch rox/equinox/xfce instead will it be configured for pdaxrom already or will I have to set everything up myself (panel battery monitor etc.)

Thanks for your help!

dan
flavien
USB CONNECTIVITY
=> Work good with TCP/IP (tested)

PACKAGE MANAGEMENT
edit ipkg.conf and change tmp path to /hdd2/tmp and it ok

HIDING PANEL/ RESIZING WINDOWS/ RUNNING GIMP
=> use ALT + Stylet to move window (ALT is the button on the right of CTRL) tongue.gif

MISSING PACKAGES
=> Waiting for a mirror of mail.pdaxrom.org

UNTESTED
=> solve first problems with kernel and implementation of SL-C3000( HD management & partition, core package bug etc... )

ph34r.gif Any issue for IPKG lot of errors ? (problems with dependances)

I think it is the first step to begin to debug
gromituk
QUOTE(Danboid c/o pgas @ Dec 26 2005, 08:55 AM)
VIRTUAL DESKTOPS

Wha? No virtual desktops under Matchbox? sad.gif

Ctrl-Alt-left/right gives you the choice of 4 - at least for an 860!
QUOTE
Wake-on-alarm under Ko/pi (does this work?)

It never did, but people have been trying hard to make it work recently - see a separate thread.
oncle-dave
for the USB connection :


Edit the file /usr/bin/usbfunction.py


print MODEL

if (MODEL.find("SL-C3100") != -1):
STORAGE_OPTS = ["/dev/mmcda1","/dev/hda1","/dev/hda2","/dev/hda3","/
elif os.path.exists("/dev/.devfsd"):
STORAGE_OPTS = ["/dev/mmcd/disc0/part1","/dev/hda1"]
else:
STORAGE_OPTS = ["/dev/hda3"]


Change ["/dev/mmcda1","/dev/hda1"] to ["/dev/hda3"]

And then you can acces to you Zaurus like usb HD .

Oncle-dave
flavien
QUOTE(pgas @ Dec 26 2005, 05:55 PM)
*
VIRTUAL KEYBOARD
Didn't work at all for me, so of course this means I can't use my Z in portrait mode with the keyboard tucked away. Pushing the 'ABC' icon in the panel did nothing. I went to 'Panel' in the pdaxrom menu and chose 'Virtual keyboard' and so now I've got 2 abc icons that don't work in my panel. How do I get rid of the second one (or any panel icon under matchbox)?


CODE
edit /usr/bin/xvkbdlauncher

remove line 38,39,40,41


now the virtual keyboard appear but on the top of the screen indead of the bottom

enjoy ! laugh.gif
elektron
Suspending while playing mp3's in XMMS broke audio.

tried restarting sdpd ( i think that's esound ? ). no go.

rebooted to fix.
ThC
elektron, next time : close xmms then open an xterm or aterm and "killall esd" ... then relaunch xmms everything should work wink.gif
flavien
QUOTE(pgas @ Dec 26 2005, 05:55 PM)
Danboid (who has trouble registering) says:

PACKAGE MANAGEMENT

I thought it was fantastic being able to download new progs with a click over WiFi on my Z- I just wish the pdaXrom package manager resolved the dependencies for you. Installing gnumeric took an age, mainly due to all the errors that come up on this beta when installing stuff- each package takes about 5mins to download and install! I'm sure that will be fixed in the next release. As has already been mentioned in the beta announcement thread, before you can get packages to install you must edit /etc/ipkg.conf and change /mnt/ide to /mnt/hdd1, /mnt/ide2 to /mnt/hdd2 etc.


To disable auto install depencies and remove all messages that slow down the zaurus

edit /usr/bin/ipkg

comment line 553 & 554
CODE
#  new_deps=`echo $new_deps | sed -e 's/[[:space:]]\+/\\
#/g' | sort | uniq`



After you need to install all depencies by hand but it is more speed than bug wink.gif

Enjoy ...
Mongus
Thanks to flavien's ipkg hint I've got it working correctly now! The problem is that the sort command is linked to busybox but busybox doesn't handle it. If you look closely at all the ipkg errors they contain the text that busybox spits out when you call it directly. laugh.gif

It's not too hard to fix. First, install the coreutils package to get the real sort command. Then you'll need to remove the sort symlink to busybox.
CODE
mount -o remount,rw /dev/root /
rm /bin/sort
mount -o remount,ro /dev/root /


Now ipkg should work correctly. biggrin.gif

BTW, I finally got my Audiovox RTM-8000 GPRS modem working! Yesterday was the first time I've seen it working on my Zaurus. I hardly had to do anything to get it working on rc12. Now I can finally use it for what I intended when I got it in April.
ThC
in fact, the coreutils package install is not needed as /usr/bin/sort is allready present ... it was my fault adding the sort symlink in /bin and forgetting it there ... thanks for pointing this one out wink.gif
Da_Blitz
MPLAYER:

Try mplayer -vo bvdd -vm -fs *.avi
you will have to get the special "iwmmxt" version (just nick it from a cakco feed and untar it) but once that is done you should see the same speeds as under cacko

that said i havent tested it yet due to usb problems and ipkg (at leaast we now have a fix)
danboid
Thanks for your help everybody! You managed to answer pretty much all my questions and solve most of the bugs.

I got my OE account sorted out- all that had happened was that the confirmation e-mail got sent to my junk mail and I never check that.

I've put the Cacko 1.23b back on my C3000 now until Thc releases his next beta. Can't wait to see if Kword and kspread will run OK!

Happy New Year!

dan
flavien
QUOTE(Da_Blitz @ Jan 3 2006, 12:06 PM)
MPLAYER:

Try mplayer -vo bvdd -vm -fs *.avi
you will have to get the special "iwmmxt" version (just nick it from a cakco feed and untar it) but once that is done you should see the same speeds as under cacko

that said i havent tested it yet due to usb problems and ipkg (at leaast we now have a fix)
*


CODE
mplayer -vo bvdd -fs *.avi

or
CODE
mplayer -vo bvdd -ao sdl -fs *.avi

and
CODE
overclock @ 624 mhz


I can not play movie at 640x336 without problem of lag.
With Cacko everything was OK.

I test this :
CODE
mplayer -vo bvdd -nosound -fs *.avi

and no problem of lag.

Can somebody know why or help us to find ?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.