Help - Search - Members - Calendar
Full Version: 5600 permissions? nethack and gutenbrowser ...
OESF Forums > General Forums > General Support and Discussion > Software
Anonymous
I just got a 5600, yesterday, and I have been putting some software onto it with limited success ... gutenbrowser didn't work as installed because of permissions issues (i think because when i hit the icon it runs as 'zaurus' but it installed as root, maybe). When I try and run nethack from the icon, i get the first screen and then hit 'Play' and it exits. When I run it from the shell, I get all sorts of issues with permissions ... am i doing something wrong when i install? or do i have to handle all of these permissions problems individually?

what am i missing?

thanks!
joebeaudoin
Typically, you can run things as root user from the laucher by using the tap-hold method. Once you do that, you'll have the option to run the program as root (there are a few exceptions to this, particularly with the default Z apps) but otherwise it should work.

Additionally, if you want to run something via terminal, I recommend downloading & installing the sudo ipk. Makes things a lot easier for you.

P.S. There seem to be issues with the newer version of nethack on the 5600... Not sure how to recitfy it though (because it hasn't been too much of a concern for me).
RichS
Take Joe's advice. I finally broke down and installed nethack just the other day. Had the same problems as you on my 5600, saw the same results in terminal. So I ran it as root and it works fine...
No doubt, you could chown the nethack directory so you could run it as zaurus, but I'm lazy and if root works, that's fine with me...

As far as "issues"? I haven't played much yet but it does seem to work fine, except for the root thing anyway...
joebeaudoin
Just curious, but what version of Nethack did you install, Rich? The version I tried to install is 3.3.1-4.

When I installed Nethack through Sharp's IPKG Manager, it spat out an error message stating that it couldn't install some files correctly. Is there a better version out there somewhere or do I have to install it differently?
RichS
I installed qpe-nethack_3.4.2-2_arm.ipk. The only 'problem' it gave me was needing to be in internal mem instead of a card. Surprisingly, it didn't seem to use all that much after installation though. I used the 'Add/Remove' built-in with and don't remember any problem or messages. I haven't tried installing the sound package yet, and that seems like a bit too much, but who knows?
stampsm
well i got nethack to work on my 5600
i had to chmod i few files i cant remember which ones but i think it included the nethack binary, it's folder, and a few other files
i can now play it fine from the icon and every thing goes well till i try to save it and it says it can't open the save file and won't let me save it
does anyone know how to fix this saving problem it kind of ruins the point of playing it you can't save it
RichS
The only 'permissions' I set when I installed it was to hold down the stylus on the nethack icon and set it to run with root priviledges. I've found most of the software written for the 5500 work just fine after setting this option as the original 5500 only ran as root and the software was written to run that way... Give it a try...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.