Help - Search - Members - Calendar
Full Version: Konsole For Oz
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
conn-fused
Hi all,

I'm looking for an alternative to opie-console that can handle special characters like the Euro symbol.

I have heard that you can type this symbol (€) with Fn, Shft+4 but that doesn't work on my (US) SL-5500 running OZ 3.5.3 (with the new kernel ... r21?). Nor does Fn, Shft+3 work for the British pound symbol.

I can enter a pound symbol from the handwriting screen (although the Euro symbol doesn't seem to be available ... nor is Yen), but opie-console just displays it as a box.

So, what other consoles (eg konsole) are available, where can I find them, and how can I enter more currency characters?

Thanks.
YoG
just a thought, did you try changing the font in the opie-console? maybe download a new font from the feed?
BTW I tried fn+shift+4 and it locked the keyboard until I rebooted... had anybody that before?
Mickeyl
There's always opie-embeddedkonsole as an alternative.
conn-fused
Thanks for the ideas guys.

I've tried changing the fonts without success, although I've yet to download new fonts. I will try that soon and report my success. But first:

I tried opie-embeddedconsole. It doesn't fix this problem but it's a perfectly acceptable console <i> except that </i> installing it seems to have broken opie-console. Basically, opie-console's window now extends beneath the opie taskbar, so once I've filled the page with text, I loose sight of the last line (normally the command prompt). If anyone reading this thread has seen this before, I'd appreciate suggestions.
YoG
QUOTE
Basically, opie-console's window now extends beneath the opie taskbar


I've encounterd that when I enabled the text wrapping option... once disabled everything returned to normal...

Yog.
conn-fused
You're right that the line-wrap option is involved. If I disable line-wrap opie-console stays in its window, but - as you'd expect - long commands are more difficult this way.

Building on what you suggested I found that if I disable line-wrap, rotate the screen (from the Opie Menu), rotate it back, and the enable line-wrap, I get the best of both worlds (line-wrap & a proper window). But it is a nuisance having to do that when, before, it "just worked". Still, thanks for the work-around.

Edit: Turns out you can just rotate the display and rotate it back, without disabling and re-enabling line-wrap. It's as if the window's dimensions are set incorrectly the first time, but not subsequently.
lardman
You might find the other terminal app tries writing its settings to the same file. Although you've got it fixed now, I'd do an 'ls -a ~/' and see if you can work out which is the file in question.


Si
conn-fused
QUOTE(lardman @ Jan 2 2006, 10:47 AM)
You might find the other terminal app tries writing its settings to the same file. Although you've got it fixed now, I'd do an 'ls -a ~/' and see if you can work out which is the file in question.


Si
*



The file you're thinking of is probably ~/Settings/opie-console-profiles.conf. That was the only file revealed by "find ~ -name *kons*" and "find ~ -name *cons*". It reads as follows:

[default]
Color = 1
Command = /bin/sh
Echo = 1
EnvVars = 0
Font = fixed
FontCharset = iso10646-1
FontSize = 7
FontStyle = Regular
Inbound = 1
Outbound = 1
Terminal = 3
Wrap = 1
autoConnect = 1
back = 0
fore = 3
ioplayer = console
key_cols = 10
keb_r0c0 = Enter|enter|4101|0
keb_r0c1 = Space|space32|32
keb_r0c10 = Pd||4119|0
keb_r0c11 = Esc||4096|4095
keb_r0c2 = Tab|tab|4097|0
keb_r0c3 = Up|ip|4115|0
keb_r0c4 = Down|down|4117|0
keb_r0c5 = ||0|0
keb_r0c7 = Ho||4112|0
keb_r0c8 = End||4113|0
keb_r0c9 = Pu||4118|0
keb_r1c0 = F1||4144|0
keb_r1c1 = F2||4145|0
keb_r1c2 = F3||4146|0
keb_r1c3 = F4||4147|0
keb_r1c4 = F5||4148|0
keb_r1c5 = F6||4149|0
keb_r1c6 = F7||4150|0
keb_r1c7 = F8||4151|0
keb_r1c8 = F9||4152|0
keb_r1c9 = F10||4153|0
keb_rows = 2
name = default
term = default
terminal = 0

Now, does anyone have that file from a clean installation of opie-console so I can do a diff? Thanks.
conn-fused
It would seem that rebooting the Zaurus (a couple times?) rectifies this problem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.