Help - Search - Members - Calendar
Full Version: G-rom And Usbnet
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Guylhem Rom
speculatrix
does anyone have usb networking working on G-ROM?

I ask because when I plug my Z 6000 into my laptop I don't end up with usbdnet0 or usb0 interfaces!

I know it's not my PC because when I plug in my 860, usb networking comes up just fine (kernel 2.6.14 on the pc linux)

the net.usb.local or net.usb.remote scripts fail with no such interface etc.

I've been coping over modules from one to the other, but this is tedious guess work, and might not work if the 860's kernel (Maslovsky's cacko 1.23) has got stuff compiled in and not as modules.

thanks
Paul
lardman
If you're using the 2.4.xx kernel then the module should be called net_fd.o; try modprobing it and see if that works.

Si
speculatrix
QUOTE(lardman @ Jan 3 2006, 12:34 AM)
If you're using the 2.4.xx kernel then the module should be called net_fd.o; try modprobing it and see if that works.

Si
*


nope.. .I copied over usbnet.o from a kernel built from G's 6000 sources, and insmod'ded it, and nothing. The PC end doesn't even see the Z on the USB bus at the moment (I rebooted the Z 'cos I'd been doing all manner of sh^Htuff to it so a clean start seemed best).

hmm.

time for bed, I will try again soon. damn, it's midnight!
lardman
QUOTE
nope.. .I copied over usbnet.o from a kernel built from G's 6000 sources, and insmod'ded it, and nothing.


I said net_fd.o .....


Si
speculatrix
QUOTE(lardman @ Jan 3 2006, 06:35 PM)
QUOTE
nope.. .I copied over usbnet.o from a kernel built from G's 6000 sources, and insmod'ded it, and nothing.


I said net_fd.o .....


Si
*



sorry, I should have made myself clear.. I already had a net_fd.o and insmod'd it, but no joy, hence I tried usbnet.o too.
lardman
Ah, okay.

Was it already loaded? If not you need to remove storage_fd.o or net_fd.o then usbdcore.o then pxa_bi in that order.

Then modprobing net_fd.o should load the usbdcore and pxa_bi, otherwise just load them in the reverse order and see what happens.


Si
powers
QUOTE(speculatrix @ Jan 2 2006, 10:44 PM)
does anyone have usb networking working on G-ROM?

I ask because when I plug my Z 6000 into my laptop I don't end up with usbdnet0 or usb0 interfaces!

I know it's not my PC because when I plug in my 860, usb networking comes up just fine (kernel 2.6.14 on the pc linux)

the net.usb.local or net.usb.remote scripts fail with no such interface etc.

I've been coping over modules from one to the other, but this is tedious guess work, and might not work if the 860's kernel (Maslovsky's cacko 1.23) has got stuff compiled in and not as modules.

thanks
Paul
*


I was able to get usb networking to work by typing.

usbd.net usbd0

And then to turn it off.

usbctl off 0

Bill
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.