Help - Search - Members - Calendar
Full Version: Some Problems With My Z(c-1000)[solved]
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
urielka
i upgraded to Beta1 and then i saw that i have a small root partiton so i resize it and reinstall it all by the instructions.
but now i can`t start X and i get a bunch of messages about libXext.so.6
and i get something alot messages about magic bitmask 0x1985 not found in ....
all this in boot time.
and i get something about:
ld.so: dynamic-link.h : 74:elf_get_dynamic_info:Assertion '! "bad dynamic tag" failed!
when i try to start Xserver.
is there any way to do a super hard reset like doing a mke2fs to root?
coz when i flash the new rom it doesn`t erase it,it just write over it(as far as i see).
plz help me
pgas
did you check the md5sums of the file you have downloaded?
Did you apply the nand fix to have your root partition >64mb?


QUOTE
is there any way to do a super hard reset like doing a mke2fs to root?

make a nand restore with the orignal rom?
urielka
how i do a nand restore with original rom?
and yep i have done all that stuff and the first time that i flashed from rc12 to beta1 it worked ok(except kde didn`t work ok).
pgas
see "In case a backup won't work !"
here:
http://www.trisoft.de/en_c1000howto.htm
urielka
can you give my the instruction for Chinise C1000(i mean the diagnostic menu is in Chinsie).
urielka
ok it is in englush and it is amazing:)
i think it is the most hackable pda in the world
urielka
it saying that the CF could not be initalized.
i formated my CF as ext2,do i need it to be FAT32(vfat)?
pgas
QUOTE
do i need it to be FAT32(vfat)?

yes, Fat16 in fact if I remember well
urielka
how i do that in linux?
urielka
i erased the NAND (mistake of mine) and now i can only get to the Diagnostic menu.
so can i still use the NAND backup to fix everything?
by the way which rom i will have after the NAND backup,SHARP ROM?
TheWalt
Don't feel bad, I did almost the exact same series of events when I first got my SL-C860 many months ago.

As long as you can get in the diag menu you can still do the nand restore (and the file provided in the previous link will put you back to sqaure 1 with the factory japan rom).

The SD or CompactFlash needs to be formatted FAT, unfortunatly I can't tell you how to do that on a linux machine. Once you have it formatted fat and copy the nand backup file to it (I bought a cheap multi reader from BestBuy to accomplish this) just follow the prompts and let it restore (it will take a LONG time compared to flashing so let it sit).

Once it is done you should be able to reboot and it will prompt you with all the same screens that it did the day you bought it smile.gif
urielka
it still say that the CF could not be initalized.
i formated my card(CF kingston 2GB x50) as FAT16.
can it handle a 2GB card?
can i do this with a SD card also(got a 1GB)
urielka
i made it!!! it is flashing now from sd card i guess my CF i card i too big smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.