ok..
so i've been trying to get wireless working on pdaxrom for a long time now..and keep having problems..
my setup
3100: cacko 1.23
6000: beta1

on the 3100 w/ the cacko rom i can use wireless on my planex/io-data right out the the box.. (low-power sandisk doesn't work)
i want to be able to do everything from the command line so in cacko i have to type
CODE
cardctl scheme CardResume

for it to work..
if i type
CODE
cardctl scheme my-created-wifi-scheme

it wont work.. iwconfig will show wlan0 up but with much less detailed info and i can't manipulate anything.. (ie. iwconfig wlan0 mode monitor, etc..)

whats weird is that when i run "cardctl scheme my-wifi" it says it downloads the firmware into the card's RAM just fine but doesn't work.. but when i run "cardctl scheme CardResume" i get massive errors but it works....

So on pdaxrom beta 1 on my 6000 i can get it to bind to hostap but i get "operation prohibited" when i try to change anything.. and no luck with changing cardctl at all =(
Has anyone else gotten wireless to work for them? 6000 bug??

I read in other forums that i have to upload firmware for the PLANEX card but when i run
CODE
prism2_srec -gs wlan0 /etc/firmware/pm010102.hex

i get
CODE
Verifying update compatibility and combining data:
Failed to parse 'pci' or 'sram_type' from /proc/net/hostap/wlan0/debug
Incompatible update data.

i remember i was able to do this with my sandisk wlan with rc10..
i wonder why this happens now.. it seems other people have this problem too..


so to clarify something..
Do ALL wifi cards need firmware to be uploaded to RAM (always the pm010102.hex & rfxxx.hex??) (I thought the sandisk was different b/c it was the only one that gave problems b/c you had to manually upload firmware)

any help is very appreciated..thanks..