Help - Search - Members - Calendar
Full Version: Sl-5500 Post Installation Issues
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
sentinel
Hi,

This may have been covered before, but I could'nt seem to figure it out from previous posts.

The question is once the device has been successfully flashed, which are the packages that contain the necessary system tools / applications.

The main system is 'barebones', but I am unusre which packages to install first.


Thanks
Neil.
pgas
can you do "startx"?

maybe install the packagemanager?

you can see the installed packages using
"ipkg status" in the command line
sentinel
Yes, I can do 'startx' and bring up a window.

My main problem is that I don't have a wireless CF card, so I need to flash off an old FAT16 formatted card that the zaurus likes, then use another CF card which I formatted as ext2 to hold additional packages, ec...

I need to get the networking sorted out so that I can transfer data accross. Then hopefully I do some useful things on it. However, I can't assign an IP address to usb0.

Do I need to install the usbdconfig package to do this ?

Thanks
sentinel
Following on from the thread below, I was attempting to install packages from the terminal using the ipkg command.

I installed 'usbdconfig' & 'packagemanager' - however, when I attempted to launch them (after rebooting the system) nothing happens, apart from a 'busy' cursor for 10 seconds or so.....

I've read all the notes / posts I can find, but really can't figure out what is going on here.....

Any suggestions.

Rgds
Neil.
pgas
hmm, maybe you didn't install the dependancies?
packagemanager requires qt-mt.
usbdconfig is a python application and requires python, the gtk bindings etc...

try to run the application in a console (aterm) to see if you get any error message.

I 'll try to find out what is required to do to set the usb network without the gui.
sentinel
I see what you mean about the dependencies.

Assuming I can get the usb networking working (I still haven't figured this out yet), has anybody got an idea of the important packages to install to get the GUI configuration working ?

Previous posts do not go into this in any great detail, and it is kind of trial and error, unless you already know what the packages are.

If I can figure this out, I should be able to move /usr onto my CF card.
pgas
you need the hotplug package.

here is what usbdconfig does:
it writes something like:
CODE
IP=192.168.129.201
NETMASK=255.255.255.0
DHCPS=no
DHCPC=no

in /etc/hotplug/usbdnet.conf

it removes /etc/hotplug/usbdstorage.conf

it calls
CODE
/etc/usbcontrol net


you can install the package on a card using the -d option like
CODE
ipkg -d /mnt/card install hotplug...ipk


more info on package http://mail.pdaxrom.org/contrib/docs/ipk.txt
sentinel
Hi,

I tried to follow these steps, but can't seem to get the USB Networking sorted out. I can't even ping the Zaurus from my Mac. (I have the OSX drivers installed, and could previously make a SSH connection to the Zaurus running the TKC Rom).

Looking through the package list, it seems that Hotplug is installed with the base system when it is flashed.

I changed the settings in usbdnet.conf, but could'nt locate any file named usbdstorage.conf (there is a file called usbdstorage.agent) - so I launched /etc/usbcontrol net in the background, but this did not allow me to connect or ping the Z.


Therefore, I decided to just try and install USBconfig and see if this would sort it out - I installed Python, and numerous other dependency modules before I was allowed to install usbdconfig to the cf card. However, this still would not work.

When I tried to launch usbconfig from the Terminal, it spits the following errors:

(usbfunction.py:8980): Gdk-WARNING **: Error converting from UTF-8 to STRING: Conversion from character set 'UTF-8' to ISO-8559-1 is not supported.

The error is traced back to:

File "/usr/bin/usbfunction.py", line 11, in usbconfig
f=open("/proc/deviceinfo/product", "r")
IOError: [Errno 2] No such fule or directory '/proc/deviceinfo/product'


I'm lost............


Having said that, now that I've managed to get a lot of the additional packages onto my Z, I've got to say that this looks very good - I'm very impressed being able to able to run gVim.

I managed to figure out from the Filelist in the feed where most of the packages I needed are. However, I could'nt find out where the 'less' utility is located. Is it supported, and if so, does anyone know which package it is located in ?

Thanks
Neil.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.