Help - Search - Members - Calendar
Full Version: Tube Map - Metromap Runs!
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
iamasmith
Wow, I was putting my SL-C3000 through it's paces.

I'm running a proof of concept pdaXrom environment using /dev/hda1 as a single root file system pivot rooted off the flash partition. So far things are looking great.

I was looking around for software to replace my Qtopia stuff and came across http://metromap.antex.ru/

This package is a regular python package and requires no compilation whatsoever, simply install the full version of Python from the pdaXrom feed and you can run this straight from the directory that you unpacked it (or you can choose to make install which copies stuff to relevant locations on your machine).

You need to Alt-Drag around and it's not the snappiest of things on a Z but apart from that it runs fairly well smile.gif
ZDevil
It's a good start. I do miss Metro on Palm a lot (http://chotto.free.fr/tatami/Metro/MetroA-en.html ) This one doesn't offer that many maps. It's a big pity as Metro is already available for PalmOS, PocketPC, MS Smartphone, Symbian UIQ/SonyEricsson, Symbian S60/Nokia, Symbian S80/Nokia, Symbian S90/Nokia, but no linux!
desertrat
QUOTE(ZDevil @ Jan 11 2006, 05:50 PM)
It's a good start.  I do miss Metro on Palm a lot (http://chotto.free.fr/tatami/Metro/MetroA-en.html )  This one doesn't offer that many maps.  It's a big pity as Metro is already available for PalmOS, PocketPC, MS Smartphone, Symbian UIQ/SonyEricsson, Symbian S60/Nokia, Symbian S80/Nokia, Symbian S90/Nokia, but no linux!
*


Metro is great - tons of maps. But one thing it's lacking is graphical maps. Metromap seems to be similar to TubeRoute that I used to use on my Psion.

Anyway when I run Metromap I get this:

CODE
# ./metromap.py
Traceback (most recent call last):
 File "./metromap.py", line 3, in ?
   import pygtk
 File "/home/sash/Work/Akita/pdaXrom-builder/build/pygtk-2.5.3/ipkg_tmp/usr/lib/python2.4/site-packages/pygtk.py", line 22, in ?
ImportError: No module named fnmatch


Any idea which package I need to install to get the "fnmatch" module?

-- cheers
pgas
search the forum?
http://www.oesf.org/forums/index.php?act=S...ighlite=fnmatch
desertrat
QUOTE(pgas @ Jan 11 2006, 09:05 PM)


Sorry, I thought I had practiced due diligence by searching the official python docs before asking dry.gif

To save others some legwork these are the required packages:

python-shell_2.4.1_armv5tel.ipk (fnmatch)
python-compression_2.4.1_armv5tel.ipk (zipfile)


-- cheers
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.