Help - Search - Members - Calendar
Full Version: Wellenreiter & Aircrack Ported To Pdaxrom
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
jerrybme
Well, I managed to get my first app compiled for pdaxrom, thanks to lots of help from mickeyl on #oe and pgas for compiling the qt dev files.

It's working on my Z, requires libpcap amd qt-mt. Of course, YMMV

It's my first ipk so expect errors wink.gif

Cheers,

Jerry

**Update**
Here's aircrack, see the aircrack-README.html in /usr/local/bin after you install. Not sure what the dependencies are besides libpcap.

***2nd Update***
Added updated wellenreiter ipk, new has .desktop file for menu & is stripped to make it smaller (by 1/3!)

**and again ! *** Sorry, the directory structure was wrong in previous 2 wellenreiter ipks, v3 is current. Sorry about that, but I said to expect errors rolleyes.gif

**One more time** current versions are V4 for wellenreiter & V2 for aircrack, see post below for details.

***aircrack updated to 2.41**
trichmon
Works great, after i installed qt-mt (which i found some place in the forums here). I get some errors about not finding icons when it starts up but it works great with my 6000l.

You Rock!

Todd
Yoru
What is YMMV? Srry but I am new with Zaurus

Thanks in advance!
chris08
Hi and welcome to the pdaXrom community!
QUOTE(Yoru @ Feb 7 2006, 02:41 AM)
What is YMMV? Srry but I am new with Zaurus
*

YMMV is short for "your milage may vary" take a look at this article on wikipedia.

Cheers from Berlin
chris
jerrybme
QUOTE(trichmon @ Feb 6 2006, 11:54 PM)
Works great, after i installed qt-mt (which i found some place in the forums here).  I get some errors about not finding icons when it starts up but it works great with my 6000l. 
*


Which icons is it complaining about? I'll try and add them to the ipk, thanks for the reminder about qt-mt.

Cheers,
Jerry
anunakin
QUOTE(jerrybme @ Feb 7 2006, 04:37 PM)
QUOTE(trichmon @ Feb 6 2006, 11:54 PM)
Works great, after i installed qt-mt (which i found some place in the forums here).  I get some errors about not finding icons when it starts up but it works great with my 6000l. 
*


Which icons is it complaining about? I'll try and add them to the ipk, thanks for the reminder about qt-mt.

Cheers,
Jerry
*



use --prefix=/usr this fixes some icons problems when build ipks!

We need /usr/share/pixmaps/icon48x48.png and /usr/share/applications/programname.desktop to icon works

ANd thanks for compile aircrack
jerrybme
QUOTE(anunakin @ Feb 7 2006, 12:56 PM)
We need /usr/share/pixmaps/icon48x48.png and /usr/share/applications/programname.desktop to icon works

ANd thanks for compile aircrack
*


You're welcome, updated ipk to include the desktop file & icon
trichmon
I cant seem to get the new ipk downloaded. I get a forum error that says it can't find the file.

Todd
Deviant25
hey while ur at it, is it possible you can do this http://www.oesf.org/forums/index.php?showtopic=16974
scheck.r
Great ! No more complaints about missing icons.
However, it appears as "ellenreiter" instead of "wellenreiter" in the package manager so that I can't remove version 1.

How do I remove version 1 from the command line ?
trichmon
I have the same issue, cant use the package manager and cant seem to get ipkg to remove it at the cli.

Todd
jerrybme
QUOTE(scheck.r @ Feb 7 2006, 05:35 PM)
Great ! No more complaints about missing icons.
However, it appears as "ellenreiter" instead of "wellenreiter" in the package manager so that I can't remove version 1.

How do I remove version 1 from the command line ?
*

I was mistaken when I created the ipk that it would by default install in /usr/local. Instead it was installed at the root, /

So, you'll need to delete /bin/wellenreiter, /share (but check to make sure there are no other needed files there, if it only contains a directory, wellenreiter, then the entire dir can be removed, /lib/libwellenreiter* (there will be several symlinks and one real file that start with libwellenreiter).

Once you've removed those files, you'll need to run
CODE
source /etc/profile
, then you'll be able to run the more recent version.

One other issue, is the config file is not being created, so any custom config is lost after the session. Still working on this one.

Cheers,
Jerry
silencer51
There seems to be a mixup with the package names.

Wellenreiter V3 installs correctly through the command line but when ipkg-link tries to create the symlinks (i installed to /mnt/ide2 which is ext2 formatted) it says it can't find the package "wellenreiterII".

I got the same error with aircrack and I managed to link it using "ipkg-link add Aircrack" (it needs a capital A, got it from the control file inside the ipk).

However, I can't get ipkg-link to work with wellenreiter v3. Any ideas?
jerrybme
QUOTE(silencer51 @ Feb 8 2006, 07:36 AM)
There seems to be a mixup with the package names.

Wellenreiter V3 installs correctly through the command line but when ipkg-link tries to create the symlinks (i installed to /mnt/ide2 which is ext2 formatted) it says it can't find the package "wellenreiterII".

I got the same error with aircrack and I managed to link it using "ipkg-link add Aircrack" (it needs a capital A, got it from the control file inside the ipk).

However, I can't get ipkg-link to work with wellenreiter v3. Any ideas?
*

Well it turns out there were several issues, ipkg is very picky about the contents of the control file. I'm still learning, I've updated it once again so that capitalization & spaces are the same. I've updated both files. That should fix the ipkg-link issue with wellenreiter.

In the future, I'll not be so excited to post ports without testing them first. I was just so excited that I got them to compile & work, I didn't test the installation process. blink.gif I'm so used to using the command line to install I han't tried either using the ipkg manager nor installing to external media, both of the current versions have now been so tested by me. That of course, doesn't mean there won't be issues....

Cheers,

Jerry
jerrybme
QUOTE(Deviant25 @ Feb 7 2006, 05:10 PM)
hey while ur at it, is it possible you can do this http://www.oesf.org/forums/index.php?showtopic=16974
*

blink.gif em, no I compiled the newer version of aircrack...
Deviant25
but isnt the one in my post 2.41, compared to 2.40? blink.gif
silencer51
Thanks for the packages, jerrybme!

Now if someone could tell me where I can find qt-mt and libpcap... the search function is owned.
scheck.r
QUOTE(silencer51 @ Feb 9 2006, 05:35 PM)
Thanks for the packages, jerrybme!

Now if someone could tell me where I can find qt-mt and libpcap... the search function is owned.
*


qt-mt in the c3100 feed
libpcap at www.pdaxrom.org/unstable
silencer51
Thanks sheck! :-)
jerrybme
QUOTE(Deviant25 @ Feb 8 2006, 06:56 PM)
but isnt the one in my post 2.41, compared to 2.40? blink.gif
*

Ok, I never said I could read wink.gif The differences between the the versions are minor:
Version 2.41 released on 2005-11-22. Changes from version 2.4:

* airodump: show probing clients as "not associated"

* airodump: don't substract the noise level unless madwifi

* airodump: fixed channel hopping with old orinoco

* airmon.sh: added detection of the zd1211 driver
But it is easy to compile so I've updated it to the 2.41 version (I'm getting better at ipk creation - thanks to pgas' suggestion to use mkipk )

Cheers,
Jerry
Yoru
When I try to run wellenreiter from console I have this error:
CODE
wellenreiter: error while loading shared libraries: libpcap.so.0: cannot open shared object file: No such file or directory


When I try to run it tapping on the icon at Internet folder nothing happends.

Where I can found libpcap.so.0? I have installed libpcap-dev_0.8.3-4_arm.ipk and nothing changes
jerrybme
QUOTE(Yoru @ Feb 10 2006, 04:03 AM)
When I try to run wellenreiter from console I have this error:
CODE
wellenreiter: error while loading shared libraries: libpcap.so.0: cannot open shared object file: No such file or directory


When I try to run it tapping on the icon at Internet folder nothing happends.

Where I can found libpcap.so.0? I have installed libpcap-dev_0.8.3-4_arm.ipk and nothing changes
*

You don't need the dev version of libpcap, it has the header files for development. I'd try removing that version and install the regular version you'll find in the pdaxrom.org/unstable (although it really should work with the dev version)

Before you run a scan you need to check the configuration to make sure it's found your wifi card and selected the correct driver.
Yoru
Now I have the same error but with libwellenreiter.so.1, but the file is there!
uMP2k
QUOTE(scheck.r @ Feb 10 2006, 02:32 AM)
QUOTE(silencer51 @ Feb 9 2006, 05:35 PM)
Thanks for the packages, jerrybme!

Now if someone could tell me where I can find qt-mt and libpcap... the search function is owned.
*


qt-mt in the c3100 feed
libpcap at www.pdaxrom.org/unstable
*



Anyone know where I can find these files now - the pdaxrom.org/unstable just gives a page not found and I have not been able to find them in any of the pdaxrom feeds.
fiferboy
It took me a long time to find, but this is the feed you want:

http://zaurus.spy.org/feeds/cacko/pdaXrom/unstable/

It seems to be a mirror of that old site which is no longer available. Wellenreiter works great now that this library is installed!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.